Author Topic: Problem solved:Boot hangs, PIRQ mask error  (Read 2241 times)


  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problem solved:Boot hangs, PIRQ mask error
« on: December 11, 2005, 12:21:49 am »

just trying to install plutohome (.34) for the very first time. I'm using a amd sempron machine (MB: asus a7v600-x) with a minimum of hardware (dvd burner (ide), hdd (samsung sata), onboard sound and network, and one additional network card (realtek something)). It boots with the cd just fine, and installs everything and then reboots. After that I get the grub boot menu and whatever of the two choices the boot process hangs at the same point:

Code: [Select]

shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001
modprobe: FATAL: Error inserting shpchp (/lib.../pci/hotplug/shpchp.ko): Operation not permitted

shpchp: can't be loaded
missing kernel or user mode driver shpchp
ne2k-pci: already loaded
sata_via: already loaded
generic: loaded successfully
VP_IDE: IDE controller at PCI slot 0000:00:0f.1
PCI: IRQ 14 for device 0000:00:0f.1 doesn't match PIRQ mask - try pci=usepirqmask
PCI: setting IRQ 14 as level-triggered

Can somebody please help?

edit: problem solved by adding pci=noacpi pci=usepirqmask at the end of the kernel line in grub (pressing e at the grub bootscreen and then edit the kernel line.). I will edit this permanently in /boot/grub/menu.lst or /boot/grub/grub.conf

kind regards
Tor Helge