Author Topic: can't download shows from mythweb  (Read 846 times)

wout

  • Newbie
  • *
  • Posts: 9
    • View Profile
can't download shows from mythweb
« on: April 28, 2008, 09:10:00 am »
when i try to download a recording from mythweb it says: "3_20080420203500.mpg does not exist in the recordings directory."

How can I make this feature work?

radmofo

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Re: can't download shows from mythweb
« Reply #1 on: June 04, 2008, 01:40:57 pm »
I'm wondering this as well. i think the videos directory is wrong in mythweb. I have to test more.

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Re: can't download shows from mythweb
« Reply #2 on: June 05, 2008, 08:06:32 pm »
I'm wondering this as well. i think the videos directory is wrong in mythweb. I have to test more.

 If you have multiple tuners in different machines, I don't know of an easy way to correct the mythweb error.

 In Mythweb, the directory for the recordings is a symlink in the /var/www/mythweb/data directory.

 /var/www/mythweb/data/recordings -> target_link

 With 7.10 RC2, it's using the default MythTV directory (/var/lib/mythtv/recordings). So that's definitely going to produce the file does not exist error.

 If you only have one machine with tuner cards, you should be able to delete the recordings symlink and create anot1her on the core:

 cd /var/www/mythweb/data
 sudo rm recordings
 sudo ln -s /home/public/data/videos/tv_shows_1 recordings

 In my case, I have a core/hybrid and a md with a tuner card, so my recordings show up in tv_shows_1 and tv_shows_57, not sure how I would make the web download link work for me...


radmofo

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Re: can't download shows from mythweb
« Reply #3 on: June 06, 2008, 12:41:15 pm »
I think it needs to be a function of lmce so its integrated. When lmce uses the latest mythtv build with the new asx streaming engine people will really want this to work I bet.