Author Topic: Using HADesigner: The Screencasts  (Read 11665 times)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #30 on: April 18, 2009, 07:14:08 pm »
You are getting that message because your libpluto_main.so does not match up. the quickest way to make sure this matches up is to copy the contents of /usr/pluto/lib to src/lib and rebuild screengen...

-Thom.

samir

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #31 on: April 21, 2009, 02:26:26 pm »
Hi ,
I am still unsuccessful to compile . Let me explain what I did .
I followed the instruction as described in wiki about setting up the dev environment.I had svn Linuxmce 0710. It was downloaded at home/trunk/.  After I downloaed I saw a directory called lib already in the trunk/src .Inside the trunk it had .svn directory inside and was empty. But according to he instruction on wiki I had to make a lib directory inside the src directory. But I am confused now .
Anyways I copied all the files of /usr/pluto/lib to trunk/src/lib .
I made some changes with HADesinger and added some screens in the Screen table and associated the Design Obj in screen Design obj table .Now as Thom suggested me to make the ScreenGen by using make command . I did so .and when I try to run ./ScreenGen I get error .. "Segmentation fault ".
I tried to follow the wiki instructions on Developement environment about 3 times and installed Linuxmce 3 times..I am no developer or programmer but I try my best. I have  already changed the skin of linuxmce to mine and it works fine though.But I need to add some extra screens for my own purpose .I am not able to do that . Since I had to compile it, something is going wrong.
Please can you explain me step by step , including the compilation of ScreenGen and Orbiter ..

I will be very greatful.

Thanks,
sameer

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #32 on: April 21, 2009, 06:50:31 pm »
I am sorry for the problems you've been having,

I would suggest actually going with 0810.

We are not doing any development work on 0710 anymore, and do not accept any patches on that branch.

svn is here: http://svn.linuxmce.org/branches/LinuxMCE-0810

There is a complete page on building a builder for 0810:
http://wiki.linuxmce.org/index.php/Building_LinuxMCE_0810

Once you've done a full builder pass, you can go into the directory where SVN is stored (/var/lmce-build/svn), and build a copy of ScreenGen that should work fine.

-Thom

samir

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #33 on: April 22, 2009, 04:39:50 am »
Hi,
Thanks for the response. As mention I already have LinuxMCE 0710 installed , and the wiki http://wiki.linuxmce.org/index.php/Building_LinuxMCE_0810 you gave me is for the building in 0810 but I dont have that . So this means I donot have a fresh copy of Kubuntu 0810 . And my kernel is also 2.6.22 as delivered with LINUXMCE -710 dvd . I am very confused here.

Lets make it easy.I have a clean Linux0710 install.
what should I do next ?
bit confused with building from source and Building LinuxMCE-810.
Please provide me the step guidance after installing LinuxMCE0710.
Thanks

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #34 on: April 22, 2009, 07:49:20 am »
Moderated: Unhelpful and negative posts removed, please be aware of tone.

flying

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #35 on: June 13, 2009, 06:28:57 pm »
 ;)I am a newbie to LinuxMCE, I want to customize the Orbiter skin and seems it can be customized. Can anyone help to summarize the steps need to do or point out which post should I refer to? Thanks a lot!

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #36 on: June 13, 2009, 06:47:04 pm »
Please read this post, as well as the other sticky post on the Minimo skin. You will need both of them.

-Thom

flying

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #37 on: June 21, 2009, 01:10:25 pm »
Thom,

Your screencasts really helpful, thanks a lot!

I have question regarding 03_ui2_popup_part_1.ogg, how can you inserted the lmce game plug in code/db level? Or there have related posts to introduce how to add new plug ins?

Thanks,
Eric

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #38 on: June 21, 2009, 04:16:46 pm »
the code is a media plugin, which is located in our SVN:

http://svn.linuxmce.org/svn/branches/LinuxMCE-0810

in src/Game_Plugin
and src/Game_Player

basically, these code bits sit on the core, and on each media director respectively, the plugin handles stream creation and triggering the game player device on each MD appropriately. and the Game Plugin wraps MAME.

The database linkage for these is in the MediaType, and MediaType_DesignObj, and DeviceTemplate_MediaType tables, with the rest being implemented in the Plugin/Player pair. No I have not created screencasts for them.

-Thom

flying

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #39 on: June 24, 2009, 10:37:30 am »
Thom,

basically, these code bits sit on the core, and on each media director respectively
[ERIC] I think Game_Plugin sit on the core, and Game_Player sits on the MD, am I right? And is the following flow correct?

DB<-->DCERouter<-->Game_Player(MD) <--> Game SW
DB<-->DCERouter<-->Game_Plugin <--> Game SW

So there didn't have communication between Game_Plugin and Game_Player, right?

Sorry to bring to you so many questions!


Thanks,
Eric

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #40 on: August 20, 2010, 03:55:06 pm »
Thom,

I cant view 2 of the screencasts, 02_designobj_basics_1.ogg and 04_ui2_popup_part_2.ogg. I've downloaded them twice each.
All the other screencasts work except for those two. Can you pls verify if they are indeed working.

Thanx
Karel

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #41 on: August 20, 2010, 03:58:15 pm »
those are ogg theora movie files. They do indeed work. There are many different players that can play them. Try renaming to .ogv or .ogm

-Thom

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #42 on: August 20, 2010, 04:07:36 pm »
Thom,

Nope didnt work. Its only those two that seem to be the problem.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Using HADesigner: The Screencasts
« Reply #43 on: August 20, 2010, 04:09:22 pm »
then play them with videolan client or something else. Promise, they work.

-Thom

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile