Author Topic: Turning off DHCP screwed up my SAMBA devices (0710 Beta 4)  (Read 1431 times)

erasmix

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Turning off DHCP screwed up my SAMBA devices (0710 Beta 4)
« on: April 24, 2008, 07:41:39 pm »
Hello,

I have a somewhat atypical configuration. My LinuxMCE router is not the center of the network and it has only one network card. I have a large linux box (with a 1.5TB RAID5) that acts as my gateway/router/file/print/internet server. I initially configured MCE to get an IP address using DHCP. This worked fine, until other computers connecting to my network started to get an IP address from LinuxMCE, instead of from my linux server.

So last nitght I went on the web interface Homepage -> Advanced -> Network -> Network Settings and turned of the DHCP server (http://download.erasmix.net/mce/Screenshot-1.png). After I rebooted, none of my WINDOWS shares (I had to mount my linux server directories as SAMBA, since NFS didn't seem to work) showes up. They still exist as devices (http://download.erasmix.net/mce/Screenshot-2.png), but LinuxMCE doesn't show my videos/pictures stored on those devices.

Then I went back and enabled the DHCP server and put back the IP addresses ranges for Pluto and non-Pluto devices. Same result. I cannot see any of my files.

I'm about to wipe my install using RC1, but since I spent quite a bit of time setting up my video and photo devices, I even got the screensaver to show my own photos rather than flicker, if there is a way I can fix it to avoid redoing all the work.

I'd also like to know if I can have Linux MCE not to interfere with my DHCP server with just one network card. I dont plan to connect any devices to the network that the dcerouter needs to be aware of.

Sorry for the lengthy message.

Thanks,

Erasmo.

erasmix

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: Turning off DHCP screwed up my SAMBA devices (0710 Beta 4)
« Reply #1 on: April 24, 2008, 10:27:23 pm »
Update:

I went to the "device tree" and manually entered the IP address for the server that owns the missing shares. After this, my screen server came back (not sure why), and I coud see the device mounted from the shell command line.

Then I ssh'ed into the dcerouter as root and ran:  /usr/pluto/bin/Configure_1768.sh -d my_device_number. This made my other samba share come back online and could see my videos again.

The DHCP server on the router was turned off while I did this.

So my question still, is it OK to disable the DHCP server on the dcerouter? Has anybody tried this?

Thanks,

Erasmo.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Turning off DHCP screwed up my SAMBA devices (0710 Beta 4)
« Reply #2 on: April 24, 2008, 10:54:30 pm »
try typing DHCP into the search on these forums! the answer is no it is not OK to turn it off... it is an integral part of the system... this has been discussed to death... do that and expect it to screw up your system and be prepared to have to hack it to get it working again (or speak to orionsune!), but read first before disabling stuff!

Hint: get a second NIC and sent it up how it was designed... seriously, it'll cost you 10 bucks!

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Turning off DHCP screwed up my SAMBA devices (0710 Beta 4)
« Reply #3 on: April 25, 2008, 12:50:01 am »
After I rebooted, none of my WINDOWS shares (I had to mount my linux server directories as SAMBA, since NFS didn't seem to work) showes up.

Your NFS server needs to be set up a particular way for NFS to work, then the NFS shares need to be manually added via the admin pages.  I've put some notes on: http://wiki.linuxmce.org/index.php/Howto:_Using_Network_Shares

I currently have LMCE 0710 beta 4 using NFS shares from a kubuntu 0710 system and a gentoo ~x86 system.

HTH,
Roy