Author Topic: Suspend to RAM for MDs  (Read 1484 times)

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Suspend to RAM for MDs
« on: April 17, 2008, 12:21:02 am »
I think I lost track of the thread that was discussing this some time ago....

Did this ever get anywhere? I know there were some teething issues, particularly with reliable resuming, but did it ever get sorted out and if so will it be included in RC1 or Release? If not, did anybody log a mantis for it? Clearly Linux can handle it, so I'm assuming its something getting lost in one of the LMCE modules (perhaps state information?)

sambuca

  • Guru
  • ****
  • Posts: 448
    • View Profile
Re: Suspend to RAM for MDs
« Reply #1 on: April 17, 2008, 10:30:11 am »
I put a request in mantis http://mantis.linuxmce.org/view.php?id=3822 when we discussed it last, but there has not been any progress.

I had a pretty reliable setup using 704, where I could press the power button to have the MD suspend to ram and press it again to resume again. It took only a few seconds to resume it. Nice  ;)
I just upgraded to 710, so I haven't had the time to set it up again, but it is high on my to do list. I will of course update the wiki article with my new findings, if any, for 710.

Since it seems the release is pretty close, I wouldn't bet on it being included, but I guess some of the devs should answer that. There still is the issue with LMCE loosing state or whatever as you mention. I have not looked into that.

As Ender points out in the mantis log, the suspend may not work with all hardware, so I suggest that there should be a checkbox or something in the pluto admin screen to enable suspend on a per MD basis.

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: Suspend to RAM for MDs
« Reply #2 on: May 22, 2008, 04:48:18 pm »
I'd say it was essentially not working. It does work but if you leave the machine asleep for more than an hour or so then when it comes back up the core does not respond to the local orbiter. The only reliable fix seems to be a reboot. Even killing and restarting X or killing all the LMCE "screen" processes and restarting does not fix the fault every time.