Author Topic: how to setup mythtv and IR remote under Pluto ?  (Read 4094 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
how to setup mythtv and IR remote under Pluto ?
« on: December 02, 2005, 10:59:26 am »
Hi,

I've working Asus digimatrix remote and it works ok, when in pluto menus. But when in mythtv, navigation is weird, I get multiple wrong  actions on single keypress... I guess the problem lies in me not knowing, how Pluto sends keys to mythtv...

Let me put few assumptions and let me know if I'm wrong :

- is Pluto sending keys to mythtv after remote mapping done - one that is defined in database ?
- does currently Pluto send any keys to mythtv ? If it is, then mythtv shouldn't use its own lircrc, right ?
- there are more entries in remote mapping database and I wonder if I should enter new one for mythtv only, or does it already work also for mythtv ?

Anyone with sucessful remote navigation setup in mythtv ?

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
how to setup mythtv and IR remote under Pluto ?
« Reply #1 on: December 05, 2005, 09:23:15 am »
i have the same problem with lirc and windows MC remote, we know the issues is existing but there no one right now available to fix this.
there are other several issues with lirc navigation, some screens just don't want to work :)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
MythTV almost working completely with remote
« Reply #2 on: December 05, 2005, 06:56:04 pm »
Hello,

I have been playing around with the way Pluto handles Lirc in terms of navigation with MythTV.

I have a hack that is working, but obviously it is likely to not be the correct fix, but it does work.  

I have install a lircrc file in the /root/.mythtv directory, but I have committed out the parts of the files that Pluto also sends.

0-1, Exit, etc. ( I am not infront of the pluto machine to confirm exactly how I have the file set up, but I will post it later)

The only problem that I have noticed is that if you hit select or enter while you are in the orbital screen it also start MythTV which is running in the background.  The fix is to enter MythTV and the exit with the Power button.  

I know this is a low level hack, but it does allow greater control than previously.  I am still testing, but it does not appear to break another modules.

Also, I have just start working with mythtv, so I have not lost any settings do to upgrade yet, but I did find the fix for the can not connect to backend from this link.

newbielink:http://plutohome.com/support/phpbb2/viewtopic.php?t=490 [nonactive]