Author Topic: CM11a gives Exception on serial port  (Read 1468 times)

caiman

  • Veteran
  • ***
  • Posts: 119
    • View Profile
CM11a gives Exception on serial port
« on: April 14, 2008, 09:31:26 pm »
I've been using the new CM11a code from svn happily for a while, but now I am getting a lot of these error messages in the logs (and cannot control lights any more):
Code: [Select]
Exception occured on CM11A's serial port: 0. Sleeping for 5.1 second.

The CM11a is connected via a gc100, but if I stop the CM11a process and run heyu, I can control the CM11a which indicates that the gc100-serial-bridge is working fine.

Any idea ?

cobradevil

  • Regular Poster
  • **
  • Posts: 48
    • View Profile
Re: CM11a gives Exception on serial port
« Reply #1 on: April 15, 2008, 09:03:30 pm »
please search the forums before opening a new topic!

there are a few problems with the current releases.

take a look at:

http://forum.linuxmce.org/index.php?topic=4456.0


caiman

  • Veteran
  • ***
  • Posts: 119
    • View Profile
Re: CM11a gives Exception on serial port
« Reply #2 on: April 15, 2008, 09:22:03 pm »
Hi William,

thanks for your answer. For sure, I do search the forums. In this particular case, I have been following the issues with CM11a for about two years in pluto. And in particular the topic you mention.

The issue I am referring to is not the 0x05 checksum error, but a new problem I am reporting here happens with the latest sources, which - unless I am mistaken - contain the fix from jondecker76.

A search in the forums for "Exception occured" does not lead any result, and I have read all CM11a threads I could find. So I opened a new thread because it is a different issue. Sorry, professional bias ;-)
Maybe I am missing something ? Any suggestion is welcome.

thanks,
Sam

nosilla99

  • Veteran
  • ***
  • Posts: 120
    • View Profile
Re: CM11a gives Exception on serial port
« Reply #3 on: April 15, 2008, 10:03:56 pm »
@caiman,

I have never seen this error before, as the svn trunks are currently being merged can I recommend that you download the source and rebuild from the following ticket and follow the instructions http://svn.charonmedia.com/trac.cgi/ticket/8

Let us know if this fixes the problem

NOS

caiman

  • Veteran
  • ***
  • Posts: 119
    • View Profile
Re: CM11a gives Exception on serial port
« Reply #4 on: April 15, 2008, 11:31:33 pm »
Thanks a lot NOS... I've re-installed with the trac ticket and was still getting the same problem... Checking the source I found that the serial port was not supposed to say "0" but a full string with the serial device. So it had to be wrong and guess what, the port was not set in the web admin any more :-)
No idea why it has been de-configured, but that's another story. Thanks !

cobradevil

  • Regular Poster
  • **
  • Posts: 48
    • View Profile
Re: CM11a gives Exception on serial port
« Reply #5 on: April 16, 2008, 07:12:16 am »
Not a whole new story.

I had the same problem when using the lmce 0710 beta 3.
after upgrading to the latest patches/sources from jondecker i did not have that issue any more.

if you have lmce beta 3 try my suggestion in the topic :
http://forum.linuxmce.org/index.php?topic=4456.msg26203#msg26203

which was succesfull for beta3 possible it works also in beta 4!

With kind regards,

William van de Velde