Author Topic: iMON PAD + LCD on Thermaltake DH101  (Read 4806 times)

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
iMON PAD + LCD on Thermaltake DH101
« on: April 14, 2008, 01:49:34 pm »
Hi All,

I got this case (Thermaltake DH101) and with it came the iMON PAD and LCD. I have LMCE 710b4 installed and everything, but i can't seem to get the remote to work.

Here are all the links that I have tried, and none of them worked:
http://smart-home-blog.com/writes/configure-imon-padvfd-in-plutohome
http://venky.ws/projects/imon/#lirc
http://brakemeier.de/electronics/vdr/lirc-imon.html
http://img-fotki.yandex.ru/get/4/frezza.0/0_1f74_101d2e86_XL.jpg
http://wiki.linuxmce.org/index.php/Adding_iMON_PAD
http://lirc.sourceforge.net/software/snapshots/
http://www.jonobacon.org/?p=579
http://mythtv.org/wiki/index.php/LCDproc


http://mythtv.org/wiki/index.php/Imon

http://venky.ws/forums/viewtopic.php?f=2&t=279&st=0&sk=t&sd=a

libtool (1.5.22-4 in my repository)
automake1.9
autoconf2.13 (there is a higher version, but select this one)
cvs (1:1.12.13-3)
dialog <------------ missed this one



sudo apt-get install dialog
sudo apt-get install build-essential linux-headers-`uname -r`
sudo apt-get install lirc
tar xvjf lirc-0.8 3pre1.tar.bz2
CD lirc-0.8.3pre1
patch -p1 < ../lirc-0.8.3pre1-imon-pad2keys.patch
./configure
make
sudo make install

mknod /dev/lirc c 61 0

mknod -m 666 /dev/lcd0 c 180 144
modprobe lirc_dev
modprobe lirc_imon
lircd
echo "Hello" > /dev/lcd0

iMON LCD
http://www.mythtv.org/wiki/index.php/LCDproc
Followed the above wiki, only I didn't copy and alter the init file for lcdproc to start on boot, instead:
- sudo crontab -e
and add the line
- @reboot /usr/local/sbin/LCDd -c /home/mythtv/lcd/LCDd.conf

http://codeka.com/forums/viewtopic.php?f=3&t=22

modprobe lirc_imon
ls /dev/lcd0
echo "Hallo Welt" > /dev/lcd0


could anyone plz help ... thanks all

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #1 on: April 14, 2008, 02:40:09 pm »
Is it only the remote you cannot get working? did you successfully echo to the vfd screen?

Did you get any errors during the lirc compile?

What I did was to set up my imon remote in LMCE admin first before compiling the patched version in the konsole / KDE.

in the admin page go to devices (top task bar) and create new template
then on template page add soundgraph as manufacturer, then lirc remote as category and add new template name, call it imonpad (its a simple device like remote controls, so that box should be ticked)

now you can reload router and check to see if the device has been added -> at the foot of the list on the left of the admin home page click show devices tree. Then in the scroll down box see if imon pad is at the bottom.

If it is then go back to the home page, click media directors and next to remotes click add and select imonpad. then next to infrared recievers click 'default'.

Now you need to go into kde and compile lirc with the pad2keys patch


Code: [Select]
sudo apt-get install dialog
sudo apt-get install libtool
sudo apt-get install automake
sudo apt-get install autoconf
sudo apt-get install cvs
cvs -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc login
cvs -z8 -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc co lirc
cd lirc
cvs update
lirc-0.8.3pre1-imon-pad2keys.patch
tar xvjf lirc-0.8.3pre1.tar.bz2
patch -p1 < lirc-0.8.3pre1-imon-pad2keys.patch
./autogen.sh
./setup.sh

select imonpad/vfd from the usb devices list and save and run configure

Code: [Select]
make
sudo make install
sudo modprobe lirc_dev
sudo modprobe lirc_imon


Once thats done you can copy the lircd.conf from the plutohome site (http://smart-home-blog.com/writes/configure-imon-padvfd-in-plutohome) and place it in /etc in place of the current lircd.conf. You also need to re-enter lmce admin, go to your imonpad device template and click 'view'next to the device name. About half way down the page there is a section for device data (i think thats the name) you need to click add and choose configuration. Then in the first box type lircd.conf and the second box copy the contents of your lircd.conf. Save and reload router.

The remote should work now.


Then the vfd display - in konsole:

Code: [Select]
cvs -d:pserver:anonymous@lcdproc.cvs.sourceforge.net:/cvsroot/lcdproc login
hit enter for password
Code: [Select]
cvs -d:pserver:anonymous@lcdproc.cvs.sourceforge.net:/cvsroot/lcdproc checkout -r stable-0-5-x lcdproc
cd lcdproc
cvs update -d
sh autogen.sh
./configure --enable-drivers=all
make
cd shared
make
cd ../server
make
sudo make install
sudo modprobe lirc_imon
sudo chmod 666 /dev/lcd0
echo "Hello MythTV and good morning"> /dev/lcd0

you should get the echoed message on the vfd

tell it to start on boot

Code: [Select]
sudo crontab -e
and add the line
Code: [Select]
@reboot /usr/local/sbin/LCDd -c <PATH TO> LCDd.conf

Put the directory for you LCDd.conf after the -c bit. The file is in the lcdproc folder in your home directory. You need to modify the LCDd.conf file such that it specifies the imon.so driver driectory

I posted some info at the end of this thread about the LCD.conf mod and a LMCE driver to display some info on you vfd ->
 http://forum.linuxmce.org/index.php?topic=3297.0


Sorry if this is a bit confusing - i'm doing this from memory. Let me know how it goes.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #2 on: April 14, 2008, 02:58:13 pm »
gazlang: thanks for the reply, will give it a try and tell you how it went :)

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #3 on: April 14, 2008, 06:20:35 pm »
gazlang:

these lines do not work:

lirc-0.8.3pre1-imon-pad2keys.patch
tar xvjf lirc-0.8.3pre1.tar.bz2
patch -p1 < lirc-0.8.3pre1-imon-pad2keys.patch


see, we got the cvs, but the first line of the three means what? and where is lirc-0.8.3pre1.tar.bz2? its not located anywhere?

thanks for ur help, its realy appreciated

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #4 on: April 14, 2008, 06:55:29 pm »
well, i tried it and this is the eror log that i get:
Code: [Select]
========== NEW LOG SECTION ==========1
04/14/08 17:49:22 37 (spawning-device) Starting... 501
04/14/08 17:49:22 37 (spawning-device) Found /usr/pluto/bin/LIRC_DCE05
04/14/08 17:49:22.627 Connection for client socket reported NEED RELOAD IP=127.0.0.1, device 37 last error 2 <0x2ae22aefa910>05
04/14/08 17:49:22.628 The router must be reloaded before this device is fully functional <0x2ae22aefa910>05
04/14/08 17:49:22.632 void ClientSocket::Disconnect() on this socket: 0x63a9d0 (m_Socket: 5) <0x2ae22aefa910>05
04/14/08 17:49:22.679 Connection for client socket reported NEED RELOAD IP=127.0.0.1, device 37 last error 2 <0x2ae22aefa910>01
04/14/08 17:49:22.806 No SerialPort selected and no default entry found. Exiting. <0x2ae22aefa910>Return code: 13
04/14/08 17:49:22 37 (spawning-device) Device died... count=50/50 dev=37Mon Apr 14 17:49:22 EET 2008 died3
04/14/08 17:49:32 37 (spawning-device) Aborting restart of device 37...

this has always been the error, something to do with 'default' ???

Note: i did reload the router

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #5 on: April 14, 2008, 08:08:34 pm »
Now I get this error:
Code: [Select]
========== NEW LOG SECTION ==========
1 04/14/08 20:06:05 48 (spawning-device) Starting... 7
1 04/14/08 20:06:05 48 (spawning-device) Found /usr/pluto/bin/LIRC_DCE
05 04/14/08 20:06:05.549 Creating Leeching Thread for 1 remotes <0x2b827e909910>
05 04/14/08 20:06:05.551 Creating child 49 <0x2b827e909910>
05 04/14/08 20:06:05.551 Note: Device manager has attached a device of type 1911 that this has no custom event handler for.  It will not fire events. <0x2b827e909910>
05 04/14/08 20:06:05.551 Note: Device manager has attached a device of type 1911 that this has no custom handler for.  This is normal for IR. <0x2b827e909910>
05 04/14/08 20:06:05.553 Lost connection with lircd <0x40800950>
Return code: 255
3 04/14/08 20:06:05 48 (spawning-device) Device died... count=7/50 dev=48
Mon Apr 14 20:06:05 EET 2008 died
========== NEW LOG SECTION ==========
1 04/14/08 20:06:15 48 (spawning-device) Starting... 8
1 04/14/08 20:06:15 48 (spawning-device) Found /usr/pluto/bin/LIRC_DCE
05 04/14/08 20:06:15.881 Creating Leeching Thread for 1 remotes <0x2b7424840910>
05 04/14/08 20:06:15.885 Lost connection with lircd <0x40800950>
Return code: 255
3 04/14/08 20:06:15 48 (spawning-device) Device died... count=8/50 dev=48


megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #6 on: April 14, 2008, 08:52:12 pm »
Now i get this error:
Code: [Select]
========== NEW LOG SECTION ==========
1 04/14/08 20:47:07 48 (spawning-device) Starting... 4
1 04/14/08 20:47:07 48 (spawning-device) Found /usr/pluto/bin/LIRC_DCE
01 04/14/08 20:47:07.644 No SerialPort selected and no default entry found. Exiting. <0x2abe72c15910>
Return code: 1

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #7 on: April 15, 2008, 10:39:31 am »
well the patch is on the berlios webpage -> http://brakemeier.de/electronics/vdr/lirc-imon.html

sorry, i didn't specify that you needed to download that.

download the patch and copy it into your lirc folder. then run the commands:

lirc-0.8.3pre1-imon-pad2keys.patch

etc...

looks like lmce cant find the imon device. re-try after a reboot, and check that the imon vfd is connected to a usb port and power as per the imon manual.

Also, try looking at the imonpad device on lmce admin and where it says something like 'communicate via' select usb
« Last Edit: April 15, 2008, 02:06:30 pm by gazlang »
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #8 on: April 15, 2008, 02:14:43 pm »
Actually, looking at the model you have, my lcdproc setup won't work for you. I have the thermaltake bach case which has a simple vfd screen rather than lcd.
this page: http://codeka.com/blogs/index.php/dean?cat=30 has info on getting the lcd to work.

Looking at the remote also, it differs cosmetically to the standard imon pad (pictured here -> http://wiki.linuxmce.org/index.php/IMON_PAD) and don't know whether it sends the same codes. Just see how you go with my last post.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

megacrypto

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #9 on: April 15, 2008, 05:23:52 pm »
As far as the patch goesi have the patch, but what i dont understand is why to get the cvs which will not be used

tar xvjf lirc-0.8.3pre1.tar.bz2

when i followed the steps, first we downloaded the cvs:

Code: [Select]
sudo apt-get install dialog
sudo apt-get install libtool
sudo apt-get install automake
sudo apt-get install autoconf
sudo apt-get install cvs
cvs -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc login
cvs -z8 -d:pserver:anonymous@lirc.cvs.sourceforge.net:/cvsroot/lirc co lirc

Then we move into the lirc dir and update the cvs:

Code: [Select]
cd lirc
cvs update

Then we are supposed to patch what was downloaded but instead we un-tar the ready 0.8.3pre1, which is not part of the cvs (btw, i have that downloaded), but why did we download the cvs from the beginning?

Code: [Select]
tar xvjf lirc-0.8.3pre1.tar.bz2

so now we have a dir inside lirc that is named: [lirc-0.8.3pre1] plus when i tried to apply the patch on the lirc dir it gave back an error, so i did the following:

Code: [Select]
cd lirc-0.8.3pre1
patch -p1 < ../lirc-0.8.3pre1-imon-pad2keys.patch
./autogen.sh
./setup.sh

and that worked, then i did:

Code: [Select]
make
sudo make install
sudo modprobe lirc_dev
sudo modprobe lirc_imon

and before all of that , added the device template in the LMCE, and let it install LIRC first and then on and did the above. after some playing around, i got stuck at this error:

Code: [Select]
01 04/14/08 20:47:07.644 No SerialPort selected and no default entry found. Exiting. <0x2abe72c15910>

I then went into the LMCE admin webpage and went into the [default] device settings and change this communicates through to USB and reloaded the router. still i kept getting this error.

When i added the template at the very beginning, LMCE added 3 items: iMON PAD, default, and LIRC Receiver.

The iMON PAD is the one i created and added to it [Configuration] [lircd.conf] [copy of the actual lircd.conf content]
The default i did not change anything in it, except later on the communicates through to USB.
The LIRC Receiver, it has [Controlled via: default] and thats it.

I beleive my problem lies within the USB and default, but i really dont know what or where to change settings anymore :)

As for the receiver, whether or not it is connected, i beleive it is, simply because when the machine first boots into LMCE, the remote arrow wheel works like a mouse until i hit the [mouse/keyboard] button on it, and then it dies. so i beleive that the receiver is connected alreight and is picking up signal. It's the [default] that is having trouble hooking up to the USB port.

And as for the remote, it is exactly the same like the one in the wiki, except mine is all black, but the buttons are all the same.

« Last Edit: April 15, 2008, 05:28:32 pm by megacrypto »

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #10 on: April 17, 2008, 02:47:17 pm »
Sorry, the line
tar xvjf lirc-0.8.3pre1.tar.bz2
isn't supposed to be used.
I took those lines from a howto elsewhere and forgot to delete this line. Essentially, I downloaded, patched and compiled the cvs version of lirc, no need to untar this.

I had a problem with "default" loading on on install that I ran. I didn't pay much attention to it as I was concerned with something else. All other installs I haven't had a problem with.

I haven't had a device named lirc reciever though. Maybe the default reciever is competing with this??

You should only have the imonpad device that you set up (will be a lirc infrared device) and default device (because you select to have a default reciever on the media director page)

Also, I only specified communicate through usb on my imonpad device, I didn't touch the default device

I would suggest a new install, and starting from scratch. Follow my howto exactly (aside from the line:  tar xvjf lirc-0.8.3pre1.tar.bz2, and make sure the downloaded patch is placed into the lirc folder)
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #11 on: April 18, 2008, 02:10:47 pm »
I have working iMON VFD display and remote but without PAD buttons Up, Down, Right and Left. My target was patch lirc-0.8.2 which is a part of LinuxMCE 0710 and build package with support iMON PAD buttons. Because it's not so good to recompile it after each upgrade or for each new installation.

Actually VFD display works fine with current lcdproc package without any patching. But iMON PAD buttons are terrible IMHO. I'm going to replace iMON remote to some universal one with better support of LIRC.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

zaphodB

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #12 on: April 21, 2008, 07:55:34 pm »
Hi,

is this for the Antec Fusion 430 too???

regards

Thorsten

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #13 on: April 22, 2008, 08:24:13 am »
Hi,

is this for the Antec Fusion 430 too???

regards

Thorsten

It uses iMON PAD. So, it should be the same for Antec Fusion 430.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Itsik

  • Guru
  • ****
  • Posts: 185
    • View Profile
Re: iMON PAD + LCD on Thermaltake DH101
« Reply #14 on: April 22, 2008, 10:07:28 am »
can some one please post the lircd.conf for the imon pad? all the links on the blog linked to this thread seam to be dead ...

thnx
Itsik