Author Topic: Video brightness adjustments  (Read 1077 times)

Randykc

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Video brightness adjustments
« on: April 13, 2008, 09:43:34 pm »
Is there a way to adjust the brightness level on movies that I'm playing on my diskless MD that I have ripped on my core system?  They all appear on the dark side to me.  I tried tweaking the brightness level using nvidia-settings from the desktop, but the change did not appear to get reflected when I play a video.  To verify this, I tried setting the nvidia-settings brightness level to full and then playing the movie again. It was still dark while everything else (menus, flickr pictures, etc) appeared washed out because of the increased brightness level.

Randykc

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Video brightness adjustments
« Reply #1 on: April 18, 2008, 03:35:04 pm »
Anyone?  Feel like I'm the only one seeing this.  I watched a movie again last night and I had to increase the brightness on the TV from 50% to around 72%. Can I just increase the brightness level in Xine itself (if Xine is the player LMCE uses) without effecting anything else?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Video brightness adjustments
« Reply #2 on: April 18, 2008, 04:18:49 pm »
Anyone?  Feel like I'm the only one seeing this.  I watched a movie again last night and I had to increase the brightness on the TV from 50% to around 72%. Can I just increase the brightness level in Xine itself (if Xine is the player LMCE uses) without effecting anything else?

I must say we don't experience this problem. As far as I know there are no brightness settings in LinuxMCE but there may be some settings for this in xine itself which is used for non HD video playback.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: Video brightness adjustments
« Reply #3 on: April 18, 2008, 04:49:28 pm »
 ;D

I have this issue with an older 36" TV/CRT. If you have an nvidia card, there is hope. From the kde desktop, launch a terminal, become root
Code: [Select]
sudo -iThen from the terminal window run nvidia-settings
Code: [Select]
nvidia-settingsThere is an option in the window presented for "X Server Color Correction" Select it and adjust Gamma, Contrast, and Brightness to about 3 or 4. Then exit the application. This will have created a file in roots home directory /root/ called
Code: [Select]
.nvidia-settings-rcTo get this to stick (and after you play around until you get the right picture quality) add the following line to /usr/pluto/bin/lmce_launch_manager.sh
Code: [Select]
vi /usr/pluto/bin/lmce_launch_manager.shadd
Code: [Select]
nvidia-settings --load-config-only&This will apply your changes every time the launch manager is started.
Hope this helps.

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

Randykc

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Video brightness adjustments
« Reply #4 on: April 18, 2008, 06:56:18 pm »
Yep, the nvidia-settings was what I tried originally.  Tweaking the values a little at a time did not appear to be doing anything for video playback of ripped *.dvd files, so for a test, I tried setting the brightness to 100% using nvidia-settings. Everything was super bright like I would expect until I played a ripped movie. That was still dark like it was ignoring the nvidia settings :(  This was last weekend, so I'll double check that.

*Edit* - I just checked this on my core which also has an nvidia card.  Using nvidia-settings, changed the brightness to 100%. Then played a ripped .dvd file on the core. Video played like the brightness level was not changed.
« Last Edit: April 18, 2008, 07:10:26 pm by Randykc »