Author Topic: crashing core!  (Read 648 times)

gazzzman

  • Veteran
  • ***
  • Posts: 118
    • View Profile
crashing core!
« on: April 06, 2008, 06:44:15 pm »
hi all!
I had a mains failure this morning :(
when I rebooted the core everything started ok..
but over the course of the next two minutes it gets slower and slower and (more or less) stops!
it does not respond to ctrl alt bachspace
if you move the mouse the cursor moves a bit about 30 seconds later!!
cannot access the admin site from another machine.. the only way to shut it down is to pull the plug!
I have checked the disk integrity and that seems ok

just wondering where to start really!
any help would be appreciated!
Gazzzman
-----BEGIN GEEK CODE BLOCK-----
Version 3.1
GCC@GE@GIT@GO dpu S-: a+ C+++ L++ E-- W+++ N+ o+++ w-- O M+ PS+++ PE-- Y++
PGP+ t++ 5 X++ R- tv b+ DI++ D---- G e++* h*++ r+++ Y++++
-----END GEEK CODE BLOCK-----

dopey

  • Guru
  • ****
  • Posts: 222
    • View Profile
Re: crashing core!
« Reply #1 on: April 07, 2008, 07:45:54 am »
This could be many things, but my guess it's the Ushare bug I reported in Mantis. If you have recursive links in a location that Ushare scans for new media, it eats all memory, including swap, and effectively kills the computer. Try killing ushare immediatly (and I mean quick) after boot and then rename the ushare executable.

FYI, as the bug reports mentions, this bug is fixed in SVN and so it won't be a problem in the next release. The fix is actually removing ushare altogether and replacing it with fuppes. I've never used fuppes as I didn't even know it existed... I normally use MediaTomb, but fuppes looks promising!

gazzzman

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: crashing core!
« Reply #2 on: April 09, 2008, 01:35:10 am »
thanks again dopey :)
in the end I found deleting the MD and regenerating it cured the problem (but I have little idea why!!)
I do wish I could get my head round Linux a bit better!
in fact.. I wish I had never seen M$ and that way I would have concentrated on Linux from the beginning
and maybe today I would not feel like the useless gimp I do right now!
7 weeks and about $1100 in..
I have a core that works mostly..
an MD that works except I have no way to control it as the mouse died when I tried to set up the wiimote :)
and a crate full of X10 stuff I dare not connect..
a tuner card that just brings down the whole system..
well you get the idea!
-----BEGIN GEEK CODE BLOCK-----
Version 3.1
GCC@GE@GIT@GO dpu S-: a+ C+++ L++ E-- W+++ N+ o+++ w-- O M+ PS+++ PE-- Y++
PGP+ t++ 5 X++ R- tv b+ DI++ D---- G e++* h*++ r+++ Y++++
-----END GEEK CODE BLOCK-----