Author Topic: Enabling Vsync  (Read 2423 times)

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Enabling Vsync
« on: March 31, 2008, 12:25:03 am »
Hi,

I have a nVidia xfx 7300 gt and cannot seem to get rid of video tearing.

I have ticked all the boxes in nvidia settings relating to vsync and ticked the vsync box in the mythtv playback setings, I have also tried the latest envy driver but still get quite bad tearing.

I have been using the UI2 with alpha blending so (as suggested on this forum) changed to UI2 masked, but still I get bad tearing. I also closed the orbiter and tried running myth from KDE, but still no improvement.

Is there a special way to prevent tearing? Or is it just that my hardware isn't up to perfect vsync (see below for full list)?

Anybody not getting tearing with their setup?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Enabling Vsync
« Reply #1 on: March 31, 2008, 02:48:14 am »
install http://www.nvidia.com/object/linux_display_ia32_169.12.html enable all vsync options and useevents=true ot xorg

works great w my 7050 alphablending no tearing at 1080p low xorg cpu usage
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Enabling Vsync
« Reply #2 on: April 03, 2008, 02:34:11 pm »
Didn't work for me i'm affraid.

Is there any way to force vsync? eg. in the xorg.conf?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Enabling Vsync
« Reply #3 on: April 03, 2008, 03:49:45 pm »
Is your content interlaced or progressive? Or "mixed" (interlaced SD in 720P HD) content. Progressive content seems to work pretty well The interlaced content is more troublesome. And the mixed stuff may be a lost cause. What mode is your display running in? (720p, 1080p, 1080i or something else?).

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Enabling Vsync
« Reply #4 on: April 03, 2008, 04:00:13 pm »
Not sure how to tell whether i'm using interlaced or progressive.

I can say that i'm displaying 1080p @60hz and UI2 on a 40" 1080p LCD screen using a dvi to hdmi cable.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Enabling Vsync
« Reply #5 on: April 03, 2008, 11:22:44 pm »
gazlang

follow this guide http://wiki.linuxmce.org/index.php/Nvidia_Card_Tweaks_For_Better_MythTV_and_UI_Performance
Excpet:

1. make sure you use nvidia 169.12 driver
2. Enable all vblank options
3. add Option "UseEvents" "true"  to screen section of xorg.conf

Works for me

YMMV

My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Enabling Vsync
« Reply #6 on: April 04, 2008, 01:56:49 am »
Gazlang

If its any consolation, I am still getting jerky video and some tearing running 1080p with UI2Masking even after trying all the options that tk suggested and I'm using the exact same mobo as him! I'm stumped as to what to do...

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Enabling Vsync
« Reply #7 on: April 04, 2008, 11:14:21 pm »
me 2
rock your home - http://www.agocontrol.com home automation

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Enabling Vsync
« Reply #8 on: April 04, 2008, 11:32:43 pm »
look here for hints, this how I determined my settings

http://www.mythtv.org/wiki/index.php/NVidiaProprietaryDriver
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Enabling Vsync
« Reply #9 on: April 09, 2008, 02:28:21 pm »
No luck with this still.
Somehow the tearing doesn't seem to be as bad as it was now, but still very noticable when the video includes flashing lights / high speed action.

I am suprised to get any tearing at all since some users have lower graphics cards and no tearing probs.

One last question -
Do I need to have specific video settings on the media director page on LMCE admin?
Currently, the graphics card is set to generic and with high deinterlacing using xv - if I change the card to nvidia 7xxx series the x-server won't start on reboot and I have to re-install the nvidia driver using envy in the kernel recovery mode.

Anyone else seen this?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Enabling Vsync
« Reply #10 on: April 10, 2008, 12:28:58 am »
High deinterlacing could suck up all your CPU, default is off and that is what I use but still get the same issues. I'm set to xv most of the time and generic, and changing these doesn't seem to make any difference. I have asked the same questions but nobody seems to want to be pinned down on that, also there really isn't anything in the wiki on it either....

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4443
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Enabling Vsync
« Reply #11 on: April 10, 2008, 12:45:01 am »
High deinterlacing could suck up all your CPU, default is off and that is what I use but still get the same issues. I'm set to xv most of the time and generic, and changing these doesn't seem to make any difference. I have asked the same questions but nobody seems to want to be pinned down on that, also there really isn't anything in the wiki on it either....

We usually use 'xv' and 'high' or 'higher' de-interlacing.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Enabling Vsync
« Reply #12 on: April 11, 2008, 12:50:05 am »
What about the graphics card, Andrew? Does it make any difference? Should I set it to GeForce/NVidia (although it doesn't seem to make any difference!)

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4443
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Enabling Vsync
« Reply #13 on: April 11, 2008, 01:11:49 am »
What about the graphics card, Andrew? Does it make any difference? Should I set it to GeForce/NVidia (although it doesn't seem to make any difference!)

No there is no need to use that setting in Web Admin at all... i never touch it at all.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Enabling Vsync
« Reply #14 on: April 13, 2008, 10:38:55 am »
ok, i tried setting th ui to basic ui1 with s-video out - result! No tearing! My card must be strugglin with th ui. Suprising though as said before, as i don't see the 7300gt as a weak card for video.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT