Author Topic: Audio output is busy or not available (Frst 0710 Beta4 install)  (Read 1914 times)

erasmix

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Hello,

I just got my install up for the first time. When I try to play any video (or dvd) it complains "Audio output is busy or not available". Then I exit to KDE and it shows the little speaker icon on the system tray with a red cross. All this leads me to believe my sound card wasn't recognized. I also noticed that /etc/modprobe.d/sound is empty.

This computer was running fedora 9 before, and it was recognized as:

nVidia Corporation Unknown device 07fc
Driver: snd-hda-intel


Any ideas?

kir

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: Audio output is busy or not available (Frst 0710 Beta4 install)
« Reply #1 on: March 23, 2008, 12:41:36 am »
Hmm... to me it looks like your soundcard was not recognized by the Kubuntu 0710 drivers... If you have some time to experiment, can you download the Kubuntu 0710 ISO from here: http://www.kubuntu.org/download.php#latest  , burn it to the CD, reboot it to start Live CD and check if sound is there. If it is not, then probably you will need to install later ALSA sound drivers - especially if you have a modern soundcard :) If Kubuntu 0710 itself has a sound, try to "Stop LinuxMCE" from the LaunchManager and see if KDE sound works now. It could be a conflict between sound apps in LinuxMCE (SimplePhone, Xine_Player, etc.) - but this happens not so often...

erasmix

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: Audio output is busy or not available (Frst 0710 Beta4 install)
« Reply #2 on: March 23, 2008, 08:36:20 pm »
Hi!

I first stopped LinuxMCE, as you suggested. Nothing. Then I tried the Live DVD, but when I type "live" at the boot prompt, it boots to command line only. I then tried xinit, but got an error and stopped trying.

I also tried installing Fedora 8 on this machine again and took a more detailed look at the sound configuration that was automatically generated by the installer:

[erasmo@kreacher ~]$ /sbin/lsmod|grep snd_hda
snd_hda_intel         297441  3
snd_pcm                70981  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc         11593  2 snd_hda_intel,snd_pcm
snd_hwdep              10693  1 snd_hda_intel
snd                    48453  16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep

/etc/modules:
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0

/etc/modprobe.d/modprobe.conf.dist:
alias char-major-116-* snd
alias sound-service-*-0 snd-mixer-oss
alias sound-service-*-1 snd-seq-oss
alias sound-service-*-3 snd-pcm-oss
alias sound-service-*-8 snd-seq-oss
alias sound-service-*-12 snd-pcm-oss
install sound-slot-* /sbin/modprobe snd-card-${MODPROBE_MODULE##sound[_-]slot[_-]}
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && /sbin/modprobe snd-emu10k1-synth

I tried to replicated these changes on kubuntu the best I could (however I'm not an expert and I don't know kubuntu as I know Fedora), without success.

Now you mentioned something about newer alsa sounde drivers. How do I get those?

I also wanted to tell you about my soundcard, because I really don't think it's a fancy one. I bought an a-bit mini-ATX mobo based on the nvidia MCP73PV chip with a GeForce 7100 /nForce 630i GPU and HD audio (optical S/PDIF & HDMI) on board, so I didn't need to add any cards. It was really cheap it looked ideal for LinuxMCE, however it looks like Linux Kernel support is not entirely there. When I installed Fedora, I was able to play DVDs and .mkv HD videos, but my audio card would only play audio thru the analog output (the opt S/PDIF is dead, and I don't have HDMI on my TV). The video plays good though.

I'm fiercely committed to make linuxMCE work and I'm willing to run any tests you guys come up with. I built this system for that purpose.

Best regards from California.

Erasmo.

« Last Edit: March 23, 2008, 08:39:14 pm by erasmix »

erasmix

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: Audio output is busy or not available (Frst 0710 Beta4 install)
« Reply #3 on: March 24, 2008, 05:48:13 am »
Found it!

There is an hda-intel ALSA module problem is in kubunto 7.10. I found the document below which recommends downloading the latest ALSA driver and build it from source:

https://help.ubuntu.com/community/HdaIntelSoundHowto

It gives out detailed instructions. I successfully compiled the driver, but failed on the alsa-utils. However it was enough to fix my problem. Even the Optical S/PDIF works now!

Thanks for all your help,

Erasmo.

Itsik

  • Guru
  • ****
  • Posts: 190
    • View Profile
Re: Audio output is busy or not available (Frst 0710 Beta4 install)
« Reply #4 on: March 24, 2008, 07:15:32 am »
Follow the instrucions I poted here to succesfully recompile and install alsa-utils. This will anable you to run alsaconf which will properly identify and install your soundcard on the system. This should also fix your SPDIF issues.

Hope this helps.
Itsik