Author Topic: Results from my 4th installation from DVD 0710 Beta4  (Read 3370 times)


  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Results from my 4th installation from DVD 0710 Beta4
« on: March 07, 2008, 05:31:53 pm »
Started over this morning. Spent the last couple hours rebuilding my core. Seemed to go somewhat better this time for unknown reasons, but I suspect simply not having the Gyro remote USB dongle in place until things were up and running may have helped (I have read many comments about problems and a repeated question about: did you have anything connected in usb?).

Like yesterday, I made notes as I went along.

I'm using a single NIC configuration. See my previous post for exact hardware details.

The start of the installation appeared on the VGA output only.

After the reboot, I got the Kubuntu splash screen on vga output, it did a bunch of config, logged itself in and went right to the AV Wizard. I note that some of the prompts and speech say to press enter but there's an OK button on the screen, not enter.

I choose OpenGL with Alpha Blending, Component output, 720p and then video output appeared on my TV.

I would note that the LinuxMCE screen displays perfectly, it's the correct size and the flickr pictures are very good lookin, but anything in Kubuntu suffers from all four edges of the screen running offline and out of sight, which makes navigation tough at times.

The AV Wizard said she couldn't find anything for MythTV and I'd have to run that myself.

There were no additional software packages displayed in the box. No problem.

I went to the KDE desktop, fired up firefox, went to localhost and logged into the Admin page. I updated the Network Settings and reloaded router from the Linux KDE Launch Manager. Went back to check the changes stuck (these are changes to use 1 NIC). Had to adjust NIC 2 again. Saved, reloaded router, checked, looks fine.

I then went to edit /etc/dhcp3/dhcpd.conf.
-quesiton: under (subnet) should the "option domain-name-servers" remain as 2? (the core ip?) or should be (my LinkSys Router?)
-I changed "next-server" to Is that correct? 101-199 being set aside for LinuxMCE devices
-under (group) I changed "next-server" to Is that correct?

I then restarted dhcp and there were no errors.

I looked at /etc/network/interfaces (as I had to manually adjust that yesterday). I get:

auto eth0
iface eth0 inet static

auto eth0:0
iface eth0 inet static
(no gateway line)

Is that correct?

At this point I can ping internal and external IP's and domain names.

I disabled the firewall, my LinkSys router has one.

Reloaded router.

Now it noticed by Dell laptop. I told it it was a server, and it was located in the downstairs office. Something flashed about "failed to get IVTV device" and then a message installed software done. So I clicked the quick reload button.

Somewhere around here the flickr images start appearing on the screen.

I shared my "Music" and "Photos" folders off the Dell notebook.

I then went to MythTV Config.

 Same thing as yesterday. Screen runs off the edges. No mouse. How do you make the drop-down selectors work?
 I entered my SchedulesDirect.Org username and password and managed to select "Retreive Lineups"
 Somewhere I got to scan channels. First it failed to open card, but later it appeared to scan channels.
 I was told to run mythfilldatabase but I don't know how you do that?

 So now I'm back at the main interface, wiggle over to media -> tv and a nice blank screen, no sound. A window asks if I want to reset the mythtv backend. Sure. Eventually I got the MythTV screen. Selected WatchTV. repeat above. Nice.

 So then I figure I'd uncheck asterisk as we don't use VOIP. For whatever reason I get a few screens about "something cannot register with the router" so I decided heck, check it back on.

 Couldn't get out of that loop so I clicked on restart from my Dell admin screen.

 Hmm, upon restart I'm taken to the AV Wizard on the VGA output again. Fine, walk through all that and it rebuilts all the orbiter stuff.

 Now it finds my shares on my HPPavillion desktop in the office. Walk through all that. Do a quick reload at the end.

 I awake my Dell from sleep mode and it tells me I have limited or no connectivity. Try Repair. Nothing. Reboot. Nothing. So now my Dell notebook can't get an IP wirelessly. Ok, I guess I'll go back and have a look at the DHCP configs.

 And that's where I'm at so far.

 I still can't watch tv with the PVR150MCE.

 Am i supposed to go learn how MythTV works now? Maybe I can run the AV Wizard, set it to VGA output only, and then actually be able to see the screen in proper size and set it up. Suggestion? From watching the demo video, I thought all this was automatic.

 My results are better than yesterday, and I assume my issues at this point are with MythTV? and perhaps a little double check of the dhcp configs.


  • Veteran
  • ***
  • Posts: 60
    • View Profile
    • High Tech Pad
Re: Results from my 4th installation from DVD 0710 Beta4
« Reply #1 on: March 18, 2008, 09:32:27 am »
I am probably not the best person to answer this but my understanding is the two ethernet entries you have should be on different IP addresses ideally on different ranges. Do you have an internet connection for this network because the whole point of the two network interfaces on the one network card is so they run on different subnets and your Core becomes the router for the mds and orbitors.
Therefore your eth0 should run on your Internet network subnet ie 192.168.0.X and the gateway should be your DSL router or Cable router etc. The eth0:0 should be for the internal Linuxmce network such as your orbitors and mds. The default subnet is 192.168.80.X. This interface should not have a gateway because it IS the gateway for the linuxmce subnet. This should also be the DNS server for your network so the domain-name-server option should point to the core's IP on the linuxmce subnet.

The next-server is an option used for PXE booting. When the client boots to LAN the next-server tells the client which IP address to boot from. Therefore this should also be the core's IP on hte linuxmce subnet.

Thinking about it, you may not need to have separate subnets running, but it is just how I do it. You could probably have eth0 and eth0:0 on the same subnet :ie 192.168.0.X but definitely not having the same IP address.

I may be completely wrong but that is my understanding. Hope it helps.
Z-Wave,  Peripherals, Licenced Media Directors and Cores now available with European-wide Delivery at


  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: Results from my 4th installation from DVD 0710 Beta4
« Reply #2 on: March 23, 2008, 10:29:17 am »
I assume my issues at this point are with MythTV

Totally true!

You have to remember linuxmce is a wrapper around many discrete packages. If you have an issue with that package, asterix/vdr/mythtv/xine etc, you will likely get better help on a website dedicated to that product. (No offence intended to anyone here)
The mythtv wiki is an excellent example of how they should be run. There is so much info there you'll definitely find someone who has experienced, and most often solved, any issues you come across

I've been struggling for a few weeks now, but once i found the mythtv website i moved along very quickly.

To get your listings working in mythtv though, choose your listings package, then alt-tab and the terminal window might be asking for your input to select channels etc. If this is the first time you have been here you need to run "mythfilldatabase --manual" command create a xmltx file and download the channel names and icons
alt-tab back to the backend setup
It may again ask you to do a mythfilldatabase for you. If it does not do not worry, nor even when it asks you to perform one.
Basically whenever you exit the backed set-up, it will ask you if you want to run mythfilldatabase. That's the time to do it if you did not do it in the terminal window

To go through the menus, use the left arrow to select item and the right arrow to change the option, mousing does not work
I'm jealous you got your opengl working so quickly!!

I see your taking notes which is great.
Work through each package incrementally.
once it is set up and working well, save a backup at that point from the web using the web interface.
If you then screw up a package, you can save the backup sets elsewhere, reload the dvd and restore from a good point.