Author Topic: Problems playing DVDs  (Read 2361 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« on: November 13, 2005, 09:02:05 pm »
Hello!

I'm having some problems playing DVDs on my hybrid.
The picture is playing for 3-4 seconds, then stops for a second.

I've spoken to dan.a on live support, and he talked about something with the kernel not loading a module.

Could someone help me out a bit here? I've seen this on all kind of hardware, ranging from Pentium 800 to P4 3.2GHz. So I'm a bit stumbled that this have'nt been discussed before.

But when I first rip it to the hdd, and then playis it, everything is ok.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #1 on: November 14, 2005, 11:18:04 am »
It's possible that the CD unit doesn't have DMA enabled. This is a current issue with the module loading order. Tell me what "hdparm /dev/cdrom" says.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #2 on: November 15, 2005, 07:13:47 pm »
I've been trough that with aron. On another computer I was able to turn dma on, but I can't on this.

When I did it with aron, it did'nt help.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #3 on: November 15, 2005, 07:29:54 pm »
Hmm... then I'd need access to the machine and time to look into it. Lots of time given the latest turnouts :)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #4 on: November 15, 2005, 08:40:51 pm »
I've been having similar problems and tracked it down to DMA not being active on the machine. From looking in more generic forums, it seems the kernel module for your ide drivers needs to be compiled into the kernel for some reason (Mine's the AMD7xxx driver). Recompiling the kernel with the correct device built into the kernel rather than a module made DMA work.

On a related note, what is required for pluto home when you do a kernel recompile (ie, anything else needs re-compiling such as zaptel drivers) and how/where do you get the required source?

Cheers,

Darren.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #5 on: November 17, 2005, 07:37:19 pm »
The DMA is because of this:
ide-generic is loaded first
chipset-specific-driver (piix, etc.) is loaded later

ide-generic gets hold of the IDE ports
chipset-specific-driver doesn't find anything to handle

ide-generic doesn't know DMA since DMA is a chipset-specific function.

I don't know why, but just writing "chipset-specific-driver" in /etc/modules and rebooting solved my DMA problems (on systems with S-ATA hard drives).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #6 on: November 17, 2005, 07:38:11 pm »
About external kernel drivers: if we supply them, they're usually in svn (doesn't apply to nVidia kernel module - yet)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #7 on: November 18, 2005, 09:00:22 am »
Fantastic, that worked perfectly. DMA is enabled now so thankfully I don't have to recompile yet! At least not until I want my epia frontends to work.

Darren

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #8 on: November 19, 2005, 12:07:10 pm »
How to do this?

Is it just to type "chipset-specific-driver" in the file, or
do I need to download something, and type the name of it?

My skills at linux is limited here :)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #9 on: November 19, 2005, 01:38:03 pm »
It all depends on what motherboard you have.

In my case, the line I put in was:

amd74xx

To find out what chipset your motherboard uses type lspci and look for a line talking about your IDE interface.

if you cd into:

/lib/modules/2.6.13.2-vanilla-pluto-1-686/kernel/drivers/ide/pci/

You will see a list of all the available drivers. Choose one that looks like the line in your lspci and put that filename (minus the .ko extension) as the first line in the file /etc/modules.

Hopefully thats easy enough to follow, I don't tend to make a good teacher! :)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problems playing DVDs
« Reply #10 on: November 19, 2005, 09:50:40 pm »
After my last post, I played around a bit, and found the path you specified. I then put 2 and 2 togheter, and I made it! It now works finaly! :)

And I did exactly as you said. So that post would be very helpfull for someone else I think. Thank you anyway :)