Author Topic: Mythtv recording problem  (Read 1007 times)

pga57

  • Veteran
  • ***
  • Posts: 135
    • View Profile
Mythtv recording problem
« on: March 20, 2008, 09:20:48 pm »
Hi,

I use MCE beta4 with an Hauppauge nova-t-500 dvb card.

I have a problem with mythtv.
Live TV is ok but when I want to record a program using mythweb the record faild with an error like this:

2008-03-19 19:10:02.311 TVRec(1): Changing from None to RecordingOnly
2008-03-19 19:10:02.320 TVRec(1): HW Tuner: 1->1
2008-03-19 19:10:02.324 DVBChan(0) Error: Tune(): Setting Frontend tuning parameters failed.
                        eno: No such device (19)
2008-03-19 19:10:02.325 DVBChan(0) Error: SetChannelByString(4): Tuning to frequency.
2008-03-19 19:10:02.327 TVRec(1) Error: Failed to set channel to 4. Reverting to kState_None
2008-03-19 19:10:02.328 TVRec(1): Changing from RecordingOnly to None
2008-03-19 19:10:02.333 Canceled recording (Recorder Failed): Le grand journal de Canal+: channel 1004 on cardid 1, sourceid 1
2008-03-19 19:10:05.366 Error deleting '/home/public/data/videos/tv_shows_1/1004_20080319191000.mpg' could not open
                        eno: No such file or directory (2)
2008-03-19 19:10:05.399 Delete Error '/home/public/data/videos/tv_shows_1/1004_20080319191000.mpg'
                        eno: No such file or directory (2)
2008-03-19 19:10:09.404 Reschedule requested for id 0.
2008-03-19 19:10:09.414 Scheduled 1 items in 0.0 = 0.00 match + 0.01 place
2008-03-19 19:11:06.387 DVBChan(0) Error: Tune(): Setting Frontend tuning parameters failed.
                        eno: No such device (19)
2008-03-19 19:11:06.395 DVBChan(0) Error: SetChannelByString(14): Tuning to frequency.
2008-03-19 19:11:06.396 TVRec(1) Error: Failed to set channel to 14. Reverting to kState_None

I don't understand why ?

Can anyone help me ?

Thank's !

cobradevil

  • Regular Poster
  • **
  • Posts: 48
    • View Profile
Re: Mythtv recording problem
« Reply #1 on: March 21, 2008, 09:15:18 am »
Hello,

from the logging i could make up that you have a wrong device setup in the backend!

>2008-03-19 19:10:02.324 DVBChan(0) Error: Tune(): Setting Frontend tuning parameters failed.
                        eno: No such device (19)

is your card recognized and can you create an mpeg file with cat /dev/video0 > video.mpg and can you play that file with mplayer?

With kind regards,

William van de Velde

pga57

  • Veteran
  • ***
  • Posts: 135
    • View Profile
Re: Mythtv recording problem
« Reply #2 on: March 21, 2008, 10:09:54 am »
Hello William,

Yes maybe, but why can I use the Live TV if I have a wrong device setup ?!
Recording work when I use live tv and press on R to begin a record.
I only have the problem when I want programming record.

Philippe

cobradevil

  • Regular Poster
  • **
  • Posts: 48
    • View Profile
Re: Mythtv recording problem
« Reply #3 on: March 23, 2008, 09:10:13 pm »
Hello Philippe

http://www.mythtv.org/pipermail/mythtv-users/2007-March/173989.html

maybe you can try the above otherwise i have no clue!

With kind regards

William van de Velde

pga57

  • Veteran
  • ***
  • Posts: 135
    • View Profile
Re: Mythtv recording problem
« Reply #4 on: March 24, 2008, 09:49:05 am »
Hello William,

Thank's for your reply.
My setup is different than your Mythtv forum example because the Nova-t-500 give me 2 inputs cards.
I've made some others programming records test and strangely some worked and other not.

Here my setup:

INSERT INTO `capturecard` (`cardid`, `videodevice`, `audiodevice`, `vbidevice`, `cardtype`, `defaultinput`, `audioratelimit`, `hostname`, `dvb_swfilter`, `dvb_recordts`, `dvb_sat_type`, `dvb_wait_for_seqstart`, `skipbtaudio`, `dvb_on_demand`, `dvb_diseqc_type`, `firewire_port`, `firewire_node`, `firewire_speed`, `firewire_model`, `firewire_connection`, `dvb_hw_decoder`, `dbox2_port`, `dbox2_httpport`, `dbox2_host`, `signal_timeout`, `channel_timeout`, `parentid`, `dvb_tuning_delay`, `contrast`, `brightness`, `colour`, `hue`, `diseqcid`) VALUES
(1, '0', '', '', 'DVB', 'DVBInput', NULL, 'dcerouter', 0, 1, 0, 1, 0, 0, NULL, 0, 2, 0, NULL, 0, 0, 31338, 80, NULL, 500, 3000, 0, 0, 0, 0, 0, 0, 0),
(2, '1', '', '', 'DVB', 'DVBInput', NULL, 'dcerouter', 0, 1, 0, 1, 0, 0, NULL, 0, 2, 0, NULL, 0, 0, 31338, 80, NULL, 500, 3000, 0, 0, 0, 0, 0, 0, 0);

INSERT INTO `cardinput` (`cardinputid`, `cardid`, `sourceid`, `inputname`, `externalcommand`, `preference`, `shareable`, `tunechan`, `startchan`, `freetoaironly`, `diseqc_port`, `diseqc_pos`, `lnb_lof_switch`, `lnb_lof_hi`, `lnb_lof_lo`, `displayname`, `radioservices`, `childcardid`, `dishnet_eit`, `recpriority`) VALUES
(1, 1, 1, 'DVBInput', NULL, 0, 'N', NULL, '4', 1, NULL, NULL, 11700000, 10600000, 9750000, 'DVB0', 1, 0, 0, 0),
(2, 2, 1, 'DVBInput', NULL, 0, 'N', NULL, '17', 1, NULL, NULL, 11700000, 10600000, 9750000, 'DVB1', 1, 0, 0, 1);

I continue my research...

Regards..

Philippe