Author Topic: [SOLVED] 8500GT 3d nvidia driver issue  (Read 2114 times)

Blackhat

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
[SOLVED] 8500GT 3d nvidia driver issue
« on: March 12, 2008, 07:09:09 pm »
**EDIT**
I edited the title to better reflect the actual problem (hopefully make it searchable).  The solution is in my last post in the thread (or at least, my solution for my problem) but there is still the power issue that I fixed in the middle of this thread by replacing the power supply.
**EDIT**

Well, I'm finally getting somewhere I think.  Had issues with my Nvidia 8500GT not liking the "nvidia" drivers.  I was kinda working with the "nv" but OpenGL would not work.  I downloaded the new Nvidia drivers, ran the install and in general everything went well until I tried to start X up again.  Blank screen.  So I did a little searching and came across http://forum.linuxmce.org/index.php?topic=4379.0

Happily that worked.  I can now start X and I get the cool nvidia splash screen and all.  Except now, ONLY X starts (no KDE or MCE).  So I get that god aweful "x" cursor and no GUI.  When I reboot MCE does not come up automatically.  I got through the install using the simple layout (no OpenGL) on the "nv" drivers.  I'm shooting for using the "nvidia" driver with OpenGL (alpha blending if possible).  Any ideas? :-\

Thanks in advance!
« Last Edit: March 21, 2008, 12:01:53 am by Blackhat »

Blackhat

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #1 on: March 13, 2008, 02:10:28 am »
Ok, this one is stumping me.  I've been searching for hours now and have found many cases that sound similar to mine, but there are some differences.  I figured I'd ask and see if it turns on any lights for you guys.

I am having the wonder problem where switching to the 3d nvidia driver causes the monitor to loose signal.  I hear all the beeps and can pick any of the options 1-9 with no success.  ctrl+alt+f2.  I have tried envy's utility and that actually didn't work at all (quite the opposite, I lost nvidia-glx files somehow when I did it that way).  I downloaded the drivers directly from Nvidia and could actually get the barebones X session to run (funky gray background with the X cursor), but as soon as I restart X will not auto-run.  I can log in command line and start barebones X whenever, or switch back to the "nv" 2d driver and go into non-openGL mode MCE.

Any ideas?  I'm currently working to try the envy utility from a fresh install.  If I get more problems I'll try to pull the info from the xorg log file.  I'm hoping this is not the issue plaguing nvidia 8x00 users that I'm seeing everywhere.

mmnogueira

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #2 on: March 13, 2008, 08:48:11 pm »
Hello Blackhat,

Yesterday I finally got my LMCE running in UI2 with all bells and whistles. This is how I did:
1. Removed all partitions in the HD with a Win98 CD.
2. Installed LMCE with the DVD and selected:
a. DVI->1024x768->60
b. Basic UI (UI1)
c. Analog stereo
LMCE installed fine. After rebooting, GRUB showed an "Error 18" and froze. After rebooting, I managed to open the GRUB menu and selected the first option - LMCE loaded fine in basic UI1. Then I selected the KDE Desktop and:
1. Opened the System Settings in Administrator Mode;
2. Selected Video Settings->Hardware;
3. Clicked the board's "Configure" button;
4. Selected the detected driver: "NVIDIA 8 Series";
5. Clicked the monitor's "Configure" button;
6. Selected the manufacturer and the closest model of mine's (LG L1740PQ);
7. Selected the 1024x768 resolution;
8. Applied the changes and rebooted.
After LMCE loaded I inspected its Video settings and noticed that it had changed from "nv" to "nvidia". Then I clicked the "Change resolution" button and, when the monitor entered the "power saving" mode after rebooting, I hit the "1" (DVI) key. The AVWizard loaded fine, in 640x480 mode. When prompted, I selected the "OpenGL with Alpha Blending" (UI2II) and waited for the crash. Surprisingly, LCME loaded fine, generated all orbiters, the UI2II loaded also fine, and now I'm watching my videos as I expected from the beginning. However, the fonts - both of LMCE and KDE - are very ugly (the KDE fonts are completely distorted and almost unreadable), but this is a problem I'll address next.

HTH,

Marcos Nogueira
S. Paulo - Brazil

Blackhat

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #3 on: March 20, 2008, 08:58:38 pm »
Ok, I've managed to beat the nvidia drivers to the point where the work.  For anyone who happens to be having the same problem...

1) install MCE and get up and running with nv drivers
2) install envy (http://albertomilone.com/ubuntu/nvidia/scripts/legacy/envy_0.9.10-0ubuntu7_all.deb)
directions - http://albertomilone.com/pmwiki/pmwiki.php?n=Main.Envy-InstructionsForUbuntu
note: the FAQ says "sudo apt-get install -f" but it's actually "sudo apt-get -f install"  (or at least is was for me)

3) run envy and do options 2 and 6 (just to make sure everything is uninstalled)
4) then do option 1 to install the drivers
5) This is the part I leaned on a friend for help with.  It involved removing some "excess" settings in /etc/X11/xorg.conf.
Here's my xorg.conf if it helps anyone...
Code: [Select]
Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation G80 [GeForce 8500 GT]"
Driver "nvidia"
Busid "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Horizsync 30-70
Vertrefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G80 [GeForce 8500 GT]"
Monitor "Generic Monitor"
Defaultdepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
Section "Extensions"
Option "Composite" "Enable"
EndSection

ALSO.  I was having a Power Supply problem (as if one problem wasn't enough).  All of this only worked after replacing the anemic P/S that came with my case.

Anyway, I've got MCE running with the nvidia driver and all is happy.  The only problem is that when I run the AVwizard everything goes back to hell.  It must be changing graphics settings before it even loads because it kicks me back to a black screen and none of the options fix it.  Indeed, I have to redo steps 1-5 I just posted to fix it again.  So, I'm looking for a way to tell MCE to use the OpenGL menu's, but in a way that I don't have to run the AVwizard.  My resolution and everything else is fine.  My thoughts are that I just need to switch it to OpenGL and regen the orbiters....  Any idea's on how I could do this?

Thanks in advance.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #4 on: March 20, 2008, 09:09:36 pm »
  LinuxMCE keeps reconfiguring my display settings

Add a line containing exit to the top of the /usr/pluto/bin/Xconfigure.sh file. After you do this you may experience difficulties running the AVWizard again, if so remove this line and add it back again after the wizard is finished.


this should help
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

Blackhat

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #5 on: March 20, 2008, 09:13:43 pm »
That first sentence was a little confusing... Do you mean add "exit" to the beginning of that file in it's own line..

like:
-----------------------
exit
....[rest of file]
-----------------------

?

I assume this is so it doesn't do any modifications?

Blackhat

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: 8500GT drivers working! Can't get the AVWizard though...
« Reply #6 on: March 20, 2008, 11:59:13 pm »
Ok, here's how I got it working:

1) Fresh install of MCE 7.04 DVD

2) During the first run of the AVwizard I set it to use OpenGL Alpha blending and the correct resolutions

3) When it tries to render the orbiter I ctrl+alt+f2 into terminal (I didn't do it this way before because mce doesn't detect my network settings correctly, no biggy, I just have to do some whittling with ifconfig, route and /etc/resolv.conf)

For those of you who might have the same problems with networking... (replace # and ip_address with correct info)
Code: [Select]
sudo ifconfig eth# ip_address
sudo route add default gw ip_address

and then edit /etc/resolv.conf and put in the correct name server ip

4) Installed Envy (reference: http://forum.linuxmce.org/index.php?topic=3368.0  tkmedia gets the credit for this)

    apt-get update
    wget -c http://albertomilone.com/ubuntu/nvidia/scripts/ubuntu/envy_0.9.9-0ubuntu1_all.deb
    dpkg -i envy*
    apt-get install -f
    envy -t

choose options 2 then 6 (I had problems where there was something in the system that was referring to a 100 series nvidia driver that I never installed).  Then choose option 1.  Yes edit xorg.conf, no don't restart.

Also, I think there is a newer version of envy out.  Seems like they were on version 0.9.10, someone might need to verify this.

5) Edit xorg.conf and pull out the bad stuff.  See my xorg.conf on my previous post for an idea of what to get rid of.

6) reboot and everything is A++!

I hope this helps someone else out.
« Last Edit: March 21, 2008, 12:02:43 am by Blackhat »

ouie

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: [SOLVED] 8500GT 3d nvidia driver issue
« Reply #7 on: April 01, 2008, 11:29:34 pm »
On behalf of all nvidia 8500GT owners using Linuxmce THANK YOU!!!! I just finished getting it up and running on my westinghouse 42 inch HD (Which required a firmware update). Could you please update the wiki with this info ? It is most helpful.