Author Topic: LIRC for PVR250 Card unable to get working  (Read 1755 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
LIRC for PVR250 Card unable to get working
« on: November 17, 2005, 05:13:05 am »
I have been trying to get the IR receiver with the PVR250 card working, but I have not been able to get it working. This is what I have done to this point.

I created a Device Template in the LIRC Drivers #133 catagory with the following Device Data:
    #1 Device(string): hauppauge                
    #120 System Device(string): lirc_i2c
               

Then I added the new device under Media Director Infrared Receivers drop down box.  Then I added a remote lircd.conf.hauppauge.

I then rebooted and the following log message for the 38_LIRC_DCE.newlog
Code: newbielink:javascript:void(0); [nonactive]
10      11/16/05 21:24:13.415           LIRC button: Forward will fire: 0 -106 1 203
10      11/16/05 21:24:13.415           LIRC button: Rewind will fire: 0 -106 1 202
10      11/16/05 21:24:13.415           LIRC button: Pause will fire: 0 -106 1 190
lircd: no process killed
10      11/16/05 21:24:13.422           Running modprobe lirc_dev
10      11/16/05 21:24:13.426           Running modprobe lirc_i2c
10      11/16/05 21:24:13.430           Making hardware config
01      11/16/05 21:24:13.430           No SerialPort selected and no default entry found. Exiting.
Return code: 0
Wed Nov 16 21:24:13 CST 2005 died


Obviously there will be no SerialPort needed since the IR Receiver is plugged into the PVR250 card.  

I then even tried to change the settings in the LIRC DCE Template to not require Serial Port, but this does not change the above error message.  

How does one go about getting a none serial port based LIRC Receiver working under pluto.  I believe that this is the only part of the installation that I am missing.

Thank you,
Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
LIRC for PVR250 Card unable to get working
« Reply #1 on: November 17, 2005, 08:14:32 pm »
That "SerialPort" should really say "/dev entry". In "Device", instead of "hauppauge", type "/dev/lirc0" and reload the router. This should do the trick.

If not, create a /etc/udev/rules.d/lirc.rules file with this content:
Code: newbielink:javascript:void(0); [nonactive]
KERNEL="lirc[0-9]*",    NAME="lirc/%n"and type
Code: newbielink:javascript:void(0); [nonactive]
/etc/init.d/udev restart and then reload the router.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
This is not working either
« Reply #2 on: November 28, 2005, 06:16:08 am »
Quote
That "SerialPort" should really say "/dev entry". In "Device", instead of "hauppauge", type "/dev/lirc0" and reload the router. This should do the trick.

This gives the following error when I run /usr/pluto/bin/LIRC_DCE -d 38 -r localhost

Code: newbielink:javascript:void(0); [nonactive]
lircd: no process killed
10      11/27/05 23:05:15.863           Running modprobe lirc_dev
10      11/27/05 23:05:15.870           Running modprobe lirc_i2c
10      11/27/05 23:05:15.877           Making hardware config
10      11/27/05 23:05:15.878           No SerialPort selected, selecting default /dev/lirc
10      11/27/05 23:05:15.878           ->Using Driver /dev/lirc0 in database
10      11/27/05 23:05:15.880           Added remote rs15-2116-vcr0081 device 41 layout B
Driver `/dev/lirc0' not supported.
Supported drivers:
        audio_alsa
        bte
        bw6130
        creative
        creative_infracd
        default
        dev/input
        dsp
        dvico
        ea65
        livedrive_midi
        livedrive_seq
        logitech
        mp3anywhere
        mouseremote
        mouseremote_ps2
        null
        pcmak
        pinsys
        pixelview
        silitek
        tira
        udp
        uirt2
        uirt2_raw
05      11/27/05 23:05:15.889           Creating Leeching Thread for 1 remotes
10      11/27/05 23:05:15.890           Connect OK
irexec: could not connect to socket
irexec: Connection refused

obviously "Devices should be a driver, but unfortunately if I put default I get the following errors
Code: newbielink:javascript:void(0); [nonactive]
lircd: no process killed
10      11/27/05 23:07:29.026           Running modprobe lirc_dev
10      11/27/05 23:07:29.034           Running modprobe lirc_i2c
10      11/27/05 23:07:29.041           Making hardware config
10      11/27/05 23:07:29.041           No SerialPort selected, selecting default /dev/lirc
10      11/27/05 23:07:29.041           ->Using Driver default in database
10      11/27/05 23:07:29.044           Added remote rs15-2116-vcr0081 device 41 layout B
05      11/27/05 23:07:29.051           Creating Leeching Thread for 1 remotes
10      11/27/05 23:07:29.052           Connect OK
10      11/27/05 23:07:29.053           Leeching
10      11/27/05 23:07:29.053           Requesthandler 0x806c828 (device: 38) runThread now running
05      11/27/05 23:07:29.053           Lost connection with lircd

I am unable to figure this out, and I am not exactly sure why.

Any additional help would be appreciated. Here is some additional information
Code: newbielink:javascript:void(0); [nonactive]
ls -asl /dev/lirc*
0 crw-r--r--  1 root root 61, 0 2005-11-27 22:31 /dev/lirc
0 srw-rw-rw-  1 root root     0 2005-11-27 23:07 /dev/lircd


I am not sure exactly, but I believe the driver that this card needs is lirc_i2c which unfortunately is not available.

Thanks appreciated,
Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Problem solved
« Reply #3 on: December 02, 2005, 06:35:00 pm »
I am happy to report that the problem appears to be resolved.

Here are the two things that I had to do to get this working. The settings are as follows:

#1 Device(string): default
#120 System Device(string): lirc_i2c
#?? SerialPort: 0

I am not infront of the computer to give the exact number, but using the udev rules the device that gets created is /dev/lirc/0  The Serial Port setting is very misleading due to the fact that it is really the device to be used.

I was also have an IRQ issue regarding the way the kernel and the BIOS were assigning IRQ's  this was fixed by adding the following to the grub boot options.
delete all of the existing option except
Code: newbielink:javascript:void(0); [nonactive]
ro
then I had to add
Code: newbielink:javascript:void(0); [nonactive]
pci=usipcimask irqpoll

I believe the last option is the most important, but I am not going to debug since I have a working system.  

Thanks,
Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
LIRC for PVR250 Card unable to get working
« Reply #4 on: December 27, 2005, 07:57:27 am »
Mind providing a short step-by-step for those of us trying to get this receiver working?  I get lost in a lot of those references.

Thanks!