Author Topic: Making MYTHTV Interlace settings STICK after reboot or restart router  (Read 1518 times)

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
I have an issue with MYTHTV not retaining the Interlace settings that I choose. Everytime when LMCE comes up after a reboot or restart router I have to re-do my customizations for interlacing. 

In MythtV I go to Settings - Playback - and uncheck the Interlacing mode option.  But when I reboot or restart the router it always goes back to the previous setting which is use Interlacing with Xv and BOB filtering.  I have problems with BOB causing stuttering in playback so I don't want to keep that setting.  I've tried to see where to set this in LMCEadmin permanently and in the MythTV global settings using http://dcerouter/mythweb.

This would seem to be a simple problem to resolve but I can't seem to find out how to fix it.  Thanks for any input.
-Fins





orionsune

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #1 on: March 05, 2008, 05:49:07 am »
I have also been plagued by this very same problem.

I found this in the source...

UpdateMythSetting("DeinterlaceFilter","bobdeint","*");

I guess i'll try changing it to "kernel" and recompile... i'll let ya know
« Last Edit: March 05, 2008, 06:14:28 am by orionsune »
entia non sunt multiplicanda praeter necessitatem

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #2 on: March 05, 2008, 03:56:44 pm »
Ok, I appreciate that.  I'm going to look for an answer over at the mythtv forum when I get a chance.

orionsune

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #3 on: March 05, 2008, 10:19:59 pm »
[SOLVED]
The code change I made and recompiling worked.

My settings stick now... an alternative is to completely remove those lines.

Now I have been trying to get lmce working the way I expect it to for a while now, and have been very successful on just about every challenge i'm faced with.  In other words, i'm no amatuer, maybe not quite a professional either, but I feel like asking a question about the MythTV_Player plugin.

Why exactly are the settings set statically in the code?  Why in the world would you do something like that?  What if BOB interlacing is incompatible somebodies screen, what are they supposed to do?  Manually go into mythfrontend from the kde desktop each time MythTV_Player is spawned/respawned?  The same goes for any of those options that were set statically, the OpenGL vsyncing?  I actually found that turning that ON, made a HUGE difference in jitter, it removed just about all my jitter.  I understand this option may work for some, and not others, but again, why set it statically?  Shouldn't the end user ultimately be the decision in which setting he prefers to use?  Or as previously stated, which setting the computer is going to work best with?  I seriously can't understand why those are hardcoded.  I am not trying to criticize, I sware, I honestly would like to know if there is a legitimate reason for it, maybe something I don't know about?  Maybe another component of lmce that doesn't work well with settings other than those hardcoded in the plugin?
entia non sunt multiplicanda praeter necessitatem

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #4 on: March 05, 2008, 11:04:09 pm »
It is certainly a good question... and why it feels it need to set it every time as well - therefore preventing people making configuration changes....

I don't think that you will get an answer here though. You could ask the same question on the Pluto forums and see if one of the original developers answers - might take a while though.

orionsune

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #5 on: March 05, 2008, 11:24:04 pm »
Aha! Ok, thanks, I didn't even think about the fact you guys didn't develop the plugin to start with...  Big doh on me.  But no seriously, that question is not meant to criticize, I will absolutely ask this question on their forums.  I seriously need to know if there is another aspect of the system that maybe doesn't work with any other option then those specified in the code.   For example (not that it's happened) but maybe on their development system, myth kept locking up when overlaying the lmce interface, and the only solution was to use bob interlacing and disable opengl vsync... I can understand that, but to assume EVERYBODY is going to have the same problem is not wise.  So anyways, i'd just like clarification, because if it is going to cause problem in other packages then it would save me some trouble in the long run if ever I run into that incompatibility.

*shrugs* whatever it's all speculation, and my mythtv doesn't freeze anymore so I guess I shouldn't care, but it keeps itching me... there has GOT to be a reason why those settings were hard coded... programmers don't do stuff like that for "shits and giggles" i don't believe.
entia non sunt multiplicanda praeter necessitatem

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #6 on: March 06, 2008, 02:29:10 am »
Orionsune:

Would you mind explaining (maybe in a wiki) the steps necessary to fix this.  I'm just learning linux and I understand what rebuilding the kernel implies but....I don't have a clue how to acutally do it...but I am a fast learner.  Thanks.


purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Making MYTHTV Interlace settings STICK after reboot or restart router
« Reply #7 on: April 07, 2009, 03:31:17 pm »
I have also been plagued by this very same problem.

I found this in the source...

UpdateMythSetting("DeinterlaceFilter","bobdeint","*");

I guess i'll try changing it to "kernel" and recompile... i'll let ya know

Could somebody please explain to me what "the source" is in this context, and how do I open "the source" to edit any lines of code? Do I remove this line of code, or change it to "kernel" as suggested? Cheers.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps