Archive > Xine Player - Users

(Solved) Xine won't play any mp3 or dvx files after .32

<< < (2/2)

archived:
Short update:

knoppix booted fine, I mounted /home partition and I was able to play divx and mp3 files.

So hardware is OK (at least some good news ...), and the problem is related to some strange thing in pluto/debian

Any help is greatly appreciated ... not really keen to rebuild my box again ...

TIA
Marco

archived:

--- Quote from: "MarcoZan" ---Hi Rob and thanks for your help.

I have already checked xine.conf and settings are like yours.
I also tried to take down all pluto stuff and start xine from command line.
The result is that video is played, but no audio.

Then I rebooted my box, and during reboot I noticed the following error:


--- Code: ---
alsactl: set_control:909: failed to obtain info for control #50 No such file or directory)

--- End code ---


So IMHO there is also an issue related to alsa.

I tried to issue

--- Code: ---
alsactl store

--- End code ---

in order to rebuild /var/lib/alsa/asound.state and then rebooted again.

--- End quote ---

Hi,

I'm not at home, but I think I'm seeing same error, although my sound works ok....


--- Quote from: "MarcoZan" ---
The previous error during boot has disappeared, nevertheless in xine device log nothing has changed and I'm still not able to play anything.

Just to add more info, the day before yesterday I made some tests recompiling kernel and modules. AFAIK this should not affect any particular device, as long as the proper kernel - modules set is loaded.
In fact here modules appears to load properly, just conf data are wrong and this sounds strange.

I'm going to reboot my box with knoppix, just to make sure that hardware is not faulty.

Has anyone some hints form me?

TIA
Marco

--- End quote ---

 May I suggest trying aplay or even alsaplayer. Aplay (alsa command line player) has some verbose options that would maybe help you.

Also you can explore cat /proc/asound and then cards, etc... (or something like that).

What if perhaps some other device is taking your alsa device - I know that Asterisk could take alsa device for you ? Aplay will certainly show that for you ...

HTH,

regards,

Rob.

archived:
To test if the drivers are loaded and working, install mpg123 and play an mp3 with it. If you don't hear sound, then they don't work.

archived:
I found the problem.

For some (yet) unknown reasons all sound devices in /dev have been deleted.

So I recreated them with /usr/share/alsa-base/snddevices and this did the trick.

Now I can play all media files like before.

I didn't try to reboot to see whether devices are still there or if there is something deleting them on reboot. But this is anyway beyond the scope of this forum.

Thanks to all for your support.

Regards
Marco

Navigation

[0] Message Index

[*] Previous page

Sitemap 
Go to full version