Author Topic: PXE boot just keeps rebooting..  (Read 3608 times)

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
PXE boot just keeps rebooting..
« on: February 24, 2008, 09:36:29 pm »
I'm trying to PXE boot my computer. It starts just fine, announces itself to the router and a few seconds later restarts the computer. Then the network boot starts all over again, repeat...
It happens so fast that I can't really read everything. I can see however it says "Rebooting"

Is there a log I can check to determine what is causing it to continually reboot?

thanks,
Jon

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: PXE boot just keeps rebooting..
« Reply #1 on: February 24, 2008, 10:04:01 pm »
I had a similar issue and just tried looking for the forum where someone posted the solution that worked for me.  I have an Asus A7N8X with a 3com nic and a NVIDIA nic that I use as a MD.  If you have 2 NIC's as I do, try disabling one of them in the BIOS and see if that solves your problem.

If that doesn't work, I think in the core you can prepare the core for a MD if you have the mac address of the nic you are going to use.  If I remember, this was no longer necessary after 0704- I have yet to have to do this to get a MD to work.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: PXE boot just keeps rebooting..
« Reply #2 on: February 25, 2008, 02:28:39 am »
I have several md's working, definately disable any additional nics also try turning off apic in bios
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: PXE boot just keeps rebooting..
« Reply #3 on: February 25, 2008, 03:23:56 am »
The computer does have 2 nics - but one is disabled already (the onboard one).
I'll try to disable apci tomorrow when I get home.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: PXE boot just keeps rebooting..
« Reply #4 on: February 25, 2008, 04:46:59 am »
You may want to delete the md in webmin. and try again

My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

Monkgs

  • Veteran
  • ***
  • Posts: 72
    • View Profile
Re: PXE boot just keeps rebooting..
« Reply #5 on: September 09, 2008, 06:54:26 am »
Adding some info and a quick fix for this problem.

Basically, when a computer PXE boots it loads a configuration file from the tftp server which tells the boot loader what settings and what kernel to load. This configuration file is assigned based on MAC address. If for whatever reason the MAC address stored in the Pluto database does not match the MAC address used by the PXE boot rom of your NIC, then this configuration file never gets loaded and your computer will continuously boot the "first time setup" configuration file.

This is a big issue with some newer nForce chipsets. Older nForce NICs had a firmware bug that caused the MAC address to be stored in reversed order. The Linux driver solved this issue by reordering the MAC bits so they were in the correct order. With the newer nForce NICs, the firmware was changed so the order was no longer reversed. The driver however still reverses the MAC bits, so the result is a reversed MAC in the OS.

There is a fairly easy way to fix this. You'll need your NIC's MAC address from the PXE boot rom, NOT from the Linux boot messages. This will usually be displayed when the PXE boot sequence tries to get an IP. Mine was "01:1F:D0:83:EA:AE".

You'll also need to know your MD's device number. This is displayed before the system reboots. It will say "Assigned permanent IP '192.168.0.100' to device '54'" or similar. Write down what number it says after device. This is your device number.

On the core, as root, go into the folder "/tftpboot/pxelinux.cfg". Look for the file that contains the device number matching your MD. Using 54 as an example, you would look for the line "KERNEL 54/vmlinuz". This file is the configuration info your MD is SUPPOSE to load, but isn't. In my case the file was "01-ae-ea-83-d0-1f-00". Notice how it's the opposite of the MAC address I got from the PXE boot above. In your case it might not be the opposite.

Each file is named after the MAC address of the client it belongs to, and is prefixed by "01-". You'll want to symlink the configuration file to a new filename, which matches the MAC address you wrote down earlier.

Using my information as an example, I would do this: "ln 01-ae-ea-83-d0-1f-00 01-00-1f-d0-83-ea-ae". You may use a symlink instead, if you do not intend to apply the immutable attribute (below).

A quick reboot and my MD is up and running. I'm not entirely sure if the pxelinux.cfg folder is ever wiped and regenerated from the database. As a precaution against scripts removing your link, you may make it immutable by issuing "chattr +i 01-00-1f-d0-83-ea-ae".