Author Topic: mythtv-backend in 0704 & 0710 crashing or having problems  (Read 883 times)

deffcon

  • Veteran
  • ***
  • Posts: 94
    • View Profile
mythtv-backend in 0704 & 0710 crashing or having problems
« on: December 31, 2007, 01:55:05 am »
Hi,

Just a small question, does someone has problems with analog or maybe even with digital tuner cards the problem that when you're switching from one channel to antoher that the mythtv-backend  crashes or even dies? So what i did to test something and maybe someone has an better idea then me, i just killed ( just for testing purposes ) the mythtv-backend proccess, and just in my terminal connected to my laptop ( to see whats happening ) spawned mythbackend ( so not mythtv-backend --> its only a wrapper and ads some logging to /var/log/mythtv/mythbackend.log and a pid number to kill it in my case ) and just what i thought and i really don't why but it rapidly speeds up mythtv and for sure switching channels with my hauppage pvr-500, and the most important thing off all -----> i switched back and forth with my channels for nearly then minutes and it didn't crashed a single time.

Hope that someone also found this and can tell us more about it ( maybe some scripting )

Happy to share stuff

Dave

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: mythtv-backend in 0704 & 0710 crashing or having problems
« Reply #1 on: December 31, 2007, 02:50:41 am »
Hi,

Just a small question, does someone has problems with analog or maybe even with digital tuner cards the problem that when you're switching from one channel to antoher that the mythtv-backend  crashes or even dies? So what i did to test something and maybe someone has an better idea then me, i just killed ( just for testing purposes ) the mythtv-backend proccess, and just in my terminal connected to my laptop ( to see whats happening ) spawned mythbackend ( so not mythtv-backend --> its only a wrapper and ads some logging to /var/log/mythtv/mythbackend.log and a pid number to kill it in my case ) and just what i thought and i really don't why but it rapidly speeds up mythtv and for sure switching channels with my hauppage pvr-500, and the most important thing off all -----> i switched back and forth with my channels for nearly then minutes and it didn't crashed a single time.

Hope that someone also found this and can tell us more about it ( maybe some scripting )

Happy to share stuff

Dave
iirc that race condition is fixed in the newest mythtv patches but they are not yet included in the beta.

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

deffcon

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Re: mythtv-backend in 0704 & 0710 crashing or having problems
« Reply #2 on: February 16, 2008, 09:37:54 am »
Hi,

I've installed the Beta 3 successfully, but what i noticed was that in beta something changed in mythtv, now i have even worse problems with this beta 3, for instance,

Beta 3 --> mythtv --> hauppage pvr 500 mce :

- no sound
- changing channels takes really long, and when changed the video is terrible slow.

Can someone tell me what this all is, because i really lost it, i don't wanna go back to mythbuntu because i got used to use linuxmce, but mythbuntu i can watch tv and in linuxmce not.

Please can someone help me?


Dave