Author Topic: Bug: Private data not private! Please confirm...  (Read 982 times)

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Bug: Private data not private! Please confirm...
« on: February 10, 2008, 03:49:14 am »
I have been testing out 710 beta 3 for a couple of days now, and noticed that none of the security features work.

My system has 5 users. I have a core/hybrid and a touchscreen WinXP orbiter.
I can change the user and the room at will on the orbiter without using a pin, even though I have been through and set up all web admin privacy settings under:
Advanced->Privacy Settings->Users - Orbiters
Advanced->Privacy Settings->Users - Rooms
Advanced->Privacy Settings->Restrict Access

I have also noticed that i can access all private media. All of my media is stored on an internal Raid 5 array, set to use "Pluto's Structure"
However, if I change to User_A and rip a DVD to public, then change to User_B and rip to private - I can change back to User_A and User_B's private media is under my videos.
Also, I have noticed another problem in this area.....  Lets say I change back to User B, and on the orbiter go Media->Videos. Then I hit Options...  Under "User:", I can select from Public and User_A. This is wrong!  I should be able to select from Public and User_B!

Can someone else please confirm these bugs? If so, I will get them into mantis

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Bug: Private data not private! Please confirm...
« Reply #1 on: February 10, 2008, 07:21:37 pm »
Can anyone confirm that this is a bug?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Bug: Private data not private! Please confirm...
« Reply #2 on: February 10, 2008, 11:49:02 pm »
Sorry Jon - don't know the status of this. But I do know that it has been brought up before - it definitely was a bug, sounds like it still is. Can you do us a favour? Search through mantis.linuxmce.org and determine if it has been formally logged as an issue...

If not, log it with all the detail and examples you can. We obviously want this resolved, and you have the most recent experience. Nothing will get fixed unless it is logged in Mantis....

Col.

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Bug: Private data not private! Please confirm...
« Reply #3 on: February 11, 2008, 12:14:47 am »
I will do that. I have a stack of bugs I found today that I' m about to add...