Author Topic: How to correctly enable Option "UseEDID" in diskless MD's xorg.config?  (Read 2678 times)

Hipper

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
I have two Dell Latitude laptops that I am planning on using as diskless media directors and I have them successfully running 0704 UI2 with overlay. The systems have Geforce4 440 Go 32MB cards which work great with a "tweak" to the xorg.config, which leads to my question.

When I run the initial UI and sound wizard and select the output type and resolution (DVI and 1280x1024) everything works fine. However, after the wizard runs and builds the config and switches to X windows the screens go "fuzzy" like the frequency of the display config is wrong. To solve this I let the systems sit for a wile with the display switch to another terminal (so not to hurt the hardware) to allow the UI to be rendered by the MCE manager (if the UI does not fully render then I have to rebuild it later or the UI wont work right). While they sit rendering I switch to the core and edit the diskless images xorg.config (i.e. /usr/pluto/diskless/[number]/etc/X11/xorg.config). The change that I have to make is to enable EDID which results in me commenting out the two lines in the config file that set the UseEDID option to false. After that I have to edit the diskless image's XConfigure.sh to exit as soon as it starts so that it does not change the config on me when the system boots up. Once I hear the setup wizard girl's voice I reboot the system and everything works fine.

So hears the real question, is this the preferred way to configure a media director's xorg.conf? It seams like a hack and the other night when I got an update the core some how reset the MD's configuration and I had to re-edit the xorg.config and XConfigure.sh scripts. How can I go about editing the X config to suit my needs and not have MCE step on top of my changes? Ideally, I would like to setup the systems to be correct before X runs for the first time so that I don’t have to do any rebooting. Could I simply edit the MCE database to have the correct setting for my hardware when it is recognized by the setup wizard? Also, is using the EDID of the hardware going to cause me any other issues with LMCE, such as bad or slow or incorrect rendering of images?

Note:
Here's the definition of the option that I have to enable to get the correct display output for X. Which leads me to believe that the mode line values set by LMCE don’t work for my hardware but the EDID tells X the correct values.
Quote
By default, the NVIDIA X driver makes use of a display device's EDID, when available, during construction of its mode pool. The EDID is used as a source for possible modes, for valid frequency ranges, and for collecting data on the physical dimensions of the display device for computing the DPI. However, if you wish to disable the driver's use of the EDID, you can set this option to False:
« Last Edit: February 08, 2008, 11:41:41 pm by Hipper »

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: How to correctly enable Option "UseEDID" in diskless MD's xorg.config?
« Reply #1 on: February 09, 2008, 11:48:31 pm »
Actually, by default the xorg.conf file has UseEDID set to false. If you want it to use EDID probing, you can set it to true. This can cause more trouble than its worth if the display device reports invalid values (they often do!) but at least you can then read your /var/log/Xorg.0.log file and see what is going on in more detail.

Don't know about diskless MDs, but I'm assuming you just edit the same file in the boot folders for those MDs, on your core. And if you want to stop LMCE from changing your settings, put "exit" on the second line of your XConfigure scripts for each of the MDs (not the core of course).

Hipper

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: How to correctly enable Option "UseEDID" in diskless MD's xorg.config?
« Reply #2 on: February 11, 2008, 08:15:29 pm »
Using EDID for the video cards is the only way I could find to get the correct values and having it enabled seam to work just fine.

To enable EDID am doing exactly what you (and the Wiki)  are suggesting but it looks like I may have to do that every time LMCE updates my core and MD's. The last LMCE auto update overwrote the XConfigure.sh and xorg.config files for all the MD diskless images thus requiring me to re-edit the files.

What I'm really looking for a way to tell LMCE to configure specific hardware in a specific way. I would like to add the hardware config, such as a template that will tell LMCE to use "X" settings when you find "Z" hardware, is this possible?