Author Topic: What is this - Connection to plutohome.com/new_installation.php  (Read 679 times)

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
What is this - Connection to plutohome.com/new_installation.php
« on: January 30, 2008, 11:12:05 am »
Trying to reinstall my beta3 setup sinced it crashed completely yesterday.
I´m not able to do that. After dvd is copied and rebooted.

It keep complaing about,
Cannot connect to plutohome.com/new_installation.php
plutohome.com is no avaialble at the moment. Tried with "telnet pluthome.com 80" from my freshly instaled hybrid.
Other websites are wokring fine so th eproblem is isolated to just plutohome.com.

Ahh. After about 25 tries it moved on now.

But the question is still.
What data is is sent to pluto or what data is expected to be recieved?
(I know that earlier 2.0.0.3x versions needed a type of installation id entered manually)

/niz23

kir

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: What is this - Connection to plutohome.com/new_installation.php
« Reply #1 on: January 30, 2008, 03:05:56 pm »
As far as I known, this is mostly a counter that provides the ID for the new installation - the value that becomes PK_Installation in /etc/pluto.conf. It is also probably used for the remote access provision (if RA is enabled).

Don't know if there is any information sent to Pluto - probably you can grep sources and see what the exact query is (if it is something more than simple wget).

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: What is this - Connection to plutohome.com/new_installation.php
« Reply #2 on: January 30, 2008, 03:22:47 pm »
As far as I known, this is mostly a counter that provides the ID for the new installation - the value that becomes PK_Installation in /etc/pluto.conf. It is also probably used for the remote access provision (if RA is enabled).

Don't know if there is any information sent to Pluto - probably you can grep sources and see what the exact query is (if it is something more than simple wget).

Kir.
Thanks for your answer.

What do this mean in reality. PK_Installation got set to 1 since the setup/config could not connect to plutohome.com at time of install. My previous install had 55xxx something.
Is RA the only thing affected?

Will dig through the code an see what it actually do.

Can PK_Installation be changed later on? Dont know why i would like to do that....

/niz23

kir

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: What is this - Connection to plutohome.com/new_installation.php
« Reply #3 on: January 30, 2008, 03:34:41 pm »
Continuing on this: the script that asks for the installation ID is the http://svn.linuxmce.com/pluto/trunk/src/BootScripts/ConfirmInstallation.sh , it contains the following code:

Code: [Select]
#!/bin/bash

. /usr/pluto/bin/Config_Ops.sh
. /usr/pluto/bin/SQL_Ops.sh

if [[ $OfflineMode == "true" ]]; then
        # We are in offline mode, we can't do that wget
        exit 0
fi

Q="SELECT COUNT(*) FROM Installation WHERE PK_Installation=1"
R=$(RunSQL "$Q")
if [[ "$R" -ne 0 ]]; then
        NewInstNumber=$(wget --timeout=10 -O - http://plutohome.com/new_installation.php)
        if [[ -n "$NewInstNumber" ]]; then
                /usr/pluto/bin/sqlCVS -t Installation -O 1 -N "$NewInstNumber" change_key
                ConfSet PK_Installation "$NewInstNumber"
                mv /usr/pluto/orbiter/floorplans/inst{1,$NewInstNumber}
        fi
fi

So, it doesn't send anything to Pluto :) And answering to your question, it seems to be safe to re-run it once again from console - so it will update the Installation ID

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: What is this - Connection to plutohome.com/new_installation.php
« Reply #4 on: January 30, 2008, 04:56:42 pm »
Continuing on this: the script that asks for the installation ID is the http://svn.linuxmce.com/pluto/trunk/src/BootScripts/ConfirmInstallation.sh , it contains the following code:

Code: [Select]
#!/bin/bash

. /usr/pluto/bin/Config_Ops.sh
. /usr/pluto/bin/SQL_Ops.sh

if [[ $OfflineMode == "true" ]]; then
        # We are in offline mode, we can't do that wget
        exit 0
fi

Q="SELECT COUNT(*) FROM Installation WHERE PK_Installation=1"
R=$(RunSQL "$Q")
if [[ "$R" -ne 0 ]]; then
        NewInstNumber=$(wget --timeout=10 -O - http://plutohome.com/new_installation.php)
        if [[ -n "$NewInstNumber" ]]; then
                /usr/pluto/bin/sqlCVS -t Installation -O 1 -N "$NewInstNumber" change_key
                ConfSet PK_Installation "$NewInstNumber"
                mv /usr/pluto/orbiter/floorplans/inst{1,$NewInstNumber}
        fi
fi

So, it doesn't send anything to Pluto :) And answering to your question, it seems to be safe to re-run it once again from console - so it will update the Installation ID

Thanks a lot kir.

/niz23