Author Topic: Updates / Schedules Direct  (Read 1547 times)

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Updates / Schedules Direct
« on: January 30, 2008, 01:36:06 am »
It looks like an updated is needed to get schedules direct to work.  But I can't seem to get any updates to apply, or I have a different issue.

I have ran these commands per the forums for a manual update.

cd /usr/pluto/bin
sudo ./LMCEUpdate_DownloadXml.sh
sudo ./LMCEUpdate
(takes some time, but when complete...)
sudo ./LMCEUpdate_Apply.sh

Nothing seems to happen when any of them are entered.   How can I tell if I have the lastest updates, or how can I troubleshoot Schedules Direct.  It pulls down my lineup in the MythTV setup so I'm pretty sure I have I it setup right.
(Running 710B3 64Bit)

Thank you.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Updates / Schedules Direct
« Reply #1 on: January 30, 2008, 05:55:15 am »
That update was for 0704.
"Change is inevitable. Progress is optional."
-- Anonymous


jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #2 on: January 30, 2008, 03:42:20 pm »
I kinda suspected that.  Has anyone gotten schedules direct to work with 710B3?

I can pull the lineup down but I have nothing in the guide.  Not sure where to look for troubleshooting.  Anyone know of some logs I could look at or try to force the schedule in manually somehow so I can maybe see and error?

Thank you.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Updates / Schedules Direct
« Reply #3 on: January 30, 2008, 04:11:58 pm »
Go to mythweb:

 yourcioreip/mythweb 

edit the listings (click on wrench) and make sure the channels have xml id's then run mythfilldatabase.

If you need the xml id's  go zap2it and mouse over the channels in your area you can see the Id as part of the url.


(Anyone Know of a better solution for either part please advise)
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #4 on: January 30, 2008, 07:38:40 pm »
The mouse over didn't seem to work for me at zap2it, but I was able to generate a nice table by running a report on my lineup at Schedules Direct.

I've now entered the xmltvid for all my channels.  But I get errors running mythfilldatabase.  Here is the output I get (doesn't seem like it can login into the sql db.)


gaffney@dcerouter:~$ sudo mythfilldatabase

2008-01-30 12:33:44.171 Using runtime prefix = /usr

2008-01-30 12:33:44.210 New DB connection, total: 1

2008-01-30 12:33:44.224 Unable to connect to database!

2008-01-30 12:33:44.224 Driver error was [1/1045]:

QMYSQL3: Unable to connect

Database error was:

Access denied for user 'mythtv'@'localhost' (using password: YES)



QSqlQuery::exec: database not open

QSqlQuery::exec: database not open

2008-01-30 12:33:44.278 DB Error (KickDatabase):

Query was:

SELECT NULL;

No error type from QSqlError?  Strange...

2008-01-30 12:33:44.330 Failed to init MythContext, exiting.

2008-01-30 12:33:44.333 DataDirect: Deleting temporary files

gaffney@dcerouter:~$


tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Updates / Schedules Direct
« Reply #5 on: January 30, 2008, 07:56:08 pm »
Do you get the same results if you go into mythsetup within Linmce when you exit setup it asks to run mythfilldatabase.


What report did run at SD to get XML IDs
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #6 on: January 30, 2008, 11:51:59 pm »
I'll try it that way when I get home, but since I installed 710B3 everytime I would go in that way and exit it would ask me to if I wanted to run mythfilldatabase, I chose yes and the prompt goes away.  In 704 I could  aways see the script run, but not now.
Don't know if that's just a change from 704 to 710 or a problem,  I'll let you know later tonight.

As for Schedules Direct

Once you login, you will see your "Scheduled Lineups", to the right of your lineup in a maroonish color you'll see "edit" "report" and "Delte".   Selecting Report will give you the table with the XMLid.

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #7 on: January 31, 2008, 05:57:38 am »
No luck from the LMCE interface either,  I don't see any error, but I don't see anything at all.  It asks me if I want to run mythfilldatabase,  I say yes and it brings me back to the main screen and that's it.
Not sure where to check for error on that one.

I tried to run it manually again from a console  and now I get this.

gaffney@dcerouter:/var/log/mythtv$ sudo mythfilldatabase
2008-01-30 22:54:01.981 Using runtime prefix = /usr
2008-01-30 22:54:02.017 New DB connection, total: 1
2008-01-30 22:54:02.026 Unable to connect to database!
2008-01-30 22:54:02.027 Driver error was [1/1045]:
QMYSQL3: Unable to connect
Database error was:
Access denied for user 'mythtv'@'localhost' (using password: YES)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2008-01-30 22:54:02.085 DB Error (KickDatabase):
Query was:
SELECT NULL;
No error type from QSqlError?  Strange...
2008-01-30 22:54:02.140 Failed to init MythContext, exiting.
2008-01-30 22:54:02.145 DataDirect: Deleting temporary files
gaffney@dcerouter:/var/log/mythtv$                     

My SQL skill are not good, but maybe this will help (I'm probably not doing this right)

I took a look at the existing mysql dbs by doing this
mysql mysql
SHOW DATABASES;

I see this
mysql> SHOW DATABASES;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| asterisk           |
| asteriskcdrdb      |
| mysql              |
| mythconverg        |
| pluto_main         |
| pluto_media        |
| pluto_myth         |
| pluto_security     |
| pluto_telecom      |
+--------------------+
10 rows in set (0.00 sec)

I am assuming the mythfilldatabase command is trying to loginto the "pluto_myth" DB.
So I tried this command to manually log into the pluto_myth DB as user mythtv (based on the error).
"mysql -u mythtv -p pluto_myth"

It prompts for a password, I've tried the only password I have and it fails with the same
"Access denied for user 'mythtv'@'localhost"
I've also tried no password.

I no nothing about mysql, but maybe the password for the mythtv user needs to be reset?  But how do I know what it's suppose to be?
Or maybe I'm way off base here....
« Last Edit: January 31, 2008, 06:17:04 am by jgaffney »

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Updates / Schedules Direct
« Reply #8 on: January 31, 2008, 06:03:28 am »
did you run any kubuntu or other updates ??


add any non linuxmce sw etc.




My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #9 on: January 31, 2008, 02:19:57 pm »
I added the w64codecs for playing wmv files (it seemed to work for that).

I also seem to have a problem with cover art now, I'm suspecting it's related but I don't know where to find an erros on it.  When I go to Files&Media > Cover Art in webmin and select "Scan for Cover".  It returns a blank page, I've let that sit for a day thinking it would just take a while but it shouldn't take that long.  I'm assuming another sql issue?
« Last Edit: January 31, 2008, 02:33:59 pm by jgaffney »

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Updates / Schedules Direct
« Reply #10 on: January 31, 2008, 10:04:25 pm »
To make sure I didn't mess anything up.  I wiped my LMCE box and did a clean install from the DVD (710B3 amd64)
I'm still getting the same results.  I'm no sql expert but it sure looks to be a database permissions issue.  Maybe I should start a new thread on this?

Code: [Select]
linuxmce@dcerouter:~$ sudo mythfilldatabase
[sudo] password for linuxmce:
Sorry, try again.
[sudo] password for linuxmce:
2008-01-31 15:00:29.946 Using runtime prefix = /usr
2008-01-31 15:00:29.978 New DB connection, total: 1
2008-01-31 15:00:29.986 Unable to connect to database!
2008-01-31 15:00:29.987 Driver error was [1/1045]:
QMYSQL3: Unable to connect
Database error was:
Access denied for user 'mythtv'@'localhost' (using password: YES)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2008-01-31 15:00:30.043 DB Error (KickDatabase):
Query was:
SELECT NULL;
No error type from QSqlError?  Strange...
2008-01-31 15:00:30.099 Failed to init MythContext, exiting.
2008-01-31 15:00:30.102 DataDirect: Deleting temporary files
linuxmce@dcerouter:~$


grepico

  • Veteran
  • ***
  • Posts: 102
    • View Profile
Re: Updates / Schedules Direct
« Reply #11 on: January 31, 2008, 10:31:21 pm »
Tried the manual update instructions and I get this when running the second command.

dcerouter_55697:/usr/pluto/bin# sudo ./LMCEUpdate
LMCEUpdate, v.1
Visit www.linuxmce.com for source code and license information

Thu, 31 Jan 2008 11:14:18 -0800 Helper Script Started
I/O warning : failed to load external entity "/home/updates/updates.xml"
01      01/31/08 11:14:18.777           Failed to parse xml /home/updates/updates.xml <0xb77fe8e0>
05      01/31/08 11:14:18.777           UpdatesManager::init : XML parser error <0xb77fe8e0>
01      01/31/08 11:14:18.777           Updates manager failure. <0xb77fe8e0>
Thu, 31 Jan 2008 11:14:18 -0800 RECV :
dcerouter_55697:/usr/pluto/bin# Thu, 31 Jan 2008 11:14:18 -0800 Helper Script End