Author Topic: The update file is missing on the server  (Read 1967 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
The update file is missing on the server
« on: October 29, 2005, 04:22:19 am »
Hi,

I've managed to get hold of a IPAQ 5550, with bluetooth and wifi on it, also running PocketPC 2003. I've got the orbiter files onto it, and the orbiter starts. I've put in the device ID and IP address of the orbiter (is it meant to find these automatically?) and tried to start it.

I'm then getting a quick flash of the orbiter screen and the message:

Something went very wrong. We need to quit orbiter.

Log file:
Quote

13      10/29/05 4:29:07.322            TCPIP: Accepting incoming connection on socket 187, port 3450, from IP 192.168.5.232.
10      05/02/03 10:29:12.000   *DEV* 38        Device: 38 starting.  Connecting to: 192.168.5.15
10      05/02/03 10:29:12.000   *DEV* 38        Stage connect
10      05/02/03 10:29:12.000   *DEV* 38        About to cleanup Orbiter
10      05/02/03 10:29:12.000   *DEV* 38        Orbiter_PocketFrog: need to cleanup orbiter...
10      05/02/03 10:29:12.000   *DEV* 38        Orbiter cleanup finished
10      05/02/03 10:29:12.000   *DEV* 38        Orbiter_PocketFrog constructor.
10      05/02/03 10:29:12.000   *DEV* 38        Orbiter 001668E0 constructor
10      05/02/03 10:29:12.000   *DEV* 38        New orbiter created!
13      10/29/05 4:29:07.531            TCPIP: Accepting incoming connection on socket 188, port 3450, from IP 192.168.5.232.
10      10/29/05 4:29:07.533            Device 38 connected as foreign template 8
13      10/29/05 4:29:15.120            TCPIP: Accepting incoming connection on socket 189, port 3450, from IP 192.168.5.232.
10      10/29/05 4:29:15.122            Device 38 connected as foreign template 8
13      10/29/05 4:29:15.175            TCPIP: Accepting incoming connection on socket 192, port 3450, from IP 192.168.5.232.
10      05/02/03 10:29:20.000   *DEV* 38        Connect OK
08      10/29/05 4:29:15.211            Received Message from 38 (Windows CE PDA (Vert Display) / Living Room) to General Info Plug-in(4), type 1 id 239 Command:Request File And Checksum, parameters:
08      10/29/05 4:29:15.211              Parameter 13(Filename): /usr/pluto/bin/Orbiter_WinCE.dat
08      10/29/05 4:29:15.211              Parameter 91(Checksum):
08      10/29/05 4:29:15.211              Parameter 92(Checksum Only): 1
10      05/02/03 10:29:20.000   *DEV* 38        Orbiter SelfUpdate: starting
10      05/02/03 10:29:20.000   *DEV* 38        Requesthandler 001668E0 (device: 38) runThread now running
13      10/29/05 4:29:22.572            TCPIP: Accepting incoming connection on socket 193, port 3450, from IP 127.0.0.1.
10      10/29/05 4:29:22.573            Socket::ReceiveData failed, bytes left 0 m_Socket: 193 Incoming_Conn Socket 193 127.0.0.1
10      10/29/05 4:29:22.573            Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Incoming_Conn Socket 193 127.0.0.1
05      10/29/05 4:29:22.573            TCPIP: Closing connection to -1 (Router Dev #0) 0x8881c78 m_Socket: -1
05      10/29/05 4:29:22.573            Router::RemoveAndDeleteSocket 0x8881c78 -1
10      05/02/03 10:29:35.000   *DEV* 38        Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Event Dev #38
01      05/02/03 10:29:35.000   *DEV* 38        InternalSendCommand cannot send with return message.  Going to quit
01      05/02/03 10:29:35.000   *DEV* 38        The update file is missing on the server
10      05/02/03 10:29:35.000   *DEV* 38        Stage run
13      05/02/03 10:29:35.000   *DEV* 38        Exiting MessageQueueThread_DCECI thread...
05      05/02/03 10:29:35.000   *DEV* 38        Socket::ReceiveData m_Socket 7 m_bQuit 1
10      05/02/03 10:29:35.000   *DEV* 38        Socket::ReceiveString2 ReceiveData failed m_Socket: 7 Command_Impl1 Dev #38
10      05/02/03 10:29:35.000   *DEV* 38        Requesthandler 001668E0 (device: 38) Closing request handler connection
13      05/02/03 10:29:35.000   *DEV* 38        Exiting BeginHandleRequestThread thread...
10      05/02/03 10:29:40.000   *DEV* 38        About to quit EventLoop. Reload 0, ConnectionLost 0, Quit 1
10      05/02/03 10:29:40.000   *DEV* 38        Stage is now osQuit.


Any ideas?

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Debugging Orbiter running on a IPAQ 5550
« Reply #1 on: October 31, 2005, 07:54:55 am »
Hi,

Quote
I've managed to get hold of a IPAQ 5550, with bluetooth and wifi on it, also running PocketPC 2003. I've got the orbiter files onto it, and the orbiter starts. I've put in the device ID and IP address of the orbiter (is it meant to find these automatically?) and tried to start it.

The user only have to enter the IP address of the router. The device ID is detected automatically.

It seems that for some reason, Orbiter didn't received the response for "Request File and Checksum" command sent to router and it timed out after 30 seconds. I assume that your IPAQ uses wifi to communicate with the router, which is not very reliable ... Let's do this test: move your IPAQ near your access point and also disable "log to server" option; then start orbiter again. If it fails again, enable "log to server" and see if it's because it still times out.

Hope this helps.

Regards,
Chris M.