Author Topic: Orbiter failed to initialize OpenGL - 8400 GS  (Read 1157 times)

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Orbiter failed to initialize OpenGL - 8400 GS
« on: January 25, 2008, 10:26:02 pm »
Hello,

I had an nvidia 6200 PCI card working great with UI2 but could not get HD as it was a PCI card.  I replaced it with nividia 8400 GS PCI express and now I'm having driver issues.
I followed this to get the driver installed.
http://wiki.linuxmce.com/index.php/Display_Drivers
And it appeared to go OK and I can successfully run the AVWizard now.  However I can only launch UI1 successfully.  If I select UI2 I get the "Orbiter failed to initialize OpenGL"

I'm suspecting my xorg.conf if not correct but not sure how to fix it,  can anyone give me some advice. Here is my xorg.conf
I also tried the envy suggestion but that fails at install due to dependencies.
http://forum.linuxmce.org/index.php?topic=3368.0

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/etc/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "record"
        Load    "glx"
        Load    "xtrap"
        Load    "extmod"
        Load    "dbe"
        Load    "speedo"
        Load    "type1"
        Load    "int10"
        Load    "v4l"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        Modeline        "1024x768" 60.80 1024 1056 1128 1272 768 768 770 796
        HorizSync       20-500
        VertRefresh     59-61
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        #Option     "FPScale"                   # [<bool>]
        #Option     "FPTweak"                   # <i>
        #Option     "DualHead"                  # [<bool>]
        Identifier  "Card0"
        Driver      "nv"
        VendorName  "nVidia Corporation"
        BoardName   "Unknown Board"
        BusID       "PCI:2:0:0"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "false"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
        Option "DynamicTwinView" "false"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option          "ConnectedMonitor" "CRT"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "false"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
        Option "DynamicTwinView" "false"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option  "TVStandard"    "1024x768"
EndSection


Section "DRI"
        Mode    0666
EndSection


Section "Extensions"
        Option "Composite" "false"
        Option "RENDER" "true"
EndSection
[/sub]

negus

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Orbiter failed to initialize OpenGL - 8400 GS
« Reply #1 on: January 25, 2008, 10:48:04 pm »
u are running the xserver with the x86 driver. (nv). This driver has some problems with the glx/opengl.
Thats why lmce installes the nvidia-glx package of the kubuntu sources.
sh :/nvidia.....sh should work but it seams that your xorg.conf isn't updated correctly.

Backup it
  1) cd /etc/X11
   2) cp xorg.conf xorg.conf_backup
and than change
Quote
         Driver      "nv"
to
Quote
         Driver      "nvidia" 
.

If you still get problems with the driver try to find a howto in a kubuntu/ubuntu forum.
Would give you a link but i only know the german ubuntu side ( maybe it helps anyway : http://wiki.ubuntuusers.de/Nvidia-Grafikkarten/Manuelle_Treiberinstallation?highlight=%28Nvidia%29



« Last Edit: January 25, 2008, 10:50:30 pm by negus »

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Orbiter failed to initialize OpenGL - 8400 GS
« Reply #2 on: January 26, 2008, 12:08:24 am »
fyi - Changing it to "nvida" reslts in a black screen with my monitor telling me it can't display the video mode.  This is trying to get into the AVWizard (using the shift key during boot after the beeps)

I can startx and run kubuntu just fine, it's just the orbiter that fails so I'm *thinking* the driver is installed... maybe?

I never like dealing with linux vidoe drivers  >:(

« Last Edit: January 26, 2008, 12:12:12 am by jgaffney »

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Orbiter failed to initialize OpenGL - 8400 GS
« Reply #3 on: January 28, 2008, 04:41:12 pm »
The problem you seem to be experiencing (guessing here) is that the graphics card tries to drive your display at to high refresh rates.  This can be fixed by specifying more appropriate refresh rates (or modelines) in the xorg.conf file which is described on that wiki page.

What I usually do when having problems like that is to go through the AVWizard with the "vesa" driver (or maybe "nv" in your case if that works), and choose the UI I want.  Afterwards I neuter the Xconfigure script (as in the wiki) and tweak the xorg.conf by hand, often simply changing "vesa" back to "nvidia" (or fglrx for some of my machines).  Even when you change the resolution the launch manager usually picks up on it and will regenerate the Orbiter screens accordingly.
"Change is inevitable. Progress is optional."
-- Anonymous


jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Orbiter failed to initialize OpenGL - 8400 GS
« Reply #4 on: January 28, 2008, 07:29:33 pm »
I've decided to dump this card, I didn't see anyone out here using it in 710b3.  It wouldn't even display the kubuntu logo and progress bar during boot and after hours of driver installs and many different xorg configs I've replaced it with an nvidia Geforce 7300.

Just like that I have video.