Author Topic: problem on upgrading to .031  (Read 1366 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
problem on upgrading to .031
« on: October 25, 2005, 10:03:40 pm »
Hi,

it seems something is wrong on upgrading to 0.31 release....

in upgrade.log :
Code: newbielink:javascript:void(0); [nonactive]
Performing system update
Get:1 ftp://ftp.nerim.net unstable/main Packages
Err ftp://ftp.nerim.net unstable/main Packages
  Unable to fetch file, server said 'Can't open /debian-marillat/dists/unstable/main/binary-i386/Packages.gz: No such file or directory  ' [IP: 62.4.17.14 21]
Get:2 ftp://ftp.nerim.net unstable/main Release
Hit http://deb.plutohome.com sarge/main Packages
Ign ftp://ftp.nerim.net unstable/main Release
Hit http://www.geocities.com realextra/main Packages
Hit http://deb.plutohome.com sarge/main Release
Ign http://www.geocities.com realextra/main Release
Hit http://deb.plutohome.com sarge/non-free Packages
Hit http://deb.plutohome.com sarge/non-free Release
Hit http://deb.plutohome.com sarge/contrib Packages
Hit http://deb.plutohome.com sarge/contrib Release
Get:3 http://deb.plutohome.com 20dev/main Packages [9847B]
Ign http://deb.plutohome.com 20dev/main Release
Get:4 http://deb.plutohome.com replacements/main Packages [16.6kB]
Ign http://deb.plutohome.com replacements/main Release
Hit http://deb.plutohome.com unstable/mythtv Packages
Ign http://deb.plutohome.com unstable/mythtv Release
Err http://deb.plutohome.com 20dev/contrib Packages
  404 Not Found
Ign http://deb.plutohome.com 20dev/contrib Release
Failed to fetch ftp://ftp.nerim.net/debian-marillat/dists/unstable/main/binary-i386/Packages.gz  Unable to fetch file, server said 'Can't open /debian-marillat/dists/unstable/main/binary-i386/Packages.gz: No such file or directory  ' [IP: 62.4.17.14 21]
Failed to fetch http://deb.plutohome.com/debian/dists/20dev/contrib/binary-i386/Packages.gz  404 Not Found
Fetched 26.4kB in 8s (2969B/s)
Reading Package Lists...
E: Some index files failed to download, they have been ignored, or old ones used instead.
Reading Package Lists...
Building Dependency Tree...
The following packages will be REMOVED:
   amp (1.10.008-5)
   asterisk (1.0.7.dfsg.1.pluto.2-2)
   asterisk-addons (1.0.7-2)
   asterisk-oh323 (0.6.6pre3-3)
   asterisk-sounds-main (1.0.7.dfsg.1-2)
   ldap-utils (2.2.23-8)
   libpri1 (1.0.7-1)
   libtonezone1 (1.0.7-4.1)
   slapd (2.2.23-8)
The following NEW packages will be installed:
   asterisk-pluto (1.0.9-1)
   libcapi20-2 (3.6.2005-01-03-5)
   pluto-pluto-telecom-db (2.0.0.31)
   pluto-telecom-database (2.0.0.31)
The following packages have been kept back:
   pluto-lirc-wrapper (2.0.0.30 => 2.0.0.31)
The following packages will be upgraded:
   ansi2html (2.0.0.30 => 2.0.0.31)
   libxine-dev (1.0.1-1 => 1.0.2-0vdr1+net1)
   libxine1 (1.0.1-1 => 1.0.2-0vdr1+net1)
   msttcorefonts (1.2.pluto.3 => 1.2.pluto.4)
   pluto-app-server (2.0.0.30 => 2.0.0.31)
   pluto-asterisk (2.0.0.30 => 2.0.0.31)
   pluto-bluetooth-dongle (2.0.0.30 => 2.0.0.31)
   pluto-boot-scripts (2.0.0.30 => 2.0.0.31)
   pluto-cddb-ident (2.0.0.30 => 2.0.0.31)
   pluto-confirm-dependencies (2.0.0.30 => 2.0.0.31)
   pluto-convert-mac (2.0.0.30 => 2.0.0.31)
   pluto-createdevice (2.0.0.30 => 2.0.0.31)
   pluto-database-settings (2.0.0.30 => 2.0.0.31)
   pluto-dcecommon (2.0.0.30 => 2.0.0.31)
   pluto-dcerouter (2.0.0.30 => 2.0.0.31)
   pluto-devel-dependencies (2.0.0.30 => 2.0.0.31)
   pluto-dhcpd-plugin (2.0.0.30 => 2.0.0.31)
   pluto-disk-drive (2.0.0.30 => 2.0.0.31)
   pluto-diskless-base (2.0.0.30 => 2.0.0.31)
   pluto-eib (2.0.0.30 => 2.0.0.31)
   pluto-generic-serial-device (2.0.0.30 => 2.0.0.31)
   pluto-install-scripts (2.0.0.30 => 2.0.0.31)
   pluto-ivtv-video-drivers (2.0.0.30 => 2.0.0.31)
   pluto-libbd (2.0.0.30 => 2.0.0.31)
   pluto-libserial (2.0.0.30 => 2.0.0.31)
   pluto-local-database (2.0.0.30 => 2.0.0.31)
   pluto-makerelease (2.0.0.30 => 2.0.0.31)
   pluto-media-database (2.0.0.30 => 2.0.0.31)
   pluto-messagesend (2.0.0.30 => 2.0.0.31)
   pluto-messagetrans (2.0.0.30 => 2.0.0.31)
   pluto-motion-wrapper (2.0.0.30 => 2.0.0.31)
   pluto-mythtv-backend-proxy (2.0.0.30 => 2.0.0.31)
   pluto-mythtv-player (2.0.0.30 => 2.0.0.31)
   pluto-mythtv-plugin (2.0.0.30 => 2.0.0.31)
   pluto-orbiter (2.0.0.30 => 2.0.0.31)
   pluto-orbitergen (2.0.0.30 => 2.0.0.31)
   pluto-orbiterinstaller (2.0.0.30 => 2.0.0.31)
   pluto-pluto-main-db (2.0.0.30 => 2.0.0.31)
   pluto-pluto-media-db (2.0.0.30 => 2.0.0.31)
   pluto-pluto-security-db (2.0.0.30 => 2.0.0.31)
   pluto-plutoutils (2.0.0.30 => 2.0.0.31)
   pluto-qos (2.0.0.30 => 2.0.0.31)
   pluto-ra (2.0.0.30 => 2.0.0.31)
   pluto-ratpoison (2.0.0.30 => 2.0.0.31)
   pluto-remoteassistance (2.0.0.30 => 2.0.0.31)
   pluto-security-database (2.0.0.30 => 2.0.0.31)
   pluto-serializeclass (2.0.0.30 => 2.0.0.31)
   pluto-skins-basic (2.0.0.30 => 2.0.0.31)
   pluto-slim-server-streamer (2.0.0.30 => 2.0.0.31)
   pluto-sqlcvs (2.0.0.30 => 2.0.0.31)
   pluto-std-plugins (2.0.0.30 => 2.0.0.31)
   pluto-system-database (2.0.0.30 => 2.0.0.31)
   pluto-updateentarea (2.0.0.30 => 2.0.0.31)
   pluto-updatemedia (2.0.0.30 => 2.0.0.31)
   pluto-videolan-client (2.0.0.30 => 2.0.0.31)
   pluto-videolan-plugin (2.0.0.30 => 2.0.0.31)
   pluto-videolan-server (2.0.0.30 => 2.0.0.31)
   pluto-vipshared (2.0.0.30 => 2.0.0.31)
   pluto-website-admin (2.0.0.30 => 2.0.0.31)
   pluto-website-support (2.0.0.30 => 2.0.0.31)
   pluto-windowsce-libraries (2.0.0.30 => 2.0.0.31)
   pluto-xine-player (2.0.0.30 => 2.0.0.31)
   pluto-xine-plugin (2.0.0.30 => 2.0.0.31)
   xine-ui (0.99.3-1 => 0.99.3-1ctvdr2)
64 upgraded, 4 newly installed, 9 to remove and 1 not upgraded.
Need to get 224MB of archives.
After unpacking 368MB of additional disk space will be used.
Get:1 http://deb.plutohome.com sarge/main libcapi20-2 1:3.6.2005-01-03-5 [37.5kB]
Get:2 http://deb.plutohome.com replacements/main asterisk-pluto 1.0.9-1 [9315kB]
Get:3 http://deb.plutohome.com 20dev/main pluto-asterisk 2.0.0.31 [1675kB]
Get:4 http://deb.plutohome.com 20dev/main pluto-videolan-server 2.0.0.31 [839kB]
Get:5 http://deb.plutohome.com 20dev/main pluto-mythtv-plugin 2.0.0.31 [2621kB]
Get:6 http://deb.plutohome.com 20dev/main pluto-dcerouter 2.0.0.31 [2252kB]
Get:7 http://deb.plutohome.com 20dev/main pluto-libserial 2.0.0.31 [52.2kB]
Get:8 http://deb.plutohome.com 20dev/main pluto-eib 2.0.0.31 [1595kB]
Get:9 http://deb.plutohome.com replacements/main libxine-dev 1.0.2-0vdr1+net1 [309kB]
Get:10 http://deb.plutohome.com replacements/main libxine1 1.0.2-0vdr1+net1 [3982kB]
Get:11 http://deb.plutohome.com 20dev/main pluto-xine-player 2.0.0.31 [2331kB]
Get:12 http://deb.plutohome.com 20dev/main pluto-orbiter 2.0.0.31 [4552kB]
Get:13 http://deb.plutohome.com 20dev/main pluto-app-server 2.0.0.31 [898kB]
Get:14 http://deb.plutohome.com 20dev/main pluto-bluetooth-dongle 2.0.0.31 [4895kB]
Get:15 http://deb.plutohome.com 20dev/main pluto-libbd 2.0.0.31 [201kB]
Get:16 http://deb.plutohome.com 20dev/main pluto-vipshared 2.0.0.31 [2308kB]
Get:17 http://deb.plutohome.com 20dev/main pluto-generic-serial-device 2.0.0.31 [3855kB]
Get:18 http://deb.plutohome.com 20dev/main pluto-messagetrans 2.0.0.31 [497kB]
Get:19 http://deb.plutohome.com 20dev/main pluto-website-admin 2.0.0.31 [918kB]
Get:20 http://deb.plutohome.com 20dev/main pluto-local-database 2.0.0.31 [7290B]
Get:21 http://deb.plutohome.com 20dev/main pluto-mythtv-player 2.0.0.31 [930kB]
Get:22 http://deb.plutohome.com 20dev/main pluto-install-scripts 2.0.0.31 [13.5kB]
Get:23 http://deb.plutohome.com 20dev/main pluto-std-plugins 2.0.0.31 [20.3MB]
Get:24 http://deb.plutohome.com 20dev/main pluto-system-database 2.0.0.31 [4990kB]
Get:25 http://deb.plutohome.com 20dev/main pluto-boot-scripts 2.0.0.31 [58.6kB]
Get:26 http://deb.plutohome.com 20dev/main pluto-messagesend 2.0.0.31 [105kB]
Get:27 http://deb.plutohome.com 20dev/main pluto-createdevice 2.0.0.31 [271kB]
Get:28 http://deb.plutohome.com 20dev/main ansi2html 2.0.0.31 [14.9kB]
Get:29 http://deb.plutohome.com 20dev/main pluto-updatemedia 2.0.0.31 [301kB]
Get:30 http://deb.plutohome.com 20dev/main pluto-pluto-security-db 2.0.0.31 [1626kB]
Get:31 http://deb.plutohome.com 20dev/main pluto-confirm-dependencies 2.0.0.31 [422kB]
Get:32 http://deb.plutohome.com 20dev/main pluto-orbitergen 2.0.0.31 [2401kB]
Get:33 http://deb.plutohome.com 20dev/main pluto-pluto-main-db 2.0.0.31 [30.8MB]
Get:34 http://deb.plutohome.com 20dev/main pluto-pluto-media-db 2.0.0.31 [3198kB]
Get:35 http://deb.plutohome.com 20dev/main pluto-devel-dependencies 2.0.0.31 [2092B]
Get:36 http://deb.plutohome.com 20dev/main pluto-security-database 2.0.0.31 [3892B]
Get:37 http://deb.plutohome.com 20dev/main pluto-media-database 2.0.0.31 [5284B]
Get:38 http://deb.plutohome.com 20dev/main pluto-sqlcvs 2.0.0.31 [2687kB]
Get:39 http://deb.plutohome.com 20dev/main pluto-videolan-client 2.0.0.31 [845kB]
Get:40 http://deb.plutohome.com 20dev/main pluto-videolan-plugin 2.0.0.31 [1584kB]
Get:41 http://deb.plutohome.com 20dev/main pluto-xine-plugin 2.0.0.31 [1627kB]
Get:42 http://deb.plutohome.com 20dev/main pluto-dcecommon 2.0.0.31 [2238kB]
Get:43 http://deb.plutohome.com 20dev/main pluto-serializeclass 2.0.0.31 [137kB]
Get:44 http://deb.plutohome.com 20dev/main pluto-plutoutils 2.0.0.31 [666kB]
Get:45 http://deb.plutohome.com 20dev/main pluto-ratpoison 2.0.0.31 [311kB]
Get:46 http://deb.plutohome.com 20dev/main pluto-database-settings 2.0.0.31 [2722B]
Get:47 http://deb.plutohome.com 20dev/main pluto-ra 2.0.0.31 [375kB]
Get:48 http://deb.plutohome.com 20dev/main pluto-pluto-telecom-db 2.0.0.31 [2159kB]
Get:49 http://deb.plutohome.com 20dev/main pluto-telecom-database 2.0.0.31 [3696B]
Get:50 http://deb.plutohome.com 20dev/main pluto-skins-basic 2.0.0.31 [36.2MB]
Get:51 http://deb.plutohome.com 20dev/main pluto-website-support 2.0.0.31 [2022kB]
Get:52 http://deb.plutohome.com 20dev/main pluto-diskless-base 2.0.0.31 [45.0MB]
Get:53 http://deb.plutohome.com 20dev/main pluto-qos 2.0.0.31 [2924B]
Get:54 http://deb.plutohome.com 20dev/main pluto-mythtv-backend-proxy 2.0.0.31 [1419kB]
Get:55 http://deb.plutohome.com 20dev/main pluto-dhcpd-plugin 2.0.0.31 [9276B]
Get:56 http://deb.plutohome.com 20dev/main pluto-convert-mac 2.0.0.31 [68.1kB]
Get:57 http://deb.plutohome.com 20dev/main pluto-updateentarea 2.0.0.31 [339kB]
Get:58 http://deb.plutohome.com 20dev/main pluto-orbiterinstaller 2.0.0.31 [4755kB]
Get:59 http://deb.plutohome.com 20dev/main pluto-windowsce-libraries 2.0.0.31 [48.2kB]
Get:60 http://deb.plutohome.com 20dev/main pluto-remoteassistance 2.0.0.31 [11.1kB]
Get:61 http://deb.plutohome.com 20dev/main pluto-cddb-ident 2.0.0.31 [787kB]
Get:62 http://deb.plutohome.com 20dev/main pluto-disk-drive 2.0.0.31 [892kB]
Get:63 http://deb.plutohome.com 20dev/main pluto-ivtv-video-drivers 2.0.0.31 [186kB]
Get:64 http://deb.plutohome.com 20dev/main pluto-makerelease 2.0.0.31 [269kB]
Get:65 http://deb.plutohome.com 20dev/main pluto-motion-wrapper 2.0.0.31 [934kB]
Get:66 http://deb.plutohome.com 20dev/main pluto-slim-server-streamer 2.0.0.31 [1400kB]
Get:67 http://deb.plutohome.com replacements/main msttcorefonts 1.2.pluto.4 [6844kB]
Get:68 http://deb.plutohome.com replacements/main xine-ui 0.99.3-1ctvdr2 [1732kB]
Fetched 224MB in 33m6s (113kB/s)
Selecting previously deselected package libcapi20-2.
(Reading database ... 66295 files and directories currently installed.)
Unpacking libcapi20-2 (from .../libcapi20-2_1%3a3.6.2005-01-03-5_i386.deb) ...
(Reading database ... 66301 files and directories currently installed.)
Removing asterisk-oh323 ...
dpkg: asterisk-addons: dependency problems, but removing anyway as you request:
 pluto-asterisk depends on asterisk-addons.
 amp depends on asterisk-addons.
Removing asterisk-addons ...
dpkg: amp: dependency problems, but removing anyway as you request:
 asterisk depends on amp.
 pluto-asterisk depends on amp.
Removing amp ...
dpkg: asterisk: dependency problems, but removing anyway as you request:
 pluto-asterisk depends on asterisk.
Removing asterisk ...
Stopping Asterisk PBX: asterisk.
Removing asterisk-sounds-main ...
dpkg - warning: while removing asterisk-sounds-main, directory `/var/spool/asterisk/voicemail/default' not empty so not removed.
dpkg - warning: while removing asterisk-sounds-main, directory `/var/spool/asterisk/voicemail' not empty so not removed.
dpkg - warning: while removing asterisk-sounds-main, directory `/var/spool/asterisk' not empty so not removed.
dpkg: libpri1: dependency problems, but removing anyway as you request:
 pluto-asterisk depends on libpri1; however:
  Package libpri1 is to be removed.
Removing libpri1 ...
Removing libtonezone1 ...
Selecting previously deselected package asterisk-pluto.
(Reading database ... 64371 files and directories currently installed.)
Unpacking asterisk-pluto (from .../asterisk-pluto_1.0.9-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/asterisk-pluto_1.0.9-1_i386.deb (--unpack):
 trying to overwrite `/usr/include/linux/zaptel.h', which is also in package zaptel-source
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/asterisk-pluto_1.0.9-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


It seems that there is a problem on overlapping with zaptel-source package... Strangely this message is mentioned here :

  newbielink:http://www.archivum.info/debian-bugs-closed@lists.debian.org/2005-04/msg00123.html [nonactive]

Any help ?

Thanks in advance,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
problem on upgrading to .031
« Reply #1 on: October 25, 2005, 10:13:44 pm »
This helped me to get going :

Code: newbielink:javascript:void(0); [nonactive]
apt-get remove zaptel zaptel-source pluto-asterisk zaptel-modules-2.6.10-1-686


I'm not sure if this will happen to anyone else....

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
problem on upgrading to .031
« Reply #2 on: October 26, 2005, 09:09:12 am »
You are first who reported this, I'm not sure how many people compile zaptel  drivers on their pluto installation.
Anyway we are upgrading asterisk-pluto package to verison 1.0.9-2 wich should solve upgrading from .30 to .31 for people who have zaptel, zaptel-source, zaptel-modules installed.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
problem on upgrading to .031
« Reply #3 on: October 26, 2005, 11:34:23 pm »
Quote from: "torindan"
You are first who reported this, I'm not sure how many people compile zaptel  drivers on their pluto installation.
Anyway we are upgrading asterisk-pluto package to verison 1.0.9-2 wich should solve upgrading from .30 to .31 for people who have zaptel, zaptel-source, zaptel-modules installed.


Hi,

I have further problems (is it just me?) on loading zaphfc module:
Code: newbielink:javascript:void(0); [nonactive]
dcerouter_260:~$ modprobe zaphfc
WARNING: Error inserting zaptel (/lib/modules/2.6.13.2-vanilla-pluto-1-686/zaptel/zaptel.ko): Invalid module format
WARNING: Error inserting zaptel (/lib/modules/2.6.13.2-vanilla-pluto-1-686/zaptel/zaptel.ko): Invalid module format
FATAL: Error inserting zaphfc (/lib/modules/2.6.13.2-vanilla-pluto-1-686/zaptel/zaphfc.ko): Invalid module format
FATAL: Error running install command for zaphfc


and in dmesg:


Code: newbielink:javascript:void(0); [nonactive]
zaptel: disagrees about version of symbol struct_module
zaphfc: disagrees about version of symbol struct_module


Any advice ?

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
problem on upgrading to .031
« Reply #4 on: October 27, 2005, 08:20:58 am »
You don't have asterisk-pluto installed. Those modules you try to insert are leftovers of your previos experiments with zaptel drivers.
Code: newbielink:javascript:void(0); [nonactive]
dcerouter_260:~$ dpkg -l 'asterisk-pluto'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                          Version                       Description
+++-=============================-=============================-==========================================================================
in  asterisk-pluto                1.0.9-1                       (no description available)


As you can see the status is : in - desired to install but not installed.

Please install the package manually, run "depmod -a" and then "modprobe zaphfc"