Author Topic: DVD Ripping Failed  (Read 5097 times)

chamo

  • Newbie
  • *
  • Posts: 6
    • View Profile
DVD Ripping Failed
« on: February 18, 2008, 05:45:09 am »
So when I tried to rip my first DVD movie on LinuxMCE it started just fine, it went from 1% to 100% after that it came back with a message on the screen that said
Quote
Ripping failed: /home/user_1/data/videos/Meet the Fockers

I have all the dvd libs and codecs. Movies play just fine on LinuxMCE so far the problem is only ripping them. The drive is a Lite-On DVD RW 20x SATA.

Any help would be appreciated.

Thanks!

Chamo

geoffrey

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Re: DVD Ripping Failed
« Reply #1 on: February 18, 2008, 07:32:07 am »
check out this wiki page.  i don't think ripping encrypted commercial DVDs is possible.

http://wiki.linuxmce.org/index.php/Rip_a_CD/DVD_to_the_Core

a possible alternate method would be to use the program Handbrake via the KDE desktop.  I use the Mac version and it rips CSS DVDs without difficulty.

http://handbrake.fr/
« Last Edit: February 18, 2008, 07:54:34 am by geoffrey »
Asus M2NSLI Deluxe
AMD Athlon 64 X2 BE-2400 2.3GHz
Asus EN6200TC512 Graphic Card
WinTV PVR-150 MCE
(2) Samsung T166 SATA II 500GB
Corsair TwinX 2GB CL5 DDR2-800

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: DVD Ripping Failed
« Reply #2 on: February 18, 2008, 12:59:07 pm »
check out this wiki page.  i don't think ripping encrypted commercial DVDs is possible.

http://wiki.linuxmce.org/index.php/Rip_a_CD/DVD_to_the_Core

a possible alternate method would be to use the program Handbrake via the KDE desktop.  I use the Mac version and it rips CSS DVDs without difficulty.

http://handbrake.fr/

Geoffrey - ripping encrypted DVDs is quite normal and perfectly possible. The wiki article you found is very old, don't know why it hasn't been updated - choosing to install the CSS library option you are presented with during the setup wizard decrypts the CSS encryption. Almost every commercial DVD movie you will find is encrypted, and almost all of them are rippable with LMCE (and most other systems).

That being said, there are some disks that have been known to cause problems, and anecdotally at least, this is possibly to do with various copy protection extensions that are being added to some DVDs. The answer is, try a few other DVDs. If they all fail, then it is likely that the CSS library isn't installed or isn't installed correctly. If most work except one, then it is probably just one of those DVDs.... rather than spend too much time on a single DVD, probably best to try ripping that particular one on another system then copying it over to LMCE...

kir

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: DVD Ripping Failed
« Reply #3 on: February 18, 2008, 01:08:53 pm »
So when I tried to rip my first DVD movie on LinuxMCE it started just fine, it went from 1% to 100% after that it came back with a message on the screen that said
Code: [Select]
Ripping failed: /home/user_1/data/videos/Meet the Fockers
I have all the dvd libs and codecs. Movies play just fine on LinuxMCE so far the problem is only ripping them. The drive is a Lite-On DVD RW 20x SATA.

Try to check if the DVD region is set properly on your drive, according to this wiki article: http://wiki.linuxmce.org/index.php/Setting_Region_of_DVD_Drive

Venom986

  • Veteran
  • ***
  • Posts: 74
    • View Profile
Re: DVD Ripping Failed
« Reply #4 on: February 18, 2008, 04:12:24 pm »
Also, I was having a similar problem, fixed my region code, still no luck.

I tried running /usr/pluto/bin/disk_copy manually and pointed it at /tmp to put the file in.  that worked.  I poked around /var/log/pluto/DCERouter.log.  I eventually discovered that i was getting an error when it tried to open /mnt/device/122/public/data/videos as that directory didn't exist yet.  Now, ripping a CD automatically created the audio directory so i'm not sure why ripping a DVD doesn't do the same; however I went and created the videos directory from the command line and tried ripping the DVD again adn its working.

geoffrey

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Re: DVD Ripping Failed
« Reply #5 on: February 18, 2008, 05:24:23 pm »

Geoffrey - ripping encrypted DVDs is quite normal and perfectly possible. The wiki article you found is very old, don't know why it hasn't been updated


man...so much for reading the #$%! manual....  ::)
Asus M2NSLI Deluxe
AMD Athlon 64 X2 BE-2400 2.3GHz
Asus EN6200TC512 Graphic Card
WinTV PVR-150 MCE
(2) Samsung T166 SATA II 500GB
Corsair TwinX 2GB CL5 DDR2-800

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: DVD Ripping Failed
« Reply #6 on: February 18, 2008, 05:30:59 pm »
Also, I was having a similar problem, fixed my region code, still no luck.

I tried running /usr/pluto/bin/disk_copy manually and pointed it at /tmp to put the file in.  that worked.  I poked around /var/log/pluto/DCERouter.log.  I eventually discovered that i was getting an error when it tried to open /mnt/device/122/public/data/videos as that directory didn't exist yet.  Now, ripping a CD automatically created the audio directory so i'm not sure why ripping a DVD doesn't do the same; however I went and created the videos directory from the command line and tried ripping the DVD again adn its working.

Hmmmm... sounds like the free disk space is not being calculated correctly. After selecting 'Copy disc...' what  does the system tell you on the next screen about the free disk space on the drive you are trying to rip to? Does is indicate "
  • free" ?
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Venom986

  • Veteran
  • ***
  • Posts: 74
    • View Profile
Re: DVD Ripping Failed
« Reply #7 on: February 18, 2008, 06:07:50 pm »
it says nothing.  It flashes a message that is too quick to read (i assumed this was the error message about non-existant directory) and then goes to the failed to rip message.  no talk of free space.  however, looking at my ripping status in the admin page it does have a couple of attempts that showed disk full messages....weird.

incidentally...at some point (maybe when i started ripping cd's from my MD instead of the core?) the rest of the pluto directory structure showed up on my /mnt/device/122/public/data directory (i.e. documents and pcitures are there with audio and videos now, whithout my manually creating those directories).

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: DVD Ripping Failed
« Reply #8 on: February 18, 2008, 09:01:27 pm »
it says nothing.  It flashes a message that is too quick to read (i assumed this was the error message about non-existant directory) and then goes to the failed to rip message.  no talk of free space.  however, looking at my ripping status in the admin page it does have a couple of attempts that showed disk full messages....weird.

incidentally...at some point (maybe when i started ripping cd's from my MD instead of the core?) the rest of the pluto directory structure showed up on my /mnt/device/122/public/data directory (i.e. documents and pcitures are there with audio and videos now, whithout my manually creating those directories).

So you are not being asked where you would like to store the DVD? Hmm... and which version of LinuxMCE are you running on your system?
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: DVD Ripping Failed
« Reply #9 on: February 18, 2008, 10:45:56 pm »

Geoffrey - ripping encrypted DVDs is quite normal and perfectly possible. The wiki article you found is very old, don't know why it hasn't been updated


man...so much for reading the #$%! manual....  ::)

Well, maybe you could get off your #$%! ass and help updating it.... ::)
"Change is inevitable. Progress is optional."
-- Anonymous


Venom986

  • Veteran
  • ***
  • Posts: 74
    • View Profile
Re: DVD Ripping Failed
« Reply #10 on: February 18, 2008, 11:45:46 pm »
it says nothing.  It flashes a message that is too quick to read (i assumed this was the error message about non-existant directory) and then goes to the failed to rip message.  no talk of free space.  however, looking at my ripping status in the admin page it does have a couple of attempts that showed disk full messages....weird.

incidentally...at some point (maybe when i started ripping cd's from my MD instead of the core?) the rest of the pluto directory structure showed up on my /mnt/device/122/public/data directory (i.e. documents and pcitures are there with audio and videos now, whithout my manually creating those directories).

So you are not being asked where you would like to store the DVD? Hmm... and which version of LinuxMCE are you running on your system?

No, it did ask where I wanted to store it.  I thought I had said that it came up with the default of using my raid array and putting it in /mnt/device/122/public/data/videos (which it did, and which I accepted).  The problem was that at first, the videos directory did not exist in that path.  I had to manually create it (although for the audio equivalent, ripping a CD seemed to auto-create the path).  After manually creating the videos directory ripping DVDs worked fine.

geoffrey

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Re: DVD Ripping Failed
« Reply #11 on: February 20, 2008, 03:10:39 pm »

Quote
man...so much for reading the #$%! manual....  ::)

Well, maybe you could get off your #$%! ass and help updating it.... ::)

happy to...I have tried to post any solutions I have found here, as I am sure you noticed, but I think that I am too new to all this to write anything that will be seen as a "definitive answer" in the wiki...perhaps with your technical knowledge and my writing skill we could get some work done together...send a message if you care to collaborate...
Asus M2NSLI Deluxe
AMD Athlon 64 X2 BE-2400 2.3GHz
Asus EN6200TC512 Graphic Card
WinTV PVR-150 MCE
(2) Samsung T166 SATA II 500GB
Corsair TwinX 2GB CL5 DDR2-800

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: DVD Ripping Failed
« Reply #12 on: February 20, 2008, 10:09:58 pm »
Until yesterday I didn't have a problem ripping a DVD- one failed (not one of the ones that has been listed as problematic e.g. spiderman 3)...  I changed the destination harddrive to the one the core was installed on and the ripping succeeded.  Before changing the destination I tried different dvd drives on 2 separate media directors booting pxe from the core.  It may be completely unrelated, but you may try changing the destination; I don't know why it would matter.  (both drives had plenty of space 40+ GB, the core's hdd is sata and the other drive is pata)

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: DVD Ripping Failed
« Reply #13 on: February 21, 2008, 08:44:48 pm »
Until yesterday I didn't have a problem ripping a DVD- one failed (not one of the ones that has been listed as problematic e.g. spiderman 3)...  I changed the destination harddrive to the one the core was installed on and the ripping succeeded.  Before changing the destination I tried different dvd drives on 2 separate media directors booting pxe from the core.  It may be completely unrelated, but you may try changing the destination; I don't know why it would matter.  (both drives had plenty of space 40+ GB, the core's hdd is sata and the other drive is pata)

Just tested ripping to all HD's in MD's on one of our test systems and its working fine...
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk