Author Topic: Beta 2 installation story  (Read 2913 times)


  • Veteran
  • ***
  • Posts: 72
    • View Profile
Beta 2 installation story
« on: January 03, 2010, 01:45:21 pm »

I recently successfully reinstalled my system with the DVD of the Beta 2 release. I thought I'd share the experience.

My setup is a core with a software RAID array and a PVR-500 capture card stowed away in a closet, and a diskless Zotac ION MD in my living room.

The first time the installation went wrong, in the DVD menu I selected "Install KUbuntu".  The KUbuntu distro installed successfully, with a LinuxMCE installer link on the desktop, but the LinuxMCE installer failed. So I retried, this time selecting the option "Install LinuxMCE" at the bottom of the DVD menu.
(It would be nice if this option could be moved to the top somehow)

Installation on the core went pretty smoothly after that.

My software RAID array was detected successfully, but I had been using LVM on it (which isn't included in the install), so it couldn't be mounted.
I took the opportunity to reformat the array to ReiserFS, after which it was mounted automatically and detected as a ReiserFS system.
I used the Webadmin to set it to "Use LMCE's directory structure". The next day all the neccessary directories were there and I restored my media files from backup.
For some reason the webadmin now thinks the RAID array uses a cifs filesystem, and reports the array as "FAILED". I don't know why, but the array is still working fine (also according to mdadm), so I'm not too worried about that.

For the PVR software I selected MythTV, since I'm more familiar with it than VDR. The setup program informed me that I would have to set it up manually because there were no settings know for my location. I waited with that until I had the MD setup.
By the way, is there some way I can contribute my settings, so that other people (and myself on a future installation :) ) can benefit?

Installing the MD gave a little more problems. I ran the following commands on the core before it would work:
(I think only the last one was actually necessary)

I have the MD hooked up to my TV with a HDMI cable. So I had to press "3" once the AVWizard started to get output. After that I could set it up.
By the way, the new 195.30 drivers with VDPAU support were installed automatically, and since I read that these have additional support for alpha blending I decided to try out the UI2 with alpha blending. So far it's working great.

I use analog audio on my MD, and, I think, that also worked immediately after install.
I say "I think" because I spent a lot of time trying to get it to work before I realized the speakers (or probably amplifier) in my TV was broken. In recent weeks I had to turn up the volume of the TV to get a decent sound level out from it so it was probably already breaking down. It was just my bad luck that it happened to break down completely during the reinstall.
Anyway, after I realized this I stopped my tinkering with the config files, returned them to their original state, hooked up some external speakers (until I can get my TV fixed), and sound is working fine now.

Setting up MythTV gave the most problems. None of them have much to do with LinuxMCE, but more with my hardware and TV provider, but I thought I should document it:
I had to set the resolution in the Recording Profiles to 720x480 to get a stable picture (this is related to the PVR-500 hardware)
The start and end times of programs in may vary a bit from the schedule so I set the "RecordPreRoll" and "RecordOverTime" fields (via MythWeb) to 300 and 600 seconds respectively.
To get liveTV working in my living room I set "AlwaysStreamFiles" for my MD to "1" (see also

To get a TV guide I use the xmltv script from I installed it using the instructions from the site.
There is a little problem however; it caches information in $HOME/.xmltv, i.e. /root/.xmltv. However, mythfilldatabase is not run as the root user (I think it is run as the user mythtv, but /usr/pluto/bin/ sets the HOME directory to /root). So it doesn't have access rights to update it's cache, and it fails in its update.
I currently fix that with a cron job, but I still have figure out what is going on exactly and then come up with a better solution.