Author Topic: Disable flickr?  (Read 3879 times)

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Disable flickr?
« on: January 14, 2008, 10:54:54 pm »
What is the easiest way to remove the filckr pictures from being used by the screensaver.

Is just deleting the files in the flickr folder enough?  or will they get replaced?

I want the screen saver to run with my own pics (which I have figured out) but want to remove all the flickr pics also.

Thank you.

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Disable flickr?
« Reply #1 on: January 15, 2008, 04:29:59 am »
You will need to disable the process that retrieves them first.
In web admin go through the processes that run on the core and there is one related to downloading the flickr files (Not in front of it at the moment or I would give you more accurate info)

Then to get rid of the existing ones, ideally you would just remove the screen save attribute for them in the database. But removing the actual files will also stop them being displayed as there is a file existence check when forming a list of pictures to display. This will leave the database a bit messy but if you can live with that then that is fine.

Regards
Darren

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: Disable flickr?
« Reply #2 on: January 20, 2008, 09:24:55 pm »
Hi

Can anyone give more info on how to disable flickr from retrieving the files.

I have tried removing the screen saver attributes on the web admin, however it seems to reset some of them.

I have looking in the web admin but cannot find where to show processes running on the core.

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4540
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Disable flickr?
« Reply #3 on: January 20, 2008, 09:30:00 pm »
Hi

Can anyone give more info on how to disable flickr from retrieving the files.

I have tried removing the screen saver attributes on the web admin, however it seems to reset some of them.

I have looking in the web admin but cannot find where to show processes running on the core.

Regards

To stop new flickr images from being downloaded do this...

Open a Console window or ssh into your core and do this;

sudo rn /usr/pluto/bin/flickr.pl /usr/pluto/bin/flickr.pl.back <return>

to rename the flickr.pl perl script to flickr.pl.back. Just rename it again to flickr.pl if you'd like flickr images again
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Disable flickr?
« Reply #4 on: January 20, 2008, 09:42:31 pm »
Thanx, but I think you meant "mv" instead of "rn"

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4540
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Disable flickr?
« Reply #5 on: January 20, 2008, 09:43:23 pm »
Thanx, but I think you meant "mv" instead of "rn"

Ooops... yep ;-)
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

lon22

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: Disable flickr?
« Reply #6 on: January 22, 2008, 12:28:47 am »
Has anyone actually had success in disabling flickr. I followed the advice in multiple post, including this one, but with no success. I renamed flicker.pl to flickr.pl.back and I also deleted the flickr directory under pictures. Is there a step that I'm missing?

thanks

lon22

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Disable flickr?
« Reply #7 on: January 22, 2008, 12:43:58 am »
maybe the process is still running..
regards,
hari
rock your home - http://www.agocontrol.com home automation

jgaffney

  • Douchebag
  • Veteran
  • *
  • Posts: 138
    • View Profile
Re: Disable flickr?
« Reply #8 on: January 22, 2008, 12:50:46 am »
Just deleting the files did it for me, I've also renamed the flicker script since.

Maybe you need to assign the screensaver attribute to one of your own pics, if you haven't already.

RichardP

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Re: Disable flickr?
« Reply #9 on: January 22, 2008, 01:20:15 am »
Has anyone actually had success in disabling flickr. I followed the advice in multiple post, including this one, but with no success. I renamed flicker.pl to flickr.pl.back and I also deleted the flickr directory under pictures. Is there a step that I'm missing?

thanks

lon22

I think you've done it all, and probably correctly. What you're probably forgetting is that the process is still running in memory. Renaming the script will only stop it from being found the next time the system starts up. A reboot should stop new images arriving.
Best Regards,
Richard

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Disable flickr?
« Reply #10 on: January 22, 2008, 01:35:29 am »
Has anyone actually had success in disabling flickr. I followed the advice in multiple post, including this one, but with no success. I renamed flicker.pl to flickr.pl.back and I also deleted the flickr directory under pictures. Is there a step that I'm missing?

thanks

lon22

I think you've done it all, and probably correctly. What you're probably forgetting is that the process is still running in memory. Renaming the script will only stop it from being found the next time the system starts up. A reboot should stop new images arriving.

a "sudo killall flickr.pl" would be sufficient

regards,
Hari
rock your home - http://www.agocontrol.com home automation

lon22

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: Disable flickr?
« Reply #11 on: January 22, 2008, 01:53:15 am »
I have pictures of my own that show up, which I assign the screen saver attribute.

I restarted and regenerated the core numerous times.

There is no flickr process to kill. The only process I see running related to flickr is:
"14043 pts/22   SLl+   0:03 ./Photo_Screen_Saver -d 28 -r 127.0.0.1 -l /var/log/pluto/"

I took a look at the flickr log file under /var/log/pluto and the directory where it has been getting images from was deleted by myself for some time now.

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: Disable flickr?
« Reply #12 on: January 22, 2008, 03:33:58 pm »
Hi 
Well I moved the flickr.pl file and rebooted the machine. I then removed the attributes froom the file and removed the files from the disk and al works fine.
The first lot of pictures i uploaded were about 900k each and they load fine. However the second lot were 2.5mb each and they dont seem to work. Is there a limit on the file size the screensaver can use?

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4540
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Disable flickr?
« Reply #13 on: January 22, 2008, 05:23:42 pm »
Has anyone actually had success in disabling flickr. I followed the advice in multiple post, including this one, but with no success. I renamed flicker.pl to flickr.pl.back and I also deleted the flickr directory under pictures. Is there a step that I'm missing?

thanks

lon22

Yes we do it all the time ;-)

Follow the rename procedure earlier in the thread - that stops flickr.pl from running in the future. If its already running kill its PID. Having done that you have stopped any more flickr images from being downloaded. However any images already downloaded will still be used by the photoscreensaver. So remove the flickr directory or any specific subdirectories or individual images as required.

Thats it.

Hope that helps you.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

RichardP

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Re: Disable flickr?
« Reply #14 on: January 23, 2008, 03:19:44 am »
Hi 
Well I moved the flickr.pl file and rebooted the machine. I then removed the attributes froom the file and removed the files from the disk and al works fine.
The first lot of pictures i uploaded were about 900k each and they load fine. However the second lot were 2.5mb each and they dont seem to work. Is there a limit on the file size the screensaver can use?

Regards

Make sure the pictures are no more than 1240x1240 pixels.

Best Regards,
Richard.
Best Regards,
Richard