Author Topic: 0710B3 media file sync not seeing nfs share  (Read 847 times)

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
0710B3 media file sync not seeing nfs share
« on: January 31, 2008, 02:27:57 am »
Howdy,

I finally added a second drive to my core then replaced 0710B2 with 0710B3 amd64.  The new installation went smooth (the plutohome.com/new_installation.php scripts did timeout).  I was nicely prompted on which hard drive to install on.  During install the second drive was discovered and mounted as an internal drive.  Everything I had working previously checked out.

So on to adding a new feature, mounting an nfs share.  Interestingly the autodiscovery would find cifs shares but did not discover the nfs share.  So simply added the share from pluto admin, Advanced, Configuration, Devices.

The share does show up under /mnt/device/36 and I can rip dvd to it and I can play the video from it.  Interestingly, when choosing the file to play, the UI1 screen with the Play, Close, Delete button has the file location as: "File: Disk #2".

When I go to pluto admin, Files & Media, Media Files Sync, I can not find the nfs share.  I can find the second hard disk under /home/public/data/videos/Internal HDD-CORE(sdb1)[35].  That's where I would expect a symlink to /mnt/device/36.

Any hints on what is responsible for creating the symlink? 

TIA,
Roy

dan g

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: 0710B3 media file sync not seeing nfs share
« Reply #1 on: January 31, 2008, 02:09:07 pm »
i think you need to run this script (or similar) /usr/pluto/bin/StorageDevices_Symlinks.sh

if you have a bit of linux exp I think you will manage to see the similar process for crating smb shares.
there are few scripts there associated with adding shares and internal drives, if you are curious just take a look.

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: 0710B3 media file sync not seeing nfs share
« Reply #2 on: January 31, 2008, 10:49:47 pm »
Thank you, I'll give it a look see.

I may have found the root issue - when I set up the nfs share I had created  a linuxmce user on the nfs server then squashed all user access to use this account.  This caused the dcerouter to see the files as belonging to 1002:users, which is probably preventing access.  On the internal drive, the dcerouter uses linuxmce:public.  So  tonight I'll remove squashing and see what happens.

I'm curious how everyone else is solving the uid/gid synchronization problem.  Are y'all running an ldap server & pam-ldap, or setting the uid 1000 to linuxmce on all servers, or what?

Thank you,
Roy

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: 0710B3 media file sync not seeing nfs share
« Reply #3 on: February 02, 2008, 01:29:25 am »
The /usr/pluto/bin/StorageDevices_Symlinks.sh is adding the symlink to /home/public/data/other/NFS Share [36].  Currently trying to see why the share's public directory is added there.  For example here's a path to a video file:

/home/public/data/other/NFS\ Share\ \[36\]/public/data/videos/Comedy/Splash.dvd

Also I can now set/change attributes using Media File Sync, but interestingly .id3 files do not show up on the share...

Have fun,
Roy