Author Topic: Supporting the ACT Solutions ZCU201 USB Z-wave Interface  (Read 85883 times)

yann

  • First post!
  • Posts: 1
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #150 on: August 01, 2008, 03:24:05 pm »
hello,

i have followed the configuration steps that you wrote on linuxmce:

http://wiki.linuxmce.org/index.php/ACT_Homepro_Motion_Detector

But i still can not make it work. How do you know that it is working or not ? (should i see somehting in the log or on the admin site ?)

if you can let me know

Thanks a lot

yann

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #151 on: August 01, 2008, 05:42:13 pm »
never got it to work with the original driver. But maybe I was too stupid. It works fine with my new driver (under active development). The new driver does no automatic configuration for now, so the steps are a bit different.

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #152 on: August 04, 2008, 05:24:49 pm »
the svn driver should support both transfer modes (full/network only).

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #153 on: August 04, 2008, 10:25:23 pm »
the svn driver should support both transfer modes (full/network only).


I know it should, but I just have worst of luck with the full transfer. Oh well.
ah, did not know you were using the svn driver.

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

cyf4746

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #154 on: October 16, 2008, 11:46:01 am »
Hi .. Hari, I got problem to transfer the configuration from the Home Pro Master Controller. I am using the ZCS201 Srial Z-Wave Interface.
Please help.


hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #155 on: October 16, 2008, 01:48:03 pm »
activate log levels 36,40 and 41 and send me the log
rock your home - http://www.agocontrol.com home automation

cyf4746

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #156 on: October 17, 2008, 06:49:39 am »
Hari,
How to activate log level?

habazot

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #157 on: November 23, 2008, 10:51:31 pm »
Hi, struggling with getting a ZCU201 USB interface up and running.
Plain 0710 on a AMD64 machine. I'm getting this in the log file (in an endless loop):

========== NEW LOG SECTION ==========
1       11/23/08 21:47:31       77 (spawning-device)    Starting... 10
1       11/23/08 21:47:31       77 (spawning-device)    Found /usr/pluto/bin/ZWave
01      11/23/08 21:47:31.892           asynchThread started <0x2b6fc11f8b40>
05      11/23/08 21:47:36.048           ### Go to timeout queue <0x41802950>
05      11/23/08 21:47:36.048           ### execute the next job from timeout queue <0x41802950>
05      11/23/08 21:47:36.048           ZWJobInitialize::timeoutHandler <0x41802950>
05      11/23/08 21:47:41.032           ### Go to timeout queue <0x41802950>
05      11/23/08 21:47:41.032           ### execute the next job from timeout queue <0x41802950>
05      11/23/08 21:47:41.032           ZWJobInitialize::timeoutHandler <0x41802950>
05      11/23/08 21:47:46.016           ### Go to timeout queue <0x41802950>
05      11/23/08 21:47:46.016           ### skip the next job from timeout queue <0x41802950>
05      11/23/08 21:47:51.040           ### Go to timeout queue <0x41802950>
05      11/23/08 21:47:51.040           ### execute the next job from timeout queue <0x41802950>
05      11/23/08 21:47:51.040           ZWJobInitialize::timeoutHandler <0x41802950>
05      11/23/08 21:47:56.020           ### Go to timeout queue <0x41802950>
05      11/23/08 21:47:56.020           ### execute the next job from timeout queue <0x41802950>
05      11/23/08 21:47:56.020           ZWJobInitialize::timeoutHandler <0x41802950>
05      11/23/08 21:48:01.031           ### Go to timeout queue <0x41802950>
05      11/23/08 21:48:01.032           ### skip the next job from timeout queue <0x41802950>
05      11/23/08 21:48:01.051           Cannot connect to ZWave device ttyUSB0. <0x2b6fc11f8b40>
01      11/23/08 21:48:01.052           Connect() Failed <0x2b6fc11f8b40>
Return code: 1
3       11/23/08 21:48:01       77 (spawning-device)    Device died... count=10/50 dev=77
Sun Nov 23 21:48:01 CET 2008 died

Any clues on how to get a response from this interface?
dcerouter_93878:~# lsusb
Bus 002 Device 007: ID 04fc:0201 Sunplus Technology Co., Ltd
...

dcerouter_93878:~# lsmod
Module                  Size  Used by
spcp8x5                14980  0
usbserial              40688  1 spcp8x5
...

Device data:
Com port: pci0000:00/0000:00:02,0+6
Serial : /org/freedesktop/Hal/devices/usb_device_4fc_201_noserial

Not sure how this maps to ttyUSB0, though..

Any help appreciated :)

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #158 on: November 23, 2008, 11:22:53 pm »
You could try to use the new zwave driver. But the ZCU101/201 is crap.

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

habazot

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #159 on: November 23, 2008, 11:36:45 pm »
You could try to use the new zwave driver. But the ZCU101/201 is crap.

best regards,
Hari

Ok, glad to get some straight talk :)
Which one seems to be the one to recommend these days?
I was looking at the Mi Casa Verde USB/inclusion controller.
How is your experience with it wrt LMCE?

Regards

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #160 on: November 23, 2008, 11:44:13 pm »
Which one seems to be the one to recommend these days?
I was looking at the Mi Casa Verde USB/inclusion controller.
How is your experience with it wrt LMCE?
I can recommend the Seluxit, full PNP. The tricklestar should work with manual tweaks. The MCV stick should work too, my unit is at the customs office, will report these days.

br, Hari
rock your home - http://www.agocontrol.com home automation

coley

  • Guru
  • ****
  • Posts: 492
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #161 on: January 13, 2009, 05:59:10 pm »
You could try to use the new zwave driver. But the ZCU101/201 is crap.

best regards,
Hari

I know I'm draggin up an old thread - what are the low level issues mentioned in the wiki which reference this thread?
I jumped in and bought one last year but its been sitting idle since I got proof of concept going. When I get back to my system will the ZCU201 be headed for the bin?

thanks
Coley.

Tonop

  • First post!
  • Posts: 1
    • View Profile
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #162 on: May 17, 2010, 01:47:20 pm »
Hi all!

I have this old device ZCU201 and let to know where I can get Linux drivers for it? Can anybody provide me with this info?

Thanks in advance!

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Supporting the ACT Solutions ZCU201 USB Z-wave Interface
« Reply #163 on: May 17, 2010, 06:33:41 pm »
Hi all!

I have this old device ZCU201 and let to know where I can get Linux drivers for it? Can anybody provide me with this info?

Thanks in advance!

The only viable ZWave driver for LinuxMCE is the open one that is currently used - this may or may not work with the ZCU201. If you have a unit test it and let us know if it works.

All the best


Andrew
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk