Author Topic: SBLive and Digital Sound  (Read 1510 times)

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
SBLive and Digital Sound
« on: January 01, 2008, 02:19:53 am »
Hope someone can help or point me in the right direction:

MD - SPECS
ASUS Mobo 3.2
4 Gb RAM
320 Gb HDD
Yukon GB eth0
SBLive 5.1 Card
Onboard Audio - ICH5 - Disabled
DVI-HDMI output
Digital Coax connected to Receiver

I get no sound with this card or the on-board.  I went with this card due to the fact that it was one of those identified as "working out of the box", based on some of the pleas for help that is not the case.

Here is what I've done:

Alsamixer config -

    I set all of the IE958 settings to un-mute as well as AC97 and saved it (boy this took a while to get through) but I did.

    In KDE loaded a DVD in drive, it autostarted with the XINE player - NO Sound
    Launched KMIX - used a myriad of settings (bad thing about this utility, what is on and what is off, no way to really tell) (light reds, dark reds, greens, yellows).  You would think that GREEN (being a standard for on/go/proceed) would indicate that an option is on.  Go figure.

Ok, so I am a little frustrated and am willing to buy "whatever works with this system out of the box", I just want to finally see it work.

You guys have helped me struggle through the slow speed and really pointed me in the right direction, hopefully you can do the same here.

THANKS IN ADVANCE - HAPPY NEW YEAR

RichardP

  • Veteran
  • ***
  • Posts: 131
    • View Profile
Re: SBLive and Digital Sound
« Reply #1 on: January 01, 2008, 11:40:06 am »
I'm using Creative Audigy, which is pretty similar, I think. All my mixer settings don't seem to to much. My way of getting sound working was to use the Setup Wizard, and when the sound settings came up, I chose SPDIF, then kept changing trying all the sockets at the back of the card until I got sound.
Best Regards,
Richard

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: SBLive and Digital Sound
« Reply #2 on: January 02, 2008, 12:49:26 am »
I'm able to get Analog out, but not the SPDIF (coax / optical).  I really want to have full surround with this if possible and being able to minimize the number of cables is a must.  From all of the posts I've seen, the SBLive cards (supposedly) work under this software.  It's recognized, I can see it in Alsamixer, but it does not appear to be as plug and play as I would have hoped.  I guess I'll try another card.

DeadPenguin

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: SBLive and Digital Sound
« Reply #3 on: January 02, 2008, 05:22:40 am »
Most SBLive hardware works very well in linux. You can check the HCL over at linuxquestions.org http://www.linuxquestions.org/hcl/showcat.php/cat/81

Most of the SBLIVE cards get 10 ratings which means they normally work flawlessly without a problem.

You sure all of you connections are right?
Do you have your receiver on the right optical input? (if you have multiple inputs)
You are sure you unmuted it in Alsa?

Sounds like you tried everything I would try.

Have you tried it with any other linux distros? if not, try a Linux livecd (my favs are Sabayon - MINT - PCLinuxOS) and see if you can get it to work.
Your sure the card works?
What ASUS mobo you have?



Regards,
Blair












Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
SOLVED: Re: SBLive and Digital Sound
« Reply #4 on: January 02, 2008, 05:27:18 am »
If you are experiencing issues with SPDIF Coax/Optical, stop what you are doing and go read HOWTO Dolby Digital and DTS.  I was directed to that link from this thread:

http://gentoo-wiki.com/HOWTO_Dolby_Digital_Out_(AC3,_SPDIF)

Trust me, as many problems as I have had, much of this was right under my nose.  Here's some things you should check prior to the link:

1.  If you are connecting to a RECEIVER - Ensure that the correct input for you selection is made.  This was my main problem.  I have a Pioneer Elite and connected as follows:

    MD ---> SAT  DVI ----> HDMI input (since I don't have a sat TV this was perfect)
    SAT Inputs - config
       Digital --- Opt1
       HDMI ---- HDMI1

2.  Alsamixer - turned off Analog for IEC958
3.  Changed IEC958 input to PCM
4.  Unmute PCM
5.  Turned Master Volume to max
6.  Ran the scripts in the link above

Receiver displayed Dolby/DTS and I'm a happy guy.

DeadPenguin

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: SBLive and Digital Sound
« Reply #5 on: January 02, 2008, 05:42:57 am »
I followed your gentoo-wiki link and it didn't work.

I searched and found this. I think this is the one you are speaking of.
http://gentoo-wiki.com/HOWTO_Dolby_Digital_and_DTS
« Last Edit: January 02, 2008, 05:46:40 am by DeadPenguin »

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: SBLive and Digital Sound
« Reply #6 on: January 06, 2008, 04:22:53 am »
Yep - that's the correct one.  Sorry about that