Author Topic: Orbiter on N800 (OS2008)  (Read 7327 times)

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #30 on: January 10, 2008, 06:57:52 am »
Howdy,

My wife wants to say a big THANK YOU!  She hates using the gyro mouse and this is a fantastic replacement!

Setup was a breeze with just a couple of minor hiccups.  I had to add the temporary maemo extra repository to get libxmu6 and libsdl-ttf.  Adding these to the dependency files would be nice.

It took me a while to find the directions for adding the orbiter to linuxmce.  It wasn't too bad but a little more hand holding for a noob would be nice.  Having messed up my system previously playing with linuxmce admin has made me a little gun shy.   :)

Finding and playing videos is sweet.  The filters seem broke but I think that is a 0710B2 issue.

I was really surprised and impressed when the DVD menu showed up on the N800.  Very Cool!

The first time connection to the linuxmce took a while.  A text message like "Retrieving screens from the core, this may take a few minutes" would be nice.

I experienced the orbiter lock up problem when switching to the N800 desktop then attempting to resume the orbiter that was previously mentioned.

Orbiter wake is taking about 20 seconds sometimes.  A black display with a pointer appears after first tap.  I did a second tap about 15-20 seconds later and the display appears.  Sorry for not being precise, I've only watched one movie and observed this behavior when I tried to pause about an hour into it and again when the movie was over.

Finally decided to try controlling the web bookmark feature.  I'm assuming that the mouse table area should map to MD screen.  What I observed is that only the lower right quadrant moves the pointer.  Clicking at the very bottom right of the tablet causes the MD pointer to move to a point about 1/3 horizontally from the left edge and about half way from the top.  Also did not get any response on the MD to clicking any of the keyboard keys (ok, the key colors changed from blue to greenish and stayed the new color even after clicking other keys).

Again, Thank You!

Matthew

  • Douchebag
  • Addicted
  • *
  • Posts: 567
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #31 on: January 11, 2008, 06:50:16 am »
Howdy,

My wife wants to say a big THANK YOU!  She hates using the gyro mouse and this is a fantastic replacement!

Setup was a breeze with just a couple of minor hiccups.  I had to add the temporary maemo extra repository to get libxmu6 and libsdl-ttf.  Adding these to the dependency files would be nice.

It took me a while to find the directions for adding the orbiter to linuxmce.  It wasn't too bad but a little more hand holding for a noob would be nice.  Having messed up my system previously playing with linuxmce admin has made me a little gun shy.   :)

Finding and playing videos is sweet.  The filters seem broke but I think that is a 0710B2 issue.

I was really surprised and impressed when the DVD menu showed up on the N800.  Very Cool!

The first time connection to the linuxmce took a while.  A text message like "Retrieving screens from the core, this may take a few minutes" would be nice.

I experienced the orbiter lock up problem when switching to the N800 desktop then attempting to resume the orbiter that was previously mentioned.

Orbiter wake is taking about 20 seconds sometimes.  A black display with a pointer appears after first tap.  I did a second tap about 15-20 seconds later and the display appears.  Sorry for not being precise, I've only watched one movie and observed this behavior when I tried to pause about an hour into it and again when the movie was over.

Finally decided to try controlling the web bookmark feature.  I'm assuming that the mouse table area should map to MD screen.  What I observed is that only the lower right quadrant moves the pointer.  Clicking at the very bottom right of the tablet causes the MD pointer to move to a point about 1/3 horizontally from the left edge and about half way from the top.  Also did not get any response on the MD to clicking any of the keyboard keys (ok, the key colors changed from blue to greenish and stayed the new color even after clicking other keys).

That's good feedback. Would you turn the suggestions into feature requests in Mantis, so the 0710 developers can see them?

alaric

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #32 on: May 27, 2008, 05:51:16 pm »
I'm trying to install the Orbiter on an N800 following these posts, however I've run into a problem.

I cannot find the libxmu6 package anywhere.  :(


Anyone know where I can find this?


--- Oops:  OS 2008, LinuxMCE 0710, ...
« Last Edit: May 27, 2008, 05:54:57 pm by alaric »

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #33 on: May 27, 2008, 07:31:02 pm »
I think it was in:  http://repository.maemo.org chinook/free

I haven't updated my n800 in months and am a little shy on messing up what is working...

HTH,
Roy

alaric

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #34 on: May 27, 2008, 08:11:47 pm »
Well, that's just it, by my understanding it *was*   It's not there now.

I'll see if anyone on maemo or ITT has an idea where it went to.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #35 on: May 28, 2008, 09:10:01 am »
Well, that's just it, by my understanding it *was*   It's not there now.

I'll see if anyone on maemo or ITT has an idea where it went to.

It seems that maemo repository is not accessible now. I don't see any reason to move libxmu6 somewhere from repository. Let's wait a bit. Or you can install that one - http://www.mediafire.com/?evk0mzw5nwo. I got it from Maemo VMWave Appliance.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Domodude

  • Guest
Re: Orbiter on N800 (OS2008)
« Reply #36 on: August 22, 2008, 10:46:29 pm »
Hi Andrew,
I tried the OS2007 install script on your site for the N800, but all I see is an opened text file with
[install]
repo_name = ....

It seems that the n800 does not see the script as something executable.
Posde suggested there might be a missing line in /etc/mime.types:
application/x-install-instructionsinstall
Could perhaps have a look at that?
Thanks!
Mark

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: Orbiter on N800 (OS2008)
« Reply #37 on: August 23, 2008, 12:44:50 am »
Hi Andrew,
I tried the OS2007 install script on your site for the N800, but all I see is an opened text file with
[install]
repo_name = ....

It seems that the n800 does not see the script as something executable.
Posde suggested there might be a missing line in /etc/mime.types:
application/x-install-instructionsinstall
Could perhaps have a look at that?
Thanks!
Mark


Hi Mark,

I've passed this onto Michael Stepanov who maintains this on our servers.

Thanks

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #38 on: August 23, 2008, 09:17:12 am »
Hi Andrew,
I tried the OS2007 install script on your site for the N800, but all I see is an opened text file with
[install]
repo_name = ....

It seems that the n800 does not see the script as something executable.
Posde suggested there might be a missing line in /etc/mime.types:
application/x-install-instructionsinstall
Could perhaps have a look at that?
Thanks!
Mark


Hi Mark. I'll check that case. Are you sure that your N800 runs OS2007? OS2008 is much better (especially, the latest diablo). So, I suggest you to re-flash your N800 by OS2008.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Domodude

  • Guest
Re: Orbiter on N800 (OS2008)
« Reply #39 on: August 23, 2008, 10:29:11 am »
Hi Mark. I'll check that case. Are you sure that your N800 runs OS2007? OS2008 is much better (especially, the latest diablo). So, I suggest you to re-flash your N800 by OS2008.
I just did the upgrade. I am now going to try the 2008 version.
BTW, I have this asus wl580g wireless router attached to my wired switch (which is connected to the core). How do I get my n800 to talk to the core through that Asus? Currently it is configured as AP, and I use port 3 of the asus to connect to the switch. No go, so far :(

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #40 on: August 23, 2008, 01:12:41 pm »
Strange, I checked all install scripts and it seems they  work fine. Could you try again, please?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #41 on: August 23, 2008, 01:26:07 pm »
I just did the upgrade. I am now going to try the 2008 version.
BTW, I have this asus wl580g wireless router attached to my wired switch (which is connected to the core). How do I get my n800 to talk to the core through that Asus? Currently it is configured as AP, and I use port 3 of the asus to connect to the switch. No go, so far :(

Check firewall on your LinuxMCE box. Try to shutdown it or add TCP port 3450.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Domodude

  • Guest
Re: Orbiter on N800 (OS2008)
« Reply #42 on: August 24, 2008, 10:15:28 am »
I just did the upgrade. I am now going to try the 2008 version.
BTW, I have this asus wl580g wireless router attached to my wired switch (which is connected to the core). How do I get my n800 to talk to the core through that Asus? Currently it is configured as AP, and I use port 3 of the asus to connect to the switch. No go, so far :(

Check firewall on your LinuxMCE box. Try to shutdown it or add TCP port 3450.

Re: this networking issue: turns out I had forgotten to turn off the DHCP server on the Asus router :-[
Re: the n800 software: I tried a few more times, and every time the n800 gave me an error of some sort (depending on the exact software version and the repo). But when I checked the installed software on the nokia, I was very surprised to see the orbiter in the list! So, I now have a working N800!!  8)

Thanks for helping out! If a new version comes out, I'll be sure to keep a precise log of any errors that appear; I realize that the above "report" is not very useful...

Mark
« Last Edit: August 24, 2008, 10:20:34 am by Domodude »

richard.e.morton

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #43 on: August 26, 2008, 10:02:05 pm »
Humm...

ok, so I trued to download the packages for an N800 on OS2008 and it says that the dependancies are an "Incompatible Softare Package". I tried it from this post

"Please, use dependencies from that page https://garage.maemo.org/frs/?group_id=162, but section OS2008. All those packages were tested on the several N800 with the latest OS2008. Also there is an Orbiter 0710 package for OS2008 - https://garage.maemo.org/frs/download.php/2956/lmceorbiter-os2008-0704-01_armel.deb. "

it came from earlier in the thread.

The main distribution is fine, although it can't install because it doesn't have dependancies installed, but I can't install those cause the packages aren't compatible

Any ideas of what I am doing wrong?
thx
Richard

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #44 on: August 26, 2008, 10:55:57 pm »
I suspect that your problem is related with Red/Blue pill mode. Try to activate Red pill mode:
Quote
Activating Red Pill mode

- Go to "Tools > Application catalogue",
- click "New",
- enter "matrix" into the "Web Address" field,
- click "Cancel".
- Choosing the red pill will activate the red pill mode, obviously, and choosing the blue one will deactivate it.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru