Author Topic: S-ATA HDD + ATAPI CDROM issues  (Read 6714 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
S-ATA HDD + ATAPI CDROM issues
« on: October 04, 2005, 05:43:11 pm »
There are some issues that have been noticed when it comes to S-ATA setting. Most S-ATA related BIOS settings seem to make the interrupt controller behave differently than expected.

My test computer has an AMI BIOS and the settings go like this:

location: Integrated Peripherals -> On-Chip IDE Configuration
On-Chip ATA(s) Operate Mode: Legacy Mode
ATA Configuration: P-ATA Only
S-ATA Keep Enabled: Yes
P-ATA Channel Selection: Both
S-ATA Ports Definition: P0-3rd./P1-4th.

I'll post another config from a board that disables one of the IDE ports when you go into "Compatibilty" mode, for reference, soon. But the idea is kind of universal.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
S-ATA HDD + ATAPI CDROM issues
« Reply #1 on: January 04, 2006, 11:07:22 am »
Hello Radu.c,

Any news regarding the S-ATA issue ?

Cheers,
Jim

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
S-ATA HDD + ATAPI CDROM issues
« Reply #2 on: January 04, 2006, 04:57:23 pm »
No other news. The other BIOS config I promised, I never got hold of it (the machine was a remote one).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
This is because kernel is <2.6.18 & installer is <
« Reply #3 on: January 30, 2007, 10:46:06 pm »
The installer should be upgraded to r1, or the 2.6.18 kernel - it provides a great deal more hardware support. r0 was very basic; r1 is more like the package-management system. The Sarge documentation says that the r0 installer only supports up to an Intel 815 chipset. It may be that including the 'libaata' driverset would solve this; is there any way to get it to included in the meantime?

The oldest LGA 775 chipset you can buy easily right now is an Intel 945. I put my Intel 945 chipset in 'legacy' mode, where the PATA drives are reported first. The default Debian installer on the .43 Kick-Start CD wouldn't mount the CD-ROM,  but the expert install will. Expert install fails when it's trying to partition the hard drive. (The .42 install did the same thing.)

So then I tried adding a 3ware 9590SE RAID controller, the BIOS recognizes the drives, and will boot from them, but the installer won't even see them. The latest Sarge installer works; Gnoppix runs fine. I think the SATA drives may be reported under a different path than the default expected by the installer.

Here are some supporting SATA links & some workaround excerpt, I may try installing on an IDE drive next:

newbielink:http://forums.debian.net/viewtopic.php?t=10393 [nonactive]

****************************************
newbielink:http://forums.debian.net/viewtopic.php?t=10284 [nonactive]

About halfway down the page:

shoof Joined: 08 Sep 2006
Posted: 2006-11-21 14:16    

SATA support is an ongoing project, you probably need the 2.6.18 kernel.

newbielink:http://kmuto.jp/debian/d-i/ [nonactive]

**************************************
newbielink:http://wiki.debian.org/DebianInstaller/FAQ#head-a5623cd5a3ec3d8d6a1eef09e3e4c00f911f8b18 [nonactive]

Q: Is installation on SATA harddrives supported by DebianInstaller?

A: The Sarge version of the installer has very limited support for SATA. The versions available for Etch use more recent kernels that have very much improved SATA support. So if you don't really need Sarge your best option is to use the Etch version of the installer and install Etch.

If you do really want to install Sarge, there are four options for SATA users:

   1.      You can try the 2.4.27 kernel which is default in the Sarge installer. This kernel includes some support for SATA.
   2.      Install using the Linux 2.6 kernel which should somewhat have better support for your SATA hardware (boot the installer with "linux26").
   3.      See if you can change your SATA settings in the BIOS from something like "Native mode" to "Compatibility mode" (might be labeled differently)
   4.      Use an unofficial version of the Sarge installer that uses a backported more recent kernel, like the one created by Kenshi Muto available from DebianInstaller/CustomImages.

For a list of supported chipsets and their status of support you may want to be assisted by [WWW] newbielink:http://www.linuxmafia.com/faq/Hardware/sata.html [nonactive]

************************
From that link:
************************

Problem: Serial ATA (also known as S-ATA or SATA) chipsets are rapidly replacing legacy "parallel ATA" (PATA, i.e., regular ATA/133) chipsets — but many Linux installers' kernels don't yet support many Serial ATA chipsets. If yours isn't supported, you have an installation obstacle. ...Debian 3.1/sarge and later's (especially when started with the "bf2.6 boot flavour" boot image)...all have a good selection of the required drivers. Scott Kveton's and Kenshi's Debian netinst images do, likewise — see Links/Resources.

There are three workaround options:

1. Switch the motherboard BIOS back to "legacy ATA mode" (parallel ATA = PATA). Complete a Linux installation. Fetch or build a kernel with support for your chipset. Switch the BIOS setting back. (Potential catch: It's claimed that Dell Optiplex GX270 and Dell Precision Workstation 360 desktop units, using Intel ICH5 SATA-I chipsets, don't support switching to legacy ATA mode. This might be true of some others.)

2. Rebuild your installer using kernel 2.4.27 or later, which includes libata, desirable since it adds many new chipsets and gives a (potential, subject to physical read limits, etc.) ~10M/s speed boost to some others compared to the quite slow 2.4.x drivers/ide set.

3. Temporarily add a regular PATA drive to your system. Install Linux onto that. Fetch or build a kernel with support for your chipset. Migrate your system to the SATA drives.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
S-ATA HDD + ATAPI CDROM issues
« Reply #4 on: January 31, 2007, 10:50:35 am »
The next release has a 2.6.18 kernel for the installer and an option to choose the 2.6.18 kernel (although just in experimental phase) besides the current 2.6.16 kernels.