Author Topic: PXE-Boot hangs up, looping......  (Read 3653 times)

augalex

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
PXE-Boot hangs up, looping......
« on: December 19, 2007, 04:07:16 pm »
Hy guys,

there's a big problem while trying to boot my first MD via PXE.

I got an Asus A7N8X-deluxe board, with two NICs onboard, when I connect one of them the md tries to  boot via PXE, everything seems to go its way, until, the line: filename tftpboot/pxelinux.0 comes up, for about 20 seconds and after this.
After this, the last block written:

IP-Config eth0 complete (from 192.168.1.23)
adr: 192.168.80.255  broadcast: 192.168.80.255  netmask: 255.255.255.0
gateway: 192.168.80.1  dns0: 192.168.80.1 dns1: 0.0.0.0
rootserver: 192.168.80.1 rootpath: filename tftpboot/pxelinux.0

is repeated about hours in a really fast way.....

I already tried to setup a diskless client in the webadmin first, wich also causes no effect.

Changing the NIC = the same problem....

looking forward for some help.......

augalex

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #1 on: December 19, 2007, 04:27:23 pm »
You could try to disable the NIC you're not using.
"Change is inevitable. Progress is optional."
-- Anonymous


tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: PXE-Boot hangs up, looping......
« Reply #2 on: December 19, 2007, 04:29:42 pm »
Had a similar problem at one point I think it is switching nics on you during the pxe boot. Try disabling one of the on-board nics.



Good luck

Warning - while you were typing a new reply has been posted. You may wish to review your post.
Zarec you beat me again.
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

augalex

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #3 on: December 19, 2007, 04:36:27 pm »
Wow, after hours and hours, thre different NICs, blood and tears.......

the solution was that easy.....
thanks a lot Zaerc
and of course, even if a little too late... *g* tkmedia.....

augalex

jca

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #4 on: December 19, 2007, 09:20:07 pm »
Wow, after hours and hours, thre different NICs, blood and tears.......

the solution was that easy.....
thanks a lot Zaerc
and of course, even if a little too late... *g* tkmedia.....

augalex

You should post that solution in the Wiki for the next person :)

spoolin1

  • First post!
  • Posts: 1
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #5 on: April 25, 2008, 08:35:25 pm »
can't wait to try this when I get home from work!

methodus

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #6 on: June 19, 2008, 12:47:09 pm »
Hi,

I have a Jetway J9F2-Extreme. I deactivated the second NIC but it is still looping all day long. I also tryed to set up BIOS boot order and switching between both NICs....

How can I fix it?

Thanks...

Edit: actually I just deaktivated PXE. Is this all I have to do?
« Last Edit: June 19, 2008, 12:50:50 pm by methodus »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: PXE-Boot hangs up, looping......
« Reply #7 on: June 20, 2008, 12:21:16 am »
Hi,

I have a Jetway J9F2-Extreme. I deactivated the second NIC but it is still looping all day long. I also tryed to set up BIOS boot order and switching between both NICs....

How can I fix it?

Thanks...

Edit: actually I just deaktivated PXE. Is this all I have to do?

Hmmm... you must have PXE boot enabled in BIOS otherwise your MD wont.... well PXE boot!

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Ritmo2k

  • Veteran
  • ***
  • Posts: 108
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #8 on: June 20, 2008, 12:55:46 am »
I am new to Linux MCE, but I know from PXE installs of Linux for servers which often have two nics the problem I think you are seeing is that possibly the nic that is plugged in and receives the pxe file starts, then the OS attempts to continue loading off the second nic. There are a few RH specific things to control this, but as I have no experience yet with Debian based Linux I wouldn't know what to add to the boot line.

Maybe someone familiar with this process in Debian based Linux can apply it here?

methodus

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #9 on: June 20, 2008, 01:24:08 pm »
Hi,

I have a Jetway J9F2-Extreme. I deactivated the second NIC but it is still looping all day long. I also tryed to set up BIOS boot order and switching between both NICs....

How can I fix it?

Thanks...

Edit: actually I just deaktivated PXE. Is this all I have to do?

Hmmm... you must have PXE boot enabled in BIOS otherwise your MD wont.... well PXE boot!

Andrew

Thank you Andrew, but actually this is not what I asked for. I have two nics and it keeps cycling as described in the first post. So I want to know how to deactivate one of the two devices, not both!

Murdock

  • Guru
  • ****
  • Posts: 229
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #10 on: November 29, 2008, 06:01:32 am »
I just had the same problem. You just need to disable the on-board NIC via the BIOS menu. Hit [f2] or <del> upon first boot.

Domodude

  • Guest
Re: PXE-Boot hangs up, looping......
« Reply #11 on: February 02, 2009, 11:55:02 am »
Sorry to bring this up again. WIKI mentions a fix, but....

You could try to disable the NIC you're not using.

I have a retarded motherboard (albatron KI51PV-754) which does not allow turning off only one of the two integrated NICs. So either boot with two NICs or boot with none :(
Any way to adjust a config on the core, so it will pick the other NIC?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: PXE-Boot hangs up, looping......
« Reply #12 on: February 02, 2009, 12:23:07 pm »
Sorry to bring this up again. WIKI mentions a fix, but....

You could try to disable the NIC you're not using.

I have a retarded motherboard (albatron KI51PV-754) which does not allow turning off only one of the two integrated NICs. So either boot with two NICs or boot with none :(
Any way to adjust a config on the core, so it will pick the other NIC?

Maybe try hooking both nics to the switch, desperate times call for desperate measures...
"Change is inevitable. Progress is optional."
-- Anonymous