Author Topic: LinuxMCE Slow  (Read 5367 times)

Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
LinuxMCE Slow
« on: December 09, 2007, 11:14:08 pm »
I have installed LinuxMCE DVD quick install n a P4 2.0 Ghz system, 512MB ram and a 128MB video card. During the install it seemed a little slow, but it worked.  After the install it got up and running and was slow as hell.  I went to the Kubuntu desktop and after shutting down LinuxMCE it worked great.  I haven't been able to figure what could be causing this to be so slow, considering the computer has run a few other OS's and never had an issue.  Anyone have an idea what may be causing this?

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: LinuxMCE Slow
« Reply #1 on: December 10, 2007, 08:01:54 am »
What GPU do you have? Nvidia/ATI? Also what UI settings?

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: LinuxMCE Slow
« Reply #2 on: December 10, 2007, 11:26:38 am »
It's the RAM, I have a PIV 1.7GHz and a PIV3GHz and the difference between 512 and 1024MB RAM or even 768MB is breathtaking, atleast that was my experience.
Now above 1GB (2.5GB in the 3GHz machine now) I hardly notice an improvement.

Also your graphics solution may make a difference. but I started out with an ATI Rage Fury 128 and it worked acceptable on UI1.
But, the machine you describe isn't excactly a 'powerhouse', I knew that and expected bad performance from my 1.7GHz, but it was better than I feared. Still...
« Last Edit: December 10, 2007, 11:29:04 am by Hagen »

Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: LinuxMCE Slow
« Reply #3 on: December 10, 2007, 12:51:41 pm »
Nvidia FX 5200.  I am not what UI settings your referring to, but if it si the opengl ones I used the lightest overlay...other then that everything is default.  Also, I am aware this is not a powerhouse machine, but well from the system requirements I read, this machine should be more then powerful enough to do what I want.  I am not streaming TV through it, I am not using it as a phone system, security, lighting... I am using it to watch backed up movies, listen to my MP3 collection...I figured with what I wanted to do with it, it should be more then capable.  So far I have shut down LinuxMCE and have been using it as a desktop and it works great that way.  I suppose I can see if I have more RAM around that I can stick into it and see if it makes any difference.

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: LinuxMCE Slow
« Reply #4 on: December 10, 2007, 02:57:13 pm »
That machine is more can cabable as a client, and will work 'adequatly' as a standalone hybrid.
But it also depends on what your expectations are and what you consider slow.
It's above the 'minimum specs', and it will work reliably for LMCE, but it will do so at it's own pace. And if that's ok with you you have a good enough machine for you. these things are highly objective  :)

Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: LinuxMCE Slow
« Reply #5 on: December 10, 2007, 03:29:23 pm »
It is a standalone system. I do not have any other LinuxMCE systems in the house and might look at doing that n the future when I live in a house and not an apartment.  As for what I consider slow, well let me describe it for you.  With LinuxMCE up and running, I click on say media.  I have to wait for the box to appear around the media button and then wait again for it to move to the next screen.  we are talking somewhere between 15 to 20 seconds per movement.  The video is so choppy it is unwatchable.  Even the video on install was so choppy it was useless.  The one anime I had up and running was worse then trying to talk to someone with a severe stutter.
 All it is going to be used for at the moment is strictly playback of media, be it anime, movies, music.  I might in the future set it up as a PVR, but that might be some time.  At the moment I don't see the need for it, actually at th moment i has a lot of features I probably won't be using.  Though thats not to say I won't at some point in the future.   

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LinuxMCE Slow
« Reply #6 on: December 10, 2007, 03:40:19 pm »
I think for the time being you're probably better off using something a bit more light weight like mythbuntu or VDR for instance.
"Change is inevitable. Progress is optional."
-- Anonymous


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: LinuxMCE Slow
« Reply #7 on: December 10, 2007, 03:40:50 pm »
very strange, it sounds like you are running the vesa driver by mistake.

can you go to the KDE desktop, open konsole, and type more /etc/X11/xorg.conf  ??

if you look in the Device section for your graphics card in that file, there should be an entry similar to "nvidia" "intel" "i810" etc... if it says "vesa", then it needs to be changed to "nvidia"

-Thom

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: LinuxMCE Slow
« Reply #8 on: December 10, 2007, 03:42:12 pm »
That's not right, I have had much better performance than that from a PIII 500... (Also ATI Rage 128)

I think you should post a bit more details about your system as something is definitely up, I was talking about wait times of a few seconds for menus to display. This is not it.

It's standard definition content? no HD?
Try rerunning the AV-wizard (after the 'tones' at boot up hold the left shift until you hear another tone).
Select UI1 (the top one).
Pick a resolution you know to work, you could try 800x600 or 1024x768 (if you are on a computer monitor now?) and see if that helps, with SD content going higher than 800x600 isn't really much of a point, alltough 1024x768 looks better for other apps, like firefox.



Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: LinuxMCE Slow
« Reply #9 on: December 10, 2007, 04:53:43 pm »
I am not sure what other system specs you require.  As it stand, it is sitting on the KDE desktop and works great.  No issues and it is running at 1024 X 768.  As for the xorg.conf  it is using nvidia and nvidia drivers.  I am using U1 in the setup which is the lightest set for the screen.  I have tried this with a computer monitor and my Sharp TV both using VGA and still have the same issues.  As it stands with just using the KDE desktop watching movies and such work great.  No issues what soever.  I am not sure why starting LinuxMCE causes issues, but as i said I am going to try and add some more RAM to see if makes a difference.  Let me know what I may be missing with my system set up and i'll answer the questions as much as I can.

As for using something else for now, why would I?  I prefer the way that LinuxMCE looks and works and that I can add to it in the future if I want to.  Maybe if I don't get this working I might look into something else, my biggest issue is that I am not one to give up that easily when I run into an issue. 
Just to say again:
p4 2.0 GHz
512 MB RAM
128MB Nvidia FX 5200
onboard sound (not sure why it didn't pick up my soundblaster card, though i am working on it.)
3com NIC.

At the moment I have added all the network drives I need access to to fstab.

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: LinuxMCE Slow
« Reply #10 on: December 10, 2007, 06:33:41 pm »
onboard sound (not sure why it didn't pick up my soundblaster card, though i am working on it.)
Disable the onboard sound in the Bios and rerun the AV-wizard like I explained above.

As for more specs, I was asking about brand names and model numbers, like 'HP DX6100', or motherboard manufacturer, things like that.

Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: LinuxMCE Slow
« Reply #11 on: December 10, 2007, 07:16:48 pm »
It's actually odd that the onboard sound is working since I turned it off in the BIOS yesterday.  When I get home I will look more into what the system is and well I will take another look into the soundcard issue and see if Linux has installed both.  I can change the default sound card if it does and that the BIOS still states the onboard sound is turned off. 

As for the video, i have tried almost every one listed and still had the same bad issue as explained above. 

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LinuxMCE Slow
« Reply #12 on: December 10, 2007, 10:15:48 pm »
At the moment I have added all the network drives I need access to to fstab.

That should normally not be necessary.
"Change is inevitable. Progress is optional."
-- Anonymous


Crypt

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: LinuxMCE Slow
« Reply #13 on: December 11, 2007, 02:22:45 am »
well i disabled the onboard sound, onboard nic and everything is working fine...well mostly everything.  The system isn't picking up my shared media across my network.  I am currently sitting on the KDE desktop and soon going to add the shares to the /media and fstab also going to transfer a couple of the things over and see if the machine picks them up.  is there a special place I should be putting them on the drive for them to show up properly?

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: LinuxMCE Slow
« Reply #14 on: December 11, 2007, 07:35:47 am »
Do you have more than one DHCP server enabled? a router or something?