Author Topic: Problems with Sound  (Read 1685 times)


  • Newbie
  • *
  • Posts: 4
    • View Profile
Problems with Sound
« on: December 04, 2007, 12:18:22 pm »
Hey Forum.

First of all - Nice job -well done LinuxMCE!
Well easiere to install, than Pluto it self - so a benefit for the enduser.

Well I have installed my Coreserver and hide it back in the garage. And added a MediaDirector in the livingroom. Which performs great ( From what I can se now) but I'm having hudges problems with the sound.
The Machine I'm using for MD is a Shuttle XPC.
It has an Nvidia Chipset.
The pictures and everything else is working fine.
The Soundcard is an onboard nVidia Corporation MCPS1 AC97 Audio Controller (rev a2) with SPDIF out.
In the admin I have tried allmost anything to get this to work, but cannot get the sound from LinuxMCE out that way - allthough when I switch to KDEdesktop - I got the sound. And can hear everything - so what are the options here?

I've earliere been running MythTV without anyproblem ( well a bit) but just made some changes in asound.conf to get this to work. Follwing this guide from ArchLinux but when I open a shell in the MD's KDEdesktop I cannot find the files that controls that.

In The Admin webinterface - I have tried allmost each settings here - but without luck -. the only place I got sound is in the KDE. 
I have tryed setting it to manual settings - with AC3 passthroug - And HDA Nvidia allso just with the standard soundcard - but each time with the same result!
Have anybody anyidea's of what to do - since the sound in KDE works but not on the MD's interface.

Thanks a lot


Well after a lot of other studying - I came up with the same problem as everyone else - that onboard SPDIF are not supported ( hopefully Yet)  - So used old analog output and - swing lot's of sound but only in stereo.  :'(
« Last Edit: December 04, 2007, 02:38:02 pm by Peq »
/\/o place like

Per Jørgensen


  • Veteran
  • ***
  • Posts: 58
    • View Profile
Re: Problems with Sound
« Reply #1 on: December 04, 2007, 03:27:04 pm »
I have the A8N-E motherboard which also contains an nVidia chipset. I'm not sure about the specifics of your setup or how similar they are to mine.

I documented my method at

If your chipset is similar enough please test with my method to make sure that it is correct.

Silverstone LC20M (silver)
Fiire Chief
Asus A8N-E
AMD Athlon 64 3200+
Skystar 2
Hauppauge WinTV-PVR 150 MCE
PNY 7300GT
Sony XL1B3
Sherwood RVD-6090 (needs replaced)