Author Topic: xine not playing dvds  (Read 876 times)

posterberg

  • Veteran
  • ***
  • Posts: 82
    • View Profile
xine not playing dvds
« on: November 23, 2007, 10:41:14 pm »
I tried to install the dvdcss package by running the script /usr/share/doc/libdvdread3/install-css.sh

The script executed just fine - but - now xine won't play any dvd's anymore...

It did complain, before, that libdvdcss wasn't installed if trying to play a comersial disc. Now it won't even do that...

I get a black screen when I try to play a dvd and then it just exits out to the Orbiter screen without errors... I did at least get the disc's main menu before...

I guess something got majorly broken when I ran that script... Is there any way to reinstall xine and it's components from scratch?

I've already tried apt-get install xine-ui and apt-get install libxine-extra-modules.... same black screen...

Any advice not including reinstall the whole system would be much apritiated! ;o)


---- NOTE ----

I've tried running Xine within KDE now and that works just fine... It even play that comersial disc,. This make me believe that the problem isn't really xine related but I don't know where to look... Are there any log anywhere that shows what happens when I try running a dvd from the Orbiter?
« Last Edit: November 23, 2007, 11:03:59 pm by posterberg »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4437
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: xine not playing dvds
« Reply #1 on: November 24, 2007, 08:32:19 am »
I tried to install the dvdcss package by running the script /usr/share/doc/libdvdread3/install-css.sh

The script executed just fine - but - now xine won't play any dvd's anymore...

It did complain, before, that libdvdcss wasn't installed if trying to play a comersial disc. Now it won't even do that...

I get a black screen when I try to play a dvd and then it just exits out to the Orbiter screen without errors... I did at least get the disc's main menu before...

I guess something got majorly broken when I ran that script... Is there any way to reinstall xine and it's components from scratch?

I've already tried apt-get install xine-ui and apt-get install libxine-extra-modules.... same black screen...

Any advice not including reinstall the whole system would be much apritiated! ;o)


---- NOTE ----

I've tried running Xine within KDE now and that works just fine... It even play that comersial disc,. This make me believe that the problem isn't really xine related but I don't know where to look... Are there any log anywhere that shows what happens when I try running a dvd from the Orbiter?

Hmmm... well installing libdvdcss directly from the console like you did should work fine... and I expect it has in reality as that script does not affect xine at all.

However... why didn't you try using the 'Add Software' screen from the Orbiter?
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

posterberg

  • Veteran
  • ***
  • Posts: 82
    • View Profile
Re: xine not playing dvds
« Reply #2 on: November 24, 2007, 09:26:57 am »
Well, new to this stuff - old unix fart ;o) know my way around the command prompt and found a howto for adding dvdcss with linuxmce, using google, that described using the script I used...

My system is undergoing reinstall now :-/

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4437
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: xine not playing dvds
« Reply #3 on: November 24, 2007, 10:07:38 am »
Well, new to this stuff - old unix fart ;o) know my way around the command prompt and found a howto for adding dvdcss with linuxmce, using google, that described using the script I used...

My system is undergoing reinstall now :-/

After reinstall... DVD I hope ;-)

Setup your core so that it has external network access etc as before... do the avWizard & setup Wizard etc (if installing from DVD you need to do that in Web Admin -> Advanced -> Network -> Network Settings after you have run the Wizards to setup external network access). Then after a 10-15 mins you should be able to go to 'Add Software' from the Orbiter... System -> Advanced -> Add Software. When in the Add Software screen you should see libdvdcss and W32 Codecs listed (if not then your Core has not picked up the config data for these yet... just wait as this is automatic but can take a little while)... just click on them to commence the install.

Now you should be able to play encrypted commercial DVD's without any problems ;-)

Hope the above helps

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk