Author Topic: UI2 with ABlending now with ATI?  (Read 959 times)

danielmayer

  • Regular Poster
  • **
  • Posts: 35
    • View Profile
UI2 with ABlending now with ATI?
« on: November 23, 2007, 11:51:50 am »
Hi, all,
does LMCE now run with the newest ati-drivers smoothly with ui2/ab? It supports composite and aiglx now, as it seems, so the alpha-blending should work.
Anyone tested this?
Server: Ubuntu 10.04A2, 1xL5520 on Asus Z8-PED12X, 12GB, 300GB U320Raid0, 8TB HDDs@Adaptec 2820SA + 8TB@Perc 5/E. LMCE via KVM (running); other VMs;
Workstation: W7x64, 2xOpteron 2376, 24GB, 146 GB-SSD-Raid0, ATI 4850
MD: Asrock nv630i, 2GB

danielk

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: UI2 with ABlending now with ATI?
« Reply #1 on: November 23, 2007, 05:53:33 pm »
I don't think it's been tested -- but the only special things the UI2 needs to support the Composite Extension with OpenGL, the Render Extension, and ARGB OpenGL surfaces.

AFAIK the alpha blending code in the Orbiter for nVidia cards is entirely standards compliant and any driver implementing this basic subset should work. When the code was first written the Xorg developers thought the Intel drivers would have support for this by Xorg 7.2.

Even if it is supported there is no guarantee that it will work well. UI2 runs but does so terribly on the GeForce 4 MX video card installed in one of my computers.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: UI2 with ABlending now with ATI?
« Reply #2 on: November 23, 2007, 08:56:26 pm »
...
Even if it is supported there is no guarantee that it will work well. UI2 runs but does so terribly on the GeForce 4 MX video card installed in one of my computers.
I think you might need the "older" nvidia driver-versions for those older cards to be supported properly, see also: http://wiki.linuxmce.org/index.php/Display_Drivers.
"Change is inevitable. Progress is optional."
-- Anonymous