Author Topic: Problems communicating using GC100 with a GSD  (Read 915 times)

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Problems communicating using GC100 with a GSD
« on: November 18, 2007, 09:15:23 am »
Hi gang

I'm having some trouble controlling my Denon receiver connected to a GC100.  The GC100 setup scripts are a little loopy with the new (3.0) firmware version, but I hacked around and managed to get gc-100-serial-bridge-sh functioning correctly.  It basically creates a socket to the GC100's serial port (at port 4999 on its IP address) and maps it to a serial device (/dev/TTYS_89_0) on the core.  Now, I can echo commands to the port and they work to control the device. For example, when I type:

Code: [Select]
echo -en "PWON\r" >> /dev/ttyS_89_0
It turns on.  The problem that I'm having is that, using the Denon AVR template, which has Ruby codes for the device, I can't get it to work.

Here's the command response:
Code: [Select]
Message Sent succesfully.
/usr/pluto/bin/MessageSend localhost -r 0 93 1 193 97 ""
Response was:
RESP: OKMessage Sent succesfully.
/usr/pluto/bin/MessageSend localhost -r 0 93 1 193 97 ""
Response was:
RESP: OK

The device number is 93.

The logs show:
 
Code: [Select]
31:05 11/17/07 23:54:09.742 GSDMessageTranslator isCmdImplemented = true <0xb6096b90>
05 11/17/07 23:54:09.743 #### Pre-Process Queue = 1 <0xb6096b90>
05 11/17/07 23:54:09.758 _QueueProc Pre - 193 : 0 <0xb7899b90>
05 11/17/07 23:54:09.758 GSD-Sleep Pre 193 : 0 <0xb7899b90>
05 11/17/07 23:54:09.759 Process Queue = 1 <0xb7899b90>
05 11/17/07 23:54:09.779 Parameter:  <0xb5895b90>
05 11/17/07 23:54:13.783 GSD-Sleep Post 193 : 4000 <0xb7899b90>
05 11/17/07 23:54:13.783 _QueueProc Post - 193 : 4000 <0xb7899b90>

Anyone have any ideas on where I go from here to debug?

Thanks,
-PeteK




PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: Problems communicating using GC100 with a GSD
« Reply #1 on: November 18, 2007, 09:19:24 am »
OK, nevermind.  It seems to be working now.  Hmm, weird things happen around midnight.  Cool.  Now to make it work with the squeezebox.

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: Problems communicating using GC100 with a GSD
« Reply #2 on: November 18, 2007, 12:47:11 pm »
That was easy.  I just set up the audio pipe and it's all happy now.  The stereo turns on when I start playing audio through the squeezebox.  I'll update the GC100 wiki with what I figured out for the GC100.