Author Topic: Specifying CD Rip Format?  (Read 2582 times)

Matthew

  • Douchebag
  • Addicted
  • *
  • Posts: 567
    • View Profile
Specifying CD Rip Format?
« on: November 14, 2007, 05:29:34 am »
I have ripped CDs from my VGP-XL1B CD/DVD jukebox. But the rips always produce OGG files. Where can I select the output format, like WAV?

I searched the forums and the wiki, but couldn't find where to set the format. I did see the posts discussing the bug that doesn't apply quality settings to the rips. And I see in the ripping script that it can take a paramater specifying the format. But I haven't seen where to set the format.

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: Specifying CD Rip Format?
« Reply #1 on: November 14, 2007, 06:07:50 am »
In the admnin web page, click "Installation." It's the first link under "Basic Settings"

Matthew

  • Douchebag
  • Addicted
  • *
  • Posts: 567
    • View Profile
Re: Specifying CD Rip Format?
« Reply #2 on: November 14, 2007, 05:40:01 pm »
Thanks. I have updated the Wiki entry on ripping.

There's lots of ripping params that are hardcoded in /usr/pluto/bin/ripDiskWrapper.sh that aren't available in the GUI. How can I edit the GUI to allow setting, say, all the commandline FLAC codec parameters as a single string, as well as structured fields like compression level?

Also, I really like that the ripping entry has both a "user's guide" and a "programmer's guide", rudimentary as it might be. If every function in the architecture had documentation of its layers - GUI, network/API, script, data - this project would be a lot more accessible to new people both adopting it and improving it.

I guess I could continue to update the Wiki that way as I learn my way around, but encouraging others to do so as they improve both the docs and the code would make us more productive :).

Matthew

  • Douchebag
  • Addicted
  • *
  • Posts: 567
    • View Profile
Re: Specifying CD Rip Format?
« Reply #3 on: November 15, 2007, 06:21:27 am »
Setting the rip format in the Admin website doesn't make the ripping actually use the format specified, even after core reloads and server reboots. Bug 3495
« Last Edit: November 15, 2007, 06:24:54 am by Matthew »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Specifying CD Rip Format?
« Reply #4 on: November 15, 2007, 11:55:07 am »
Setting the rip format in the Admin website doesn't make the ripping actually use the format specified, even after core reloads and server reboots. Bug 3495

If you choose mp3 in Web Admin... you need to have installed lame on the Core or the MD for rip to be in that format. Did you choose mp3?
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Matthew

  • Douchebag
  • Addicted
  • *
  • Posts: 567
    • View Profile
Re: Specifying CD Rip Format?
« Reply #5 on: November 15, 2007, 07:55:14 pm »
I have LAME, flac, sox, etc installed (by LMCE default installation).

I first switched the Admin website's Home -> Wizard -> Installation page Miscellaneous section settings from (installation default) ogg to flac, but ripping ("all" 3 in my VGP changer) produced Ogg files. I switched from flac to mp3, which ripping ("all" 3 in my VGP changer) still produced Ogg files.

Or so it seemed. Because when I tried to play the files, which always showed up as "trackname.ogg", no matter what I set the format to, they wouldn't play. I used the "play" commandline, which detects formats, but it rejected every format except MP3 (which I specified by renaming files to .wav , .flac , .mp3 and by specifying -t <type> on the commandline). When telling play the file is MP3, it played, but only a few seconds of squealy noise (the files are the right length for several minutes in any format). I tested only the files generated by setting the format to wav and to mp3, I'm not certain that "wav" files (still named .ogg by the ripper) were encoded wrong, though I didn't test them either way.

Then I changed the format settings to wav, and used the jukebox's "Manage drive" to rip just a single CD. It ripped everything into files named .flac , which I tested OK as actual FLAC files. I used the Jukebox's "Manage drive" to "rip all" (3 discs), which were again ripped to unreadable .ogg files. When I left the format settings the same (wav) and then ripped a single disc again (after deleting the "rip all" .ogg files from the filesystem and the entries from the database), they ripped into FLAC. So the "rip" and "rip all" codepaths are clearly different, with the "rip all" somewhat better, but both suffering from serious bugs.

When I delete ripped CDs, which I can do only from the commandline (or Kubuntu desktop), I use the Admin website's Home -> Files & Media -> Media Files sync. When I click "Resynchronize", it fails, with the "Cannot find self in maplock!" message as in Bug 3538.
Sometimes the dump shows fewer successful completed steps, but always the "Cannot find self in maplock!" and "alarm: AlarmManager.cpp" message.
« Last Edit: November 15, 2007, 07:58:52 pm by Matthew »