Author Topic: No Internet Connection  (Read 913 times)

rocco

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
No Internet Connection
« on: November 07, 2007, 06:15:51 pm »
I recently installed LinuxMCE, I did not have the computer connected to the cable modem during the installation.  I have 2 Ethernet cards installed.  I now after install have tried to connect to the internet directly to the cable modem with no luck.  I rebooted with the eth0 ethernet connected to the modem and nothing, I have not tryed eth1 as I understand that this is where my internal network would connect when using LinuxMCE as the DHCP server.  I  would also like to keep the Windows machines and the LinuxMCE machines on seperate networks in the future, one serving up media (linux) and the other for internet trafic (Windows). Is this possible without 2 cable modems?

Back to my inital problem, I am new to Linux, do I need to reinstall or is there a fix, where can I find info to better diagnose the problem?

Rocco ???

mikesignguy

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: No Internet Connection
« Reply #1 on: November 08, 2007, 06:52:58 pm »
most likely there is a fix
goto the KDE desktop


.... look at the MCE center and you should see a button is the center of the view that says "show my ip"
or something similiar

are all the blocks to the right of the titles filled in....if not which r empty

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: No Internet Connection
« Reply #2 on: November 09, 2007, 08:29:51 am »
There is a sollution  ;)

(from memory, so the actual button names may be slightly different)
You need to findt the listed 'eth's in the web admin, either under network setup or under device settings for the core.
Then change one of the 'eth's to say DHCP instead of the IP it currently has, that sets it up to receive a DHCP IP from the router.
You may have to apply changes/save a couple of times, and possibly also reboot, but it should work.

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: No Internet Connection
« Reply #3 on: November 09, 2007, 08:31:40 am »
And I use the LMCE box as DHCP for the whole house, Windows PCs, XboX 360, the works. No problems at all (unless you reboot the core often, as during an install)