Author Topic: nvidia support  (Read 1998 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« on: September 14, 2005, 12:12:43 pm »
Any chance you guys could patch the kernel as when i try to get the nvidia kernel driver to load and work with x (so i can use the tv out on my gf6600gt) i'm getting these two errors
Unknown symbol VMALLOC_RESERVE
Unknown symbol pci_find-class


From reading this help page i need to patch the kernel.
newbielink:http://home.comcast.net/~andrex/Debian-nVidia/troubleshooting.html [nonactive]
I think i've downloaded all the sources and bit, and tryed to follow whats ment to be done. but my custom kernel won't boot:(

Besause of this i'm getting really bad dvd playback


[/url]

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #1 on: September 17, 2005, 06:37:10 pm »
i still cant work this out. i just cant seem to get xv support in X, without it my video play back is really poor. Been going round in circles, might try an older nvidia card and see if i have any more luck, or even a ati card.

What graphics cards do peope have in their MD boxes???

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #2 on: September 17, 2005, 07:36:43 pm »
Hi There...

Well, for the record, I can't get the ATI X850 PE working either...

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #3 on: October 06, 2005, 12:19:00 pm »
still no joy. Tryed to compile using 2.0.0.30, not even managing to get the driver to compile, think theres something wrong with the kernel sources, getting some cant find files..

>> m-a prepare
( downloads  kernel-headers-2.6.13.2-vanilla-pluto-1-686 )

>> m-a auto-install nvidia
(starts to build the nvidia kernel )

/usr/src/kernel-headers-2.6.13.2-vanilla-pluto-1-686/scripts/gcc-version
No such file or directory

And then stops.

really really want my 6600gt to work :(

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #4 on: October 21, 2005, 08:44:39 am »
Kernel sources that you can actually use to build your modules are here: newbielink:http://ftp://ftp.plutohome.com/pub/ [nonactive]. You'll have to change the build and source links in /lib/modules/2.6.13.2-vanilla-pluto-1-686 to point to the directory in the archive.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #5 on: October 27, 2005, 03:38:58 am »
sp00nhead -

For every Debian kernel package there is typically a kernel header package that is available to match it. This allows the user or programs like module-assistant (m-a) to compile kernel modules against it without having to down load the entire source tree.  If this package is not available (radu.c ??) then you need to download the kernel source you are using and compile against your current config.

hopefully I won't leave anything out, try these steps:

download the kernel tarball from ftp.plutohome.com/pub to /usr/src/

expand tarball  . . .  should give 'kernel-source-2.6.13.2-vanilla-pluto' dir

create symlink:  ln -s kernel-source-2.6.13.2-vanilla-pluto linux

cd linux

Copy current config:
cp /boot/config-2.6.13.2-vanilla-pluto-1-686 .config

Compile kernel:
make
(if you are compiling the kernel to install I would suggest using make-kpkg to create nice .deb's, but to prepare kernel source to cross-compile a module against its not needed)  (also use of fakeroot here is usually recommended)

I think once this is done m-a should work from the point:
>> m-a auto-install nvidia


This is all just off the top of my head, YMMV . . . .

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
nvidia support
« Reply #6 on: October 27, 2005, 09:45:32 am »
cheers for the tips.
What i've found work is make the kernel, then the nvidia module
This for some reason leaves me with a non-working module. But i then download the offical Nvidia linux drivers off their site and run that. it uses the kernel sourses to compile and leaves me with a nice working system

Now i only have the problem that i can't regen my orbiters, getting loads of errors, think i've screwed up my database when i was playing with the skin editor :(

Ah, the wonders of linux and open sourse development :)