Author Topic: orbiter power-off not working  (Read 1581 times)

toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
orbiter power-off not working
« on: October 30, 2007, 01:55:02 pm »
Hi,

have a touchscreen via usb (ELO product) and got it working so far. The problem ist that the power-off function seems to be ignored and the screen-saver is shown for days (but I didn't change anything in the configuration of orbiter manually - all is default).

So I start to KDE, open System Settings -> Monitor & Display and activate Power-Off function there. Now the power-off works. BUT after a reboot the screen resolution is screwed totally. The MediaDirectory setting for "Video Setting" says 2048 1536/60 but 800 600/60 would be the one I did chose before. Even KDE desktop isn't shown properly anymore (only part of the screen so that I cannot turn power-off anymore). FullRegen doesn't do a change either. I can set manually the Video Setting to 800 600/60 but after a reboot it's somehow automatically changed to 2048 1536/60 again.

Hope anybody has idea which could help me, thx in advance
Thomas

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: orbiter power-off not working
« Reply #1 on: October 30, 2007, 04:10:41 pm »
orbiter power-off is primarily meant to send an IR signal to a TV to turn it off. It works either with IR or serial control. It is possible to write a DPMS DCE device, and somebody might soon..but it's currently not supported.

-Thom

toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: orbiter power-off not working
« Reply #2 on: October 30, 2007, 04:46:48 pm »
thank you for reply...

maybe I missed some information:
the touchscreen display is MediaDirector & Orbiter. I use a HP ThinClient and ELO touchscreen.

is it really that the screen has to run 24h on the screensaver images in current version?

and why the resolution screws up when I activate the power off in system settings... can that be prohibited?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: orbiter power-off not working
« Reply #3 on: October 30, 2007, 05:13:38 pm »
again... if you use power off from the orbiter's power menu.. all it does is send a command to the connected display to turn it off.. If it knows how to do this, it will.... it is meant for TVs that you have an IR transmitter or RS232 control attached to.

As for your resolution issues, I am unsure.

-Thom

toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: orbiter power-off not working
« Reply #4 on: October 30, 2007, 05:32:37 pm »
thx, didn't want to make you mad, sorry if I did

I tried now with a normal PC monitor. Tried to put
Option "offtime" "3"
into xorg.conf - ServerLayout section like some thread recommend - and there I have the same behaviour

power-off is working well then - but the resolution is blown up... the LMCE manager window shows only in parts and the fonts are shown in huge letters...

hope anybody can point me to something helpful

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: orbiter power-off not working
« Reply #5 on: October 30, 2007, 06:20:49 pm »
Try to run the AVWizard again, if that fails I suggest setting up the xorg.conf file manually.
"Change is inevitable. Progress is optional."
-- Anonymous


toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: orbiter power-off not working
« Reply #6 on: October 30, 2007, 10:32:49 pm »
did that... display is cool now again - but the offtime option seems to be overridden although it's still there in xorg.conf - however monitor doesn't go to standby

toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: orbiter power-off not working
« Reply #7 on: November 08, 2007, 10:57:46 pm »
tested and tried many things since my first post and I got a bit further, hope somebody can help me with the rest:

what my situation is like:
my station start directly MediaStation and Orbiter. When I start KDE desktop from LinuxMCE and there in a console window type "xset dpms 20 20 20" and click in taskbar on the LinuxMCE tab to return to orbiter screen, then after 20sec the monitor really powers off!

The question now is if I can automate this command. As KDE normally is not started I don't know where to put that line. Running it from another terminal not within KDE brings error (think because it isn't connect to xserver there because initlevel too low.. ).
can somebody help me with that?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: orbiter power-off not working
« Reply #8 on: November 09, 2007, 12:17:05 am »
Cool, according to the man page xset has the -display option, that should allow you to run it from outside of X.
"Change is inevitable. Progress is optional."
-- Anonymous


toko

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: orbiter power-off not working
« Reply #9 on: November 10, 2007, 11:36:51 am »
hehe, yeah that worked. using "xset -display :0 dpms 20 20 20" does monitor standby after 20sec and can be run from terminal.

however this setting seems to be reset to off-state at start of orbiter. But when I run that statement after orbiter is fully started and monitor keeps on all the time.
For now I solved that via a cronjob which runs that statement every 30min. or so...
would there be a place where I can put this statement so that it's run only once at the end of orbiter launch?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: orbiter power-off not working
« Reply #10 on: November 13, 2007, 03:21:25 am »
As I was grepping through the source, I figured I might as well have a look to see if I can find where dpms is being turned off:
Code: [Select]
LinuxMCE-1.1-SRC/src/Orbiter/SDL/StartOrbiterSDL.cpp:45:    system("/usr/bin/X11/xset -display :0 -dpms s off");

So it looks like it shouldn't be to hard to fix this so that the orbiter doesn't turn dpms off on startup. ;)

EDIT: I have put this in mantis #0003649, hopefully it will be picked up on.
« Last Edit: November 16, 2007, 03:58:10 pm by Zaerc »
"Change is inevitable. Progress is optional."
-- Anonymous