Author Topic: [SOLVED] Disable pc speaker beeping  (Read 754 times)

RockHound

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
[SOLVED] Disable pc speaker beeping
« on: October 28, 2007, 01:57:27 pm »
How do I disable the "Listening for Button 1" beeps or any PC speaker stuff for that matter? Just remove the module pcspkr? It's really annoying when you are frequently rebooting while testing things.

Any advice is appreciated.

Kind regards,

Martin
« Last Edit: October 28, 2007, 05:38:38 pm by RockHound »

acematti

  • Veteran
  • ***
  • Posts: 50
    • View Profile
Re: Disable pc speaker beeping
« Reply #1 on: October 28, 2007, 03:13:09 pm »
You could unclip the PC speaker from the motherboard as a last resort.

I dont have one on my system.

Just a thought for you to consider.

RockHound

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Disable pc speaker beeping
« Reply #2 on: October 28, 2007, 04:20:38 pm »
Then I would not have any beeps on post errors ... so I am not considering this.

Thx anyhow.

rafik24

  • Guru
  • ****
  • Posts: 158
    • View Profile
Re: Disable pc speaker beeping
« Reply #3 on: October 28, 2007, 05:03:10 pm »
rmmod pcspkr will do the job

RockHound

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Disable pc speaker beeping
« Reply #4 on: October 28, 2007, 05:38:03 pm »
Those of you looking for a permanent way of doing the above, don't let the system load this module while booting via:

Code: [Select]
sudo echo "blacklist pcspkr" >> /etc/modprobe.d/blacklist
Cheers,

Martin