Author Topic: [Fixed] Core-only install won't autostart  (Read 1336 times)

dukat

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
[Fixed] Core-only install won't autostart
« on: October 23, 2007, 10:24:11 pm »
Hi,

after I installed a dedicated core, I would like to have it autostart on every boot. According to the install wiki, a text mode GUI should appear on boot, but it doesn't at my system. Instead, I have to log into my system, start X automatically, and then launch the core. I'd much appreciate a core without X, so the console GUI would be perfect. Any ideas?

/dukat
« Last Edit: October 28, 2007, 12:23:39 pm by dukat »

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Core-only install won't autostart
« Reply #1 on: October 24, 2007, 12:04:11 am »
Hi,

after I installed a dedicated core, I would like to have it autostart on every boot. According to the install wiki, a text mode GUI should appear on boot, but it doesn't at my system. Instead, I have to log into my system, start X automatically, and then launch the core. I'd much appreciate a core without X, so the console GUI would be perfect. Any ideas?

/dukat

Where exactly did you read that in the wiki?  Because that part is incorrect and definately needs to be updated.

The only way I know of to do what you want is a hack that is documented here: http://wiki.linuxmce.org/index.php/Clean_Core

"Change is inevitable. Progress is optional."
-- Anonymous


dukat

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Core-only install won't autostart
« Reply #2 on: October 24, 2007, 10:35:45 am »
Where exactly did you read that in the wiki?  Because that part is incorrect and definately needs to be updated.

The only way I know of to do what you want is a hack that is documented here: http://wiki.linuxmce.org/index.php/Clean_Core

The Console GUI screenshot is at
http://wiki.linuxmce.com/index.php/Getting_Started#Configuration

If it's outdated, it surely should be removed.
I didn't know about the other wiki link you posted. Thanks for that, I'll have a look. But I find it really strange, that a dedicated core should be missing the autostart feature. I thought dedicated cores are also commercially sold, and I can't believe this feature would be lacking there ....

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Core-only install won't autostart
« Reply #3 on: October 24, 2007, 04:54:27 pm »
...
But I find it really strange, that a dedicated core should be missing the autostart feature. I thought dedicated cores are also commercially sold, and I can't believe this feature would be lacking there ....


The feature isn't lacking, you just chose "mainly used as PC", which starts up with KDE where by default you have to log into the desktop first, this can be changed to log in automaticly at boot but you will have to configure that in the KDE DEsktop settings I reckon.

The "dedicated MCE" option (during installation) starts a bare graphic environment with the lmce-launch manager and can start lmce without having to log in first.  So either way you won't have a simple text console after boot. 

I hope that clears things up a bit for you.

"Change is inevitable. Progress is optional."
-- Anonymous


dukat

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Core-only install won't autostart
« Reply #4 on: October 24, 2007, 07:19:16 pm »
Thanks for the reply!

I'm quite sure (so at about 99.5%) that I chose the "use primarily as MCE" option, and I didn't get the autostart feature. Maybe it's a bug? Any advice how I could manually change that?

Are you sure that there's no text GUI as shown in the wiki? If so, I'd try to remove the pic from the Wiki (don't know if I have access).

dukat

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Core-only install won't autostart
« Reply #5 on: October 28, 2007, 02:30:28 am »
Anybody knows what to modify to get at least the graphical core autostart back to working?

dukat

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Core-only install won't autostart
« Reply #6 on: October 28, 2007, 12:23:06 pm »
Found it myself :-)

Just added
/usr/pluto/bin Startup_CoreHybrid.sh into /etc/rc.local and I got it working. The name of the startup script was a bit misleading, though.