Author Topic: Source code install, amd64, build failure w/ libsdl-pluto  (Read 870 times)

needlern32724

  • Newbie
  • *
  • Posts: 10
    • View Profile
Source code install, amd64, build failure w/ libsdl-pluto
« on: October 20, 2007, 01:08:21 am »
My first post to these forums, sooooo, I'm a 9 year user of linux (RH-5.1 originally). Last 5 years with gentoo. Built a new box with an Asus-A8N-E (amd64) board a year and a half ago to install MythTV on. Got side tracked. Just discoverd LinuxMCE.

Downloaded the two kubuntu cd's and the 2 MCE cd's. Kubuntu installed perfectly. Tried many ways, though not yet the quick install dvd, to install mce. Could not get anywhere. Downloaded the source code and fired it up. Made it pretty far through, I think.

It bombs out here:
Code: [Select]
./BuildUbuntu.sh: line 81: pushd: /var/plutobuild/svn/trunk/ubuntu/libsdl1.2-1.2.7+1.2.8cvs20041007/: No such file or directory  From the BuildUbuntu.sh script these lines surrounding line 81:
Code: [Select]
#Package: libsdl-pluto
apt-get -y install quilt nasm libxv-dev libarts1-dev debhelper fakeroot
apt-get -y install dbs libaa1-dev libslang2-dev xlibs-dev libsvga1-dev type-handling automake1.7
pushd ${svn_dir}/trunk/ubuntu/libsdl1.2-1.2.7+1.2.8cvs20041007/        [b]<--------------line 81[/b]
dpkg-buildpackage -us -uc -rfakeroot -b
dpkg -i ../libsdl1.2debian-pluto-all_1.2.7+1.2.8cvs20041007+pluto-2_i386.deb
dpkg -i ../libsdl1.2debian-pluto_1.2.7+1.2.8cvs20041007+pluto-2_i386.deb
dpkg -i ../libsdl1.2-pluto-dev_1.2.7+1.2.8cvs20041007+pluto-2_i386.deb
cp ../libsdl1.2*-pluto-*.deb ${temp_dir}
popd
I'm an utter noob to anything .deb, Any help or pointers appreciated. If I must, I will try the quick install dvd, though I would rather not.

TIA,
Bill

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: Source code install, amd64, build failure w/ libsdl-pluto
« Reply #1 on: October 20, 2007, 07:18:31 am »
The build scripts currently are not made for the current 0704 or upcoming release. They will not work properly.

As for the problems with the quick install CD and DVDs, can you be more specific as to what happened?

-Thom

needlern32724

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Source code install, amd64, build failure w/ libsdl-pluto
« Reply #2 on: October 20, 2007, 09:08:17 pm »
Thanks for the reply, Thom. I've gone on and installed from the quick install dvd. I'm going to close out on this thread and post a new problem brought up by the dvd install.

Bill