Author Topic: Myth-tv outdated and need to update to newest  (Read 1643 times)

fearingsept

  • Guru
  • ****
  • Posts: 369
    • View Profile
Myth-tv outdated and need to update to newest
« on: October 15, 2007, 06:33:05 pm »
I just installed LMCE on the actual Machine that I will be using as my core/hybrid. Instead of the DVD I used the CD's because for some reason either my DVD burner or my system just didn't like the DVD. Everything for the most part is working but I am unable to configure my Myth TV program guide because it is still trying to pull the data from Zap it. On the other installs this was automatically updated after the install process. It doesn't seem to want to pull down the latest updates, any suggestions?
Core: Broken :(

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #1 on: October 15, 2007, 06:35:13 pm »
go to the advanced page under the Advanced menu on the orbiter.. select Force Updates Now.. this will cause the newest updates to be fetched and installed when the system reboots. After which, you should have your schedulesdirect.org updates...


or, you could wait 24 hours.

-Thom

fearingsept

  • Guru
  • ****
  • Posts: 369
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #2 on: October 15, 2007, 06:44:36 pm »
Quote
go to the advanced page under the Advanced menu on the orbiter.. select Force Updates Now.. this will cause the newest updates to be fetched and installed when the system reboots. After which, you should have your schedulesdirect.org updates...

yeah, I did that, but it seems like nothing happens... does it normaly take a long time to actually run updates? Maybe a status bar or a "checking for updates" splash.
Core: Broken :(

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #3 on: October 15, 2007, 07:51:14 pm »
The update you need does take a long time to download, and LMCE will only notify you that an update is available to install when it has downloaded.

You can download and install updates from the KDE Konsole:

cd /usr/pluto/bin
./LMCEUpdate_DownloadXml.sh
./LMCEUpdate
(takes some time, but when complete...)
./LMCEUpdate_Apply.sh
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

fearingsept

  • Guru
  • ****
  • Posts: 369
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #4 on: October 15, 2007, 08:46:52 pm »
Quote
The update you need does take a long time to download, and LMCE will only notify you that an update is available to install when it has downloaded.

You can download and install updates from the KDE Konsole:

cd /usr/pluto/bin
./LMCEUpdate_DownloadXml.sh
./LMCEUpdate
(takes some time, but when complete...)
./LMCEUpdate_Apply.sh


Thank you, that worked and my system is updating.
Core: Broken :(

EnderWiggin1001

  • First post!
  • Posts: 1
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #5 on: October 26, 2007, 07:26:48 pm »
Quote
The update you need does take a long time to download, and LMCE will only notify you that an update is available to install when it has downloaded.

You can download and install updates from the KDE Konsole:

cd /usr/pluto/bin
./LMCEUpdate_DownloadXml.sh
./LMCEUpdate
(takes some time, but when complete...)
./LMCEUpdate_Apply.sh

This is what I get when I attempt to run the commands shown above. Am I missing a step?


linuxmce@dcerouter:~$ cd /usr/pluto/bin
linuxmce@dcerouter:/usr/pluto/bin$ ./LMCEUpdate_DownloadXml.sh
linuxmce@dcerouter:/usr/pluto/bin$ LMCEUpdate
LMCEUpdate, v.1
Visit newbielink:http://www.linuxmce.com [nonactive] for source code and license information

Fri, 26 Oct 2007 03:04:37 -0700 Helper Script Started
/usr/pluto/bin/LMCEUpdate_Helper.sh: line 12: /var/log/pluto/UpdateHelper.log: Permission denied
05      10/26/07 3:04:37.433            Update check: CHECK_UPDATE 1
 <0xb783d8e0>
05      10/26/07 3:04:37.434            IOError: check updates <0xb783d8e0>
01      10/26/07 3:04:37.434            Updates manager failure. <0xb783d8e0>
linuxmce@dcerouter:/usr/pluto/bin$




gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #6 on: October 27, 2007, 06:11:32 pm »
There is a permissions problem from what I can see.
Try running the download command as root. i.e.

sudo ./LMCEUpdate_DownloadXml.sh
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

mikesignguy

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #7 on: November 06, 2007, 04:12:53 pm »
the correct commands are:

 

cd /usr/pluto/bin
sudo ./LMCEUpdate_DownloadXml.sh
sudo ./LMCEUpdate
(takes some time, but when complete...)
sudo ./LMCEUpdate_Apply.sh

there are a lot of postings to show how to manually update  and it is a bit confusing
this is the closest to being noobie proof
..thanx gaxlang

mark it solved and maybe stickie
« Last Edit: November 06, 2007, 04:16:53 pm by mikesignguy »

mikesignguy

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #8 on: November 06, 2007, 04:25:39 pm »
now i got a MD5 sum error for update001.tar

#Update download: FAIL MD5 sum does not match

<description>Update mythtv packages from the Core to work with SchedulesDirect.</description>
                <priority>1</priority>
                <model>LMCE_CORE_1_1</model>
                <file
                        URL="http://updates.linuxmce.com/update001.tar"
                        action="untar"
                        destination="/tmp/update001"
                        md5="e9f1cf48cc688bbb223981d0df4e52f1"
                        size="413168"
                        autoexec="/tmp/update001/install-update.sh

the file i downloaded is 42266
i deleted tar001.tar and ran it again ... nothing

grepico

  • Veteran
  • ***
  • Posts: 102
    • View Profile
Re: Myth-tv outdated and need to update to newest
« Reply #9 on: January 31, 2008, 08:17:03 pm »
Tried the manual update instructions and I get this when running the second command.

dcerouter_55697:/usr/pluto/bin# sudo ./LMCEUpdate
LMCEUpdate, v.1
Visit www.linuxmce.com for source code and license information

Thu, 31 Jan 2008 11:14:18 -0800 Helper Script Started
I/O warning : failed to load external entity "/home/updates/updates.xml"
01      01/31/08 11:14:18.777           Failed to parse xml /home/updates/updates.xml <0xb77fe8e0>
05      01/31/08 11:14:18.777           UpdatesManager::init : XML parser error <0xb77fe8e0>
01      01/31/08 11:14:18.777           Updates manager failure. <0xb77fe8e0>
Thu, 31 Jan 2008 11:14:18 -0800 RECV :
dcerouter_55697:/usr/pluto/bin# Thu, 31 Jan 2008 11:14:18 -0800 Helper Script End